CCC LED Hotkey MOD for P870xMx (and possibly other models too)

Discussion in 'Sager and Clevo' started by j95, Nov 13, 2017.

  1. Chastity

    Chastity Company Representative

    Reputations:
    1,183
    Messages:
    6,260
    Likes Received:
    147
    Trophy Points:
    231
    My biggest niggle with the CCC is that the windows scale automatically to the screen, which is a problem for me since I dock to a 4K screen, and the damn app always wants to open to the master screen. I'd like to open the app, and use it on the laptop's 1080p screen, but once it opens on the 4K screen, it's too huge for the 1080p one. Workaround is to make the 1080p one Master, open the app, then switch back to 4K as Master.

    Anyone know a way to make it not scale to screen?
     
    Stress Tech likes this.
  2. j95

    j95 Notebook Deity

    Reputations:
    2,049
    Messages:
    1,405
    Likes Received:
    1,091
    Trophy Points:
    181
    Did you follow OP instructions? Brightness is working fine here...when you're done; hit 'save'.
     
    cj_miranda23 likes this.
  3. cj_miranda23

    cj_miranda23 Notebook Evangelist

    Reputations:
    230
    Messages:
    421
    Likes Received:
    334
    Trophy Points:
    76
    Is it a normal behavior the default blue color will load whenever the computer is shut down then turn on again?

    I have to run the gamefeet.exe manually to load the profile that i made when I installed the mod.


    Sent from my iPhone using Tapatalk
     
  4. j95

    j95 Notebook Deity

    Reputations:
    2,049
    Messages:
    1,405
    Likes Received:
    1,091
    Trophy Points:
    181
    Yes, though lid should stick for a few seconds.
    Nope, Hotkey task (Hotkey3.exe) will load your last saved profile.

    Copy Hotkey folder to "C:\", otherwise Hotkey task (Hotkey.xml) will fail to run.
    [​IMG]

    [​IMG]

    If the above is correct, then change 'delay task' to 20 sec.
    [​IMG]

    AV messing w/ Hotkey3.exe process. Scan files and/or add Hotkey3.exe & GameFeet_start.exe to AV's exclusions list.
     
    Last edited: Dec 20, 2017
  5. j95

    j95 Notebook Deity

    Reputations:
    2,049
    Messages:
    1,405
    Likes Received:
    1,091
    Trophy Points:
    181
  6. cj_miranda23

    cj_miranda23 Notebook Evangelist

    Reputations:
    230
    Messages:
    421
    Likes Received:
    334
    Trophy Points:
    76
    Sorry for the late reply but unfortunately it's still the same even excluding the exe files in my antivirus. I don't know what I did wrong but when I checked the schedule task the hotkey.exe run successfully.

    hotkey.jpg


    [​IMG]
     
    Last edited: Dec 21, 2017
    j95 likes this.
  7. j95

    j95 Notebook Deity

    Reputations:
    2,049
    Messages:
    1,405
    Likes Received:
    1,091
    Trophy Points:
    181
    Did you by any chance disable "PowerBiosServer" service? If so, set startup type to "Automatic" and then manually start the service (services.msc).

    Open task scheduler and run Hotkey task. Hotkey3.exe will stop the aforementioned service right after loading your profile.
     
    Last edited: Jan 31, 2018
    cj_miranda23 likes this.
  8. cj_miranda23

    cj_miranda23 Notebook Evangelist

    Reputations:
    230
    Messages:
    421
    Likes Received:
    334
    Trophy Points:
    76
    I did that w/ the exception of turning the PBS to automatic since it's already set and after running the hotkey thru TS the color profile I chose loaded. Unfortunately I tried if it will load again when I shutdown my computer the result is not perfect since 1/3 of the keyboard specifically the numerical pads is lighted w/ the default blue color:oops:

    is there a way to change this w/o reinstalling the mod?
     
    j95 likes this.
  9. j95

    j95 Notebook Deity

    Reputations:
    2,049
    Messages:
    1,405
    Likes Received:
    1,091
    Trophy Points:
    181
    No need to reinstall anything. Leave PBS to automatic start.

    RS3/1709 new startup behavior is messing things up and/or AV is still interfering with the process, depending on the AV, many times whitelisting processes makes matters worse.

    TS try changing "Delay Task" to 25 sec -> 30 sec.
     
    Last edited: Dec 21, 2017
    Vasudev, Papusan and cj_miranda23 like this.
  10. cj_miranda23

    cj_miranda23 Notebook Evangelist

    Reputations:
    230
    Messages:
    421
    Likes Received:
    334
    Trophy Points:
    76
    Everything is fine now! Delay task remains 20 sec. Thank you!
     
    Vasudev, j95 and Papusan like this.
Loading...

Share This Page