Can I stop the screen resolution stretching?

Discussion in 'HP' started by Cogitatus, Feb 14, 2007.

Thread Status:
Not open for further replies.
  1. Cogitatus

    Cogitatus Notebook Geek

    Reputations:
    24
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    15
    I just got my first HP laptop (a dv6000t) and I have a widescreen-related question:

    Basically, I want to play full-screen games at 1024x768 resolution without stretchng them to 1280x800 -- in other words, I want to see the black borders on my screen. I have an nVidia Go 7400 on Vista Home Premium, and the XP solutions I've already searched for on this forum don't seem to be available to me. My Dell laptop had a keyboard toggle for this (fn+F7) which was pretty convenient, but I have yet to find anything similar on my HP.

    So my question is: is there a similar screen resolution toggle on my HP laptop? Or, failing that, is there a way I can get Vista to stop stretching my 4:3 fullscreen programs to the widescreen resolution?

    (My only other option seems to be playing my games in a window, but I'm not sure if I have the RAM for that.)

    Thanks in advance.
     
  2. JM

    JM Mr. Misanthrope NBR Reviewer

    Reputations:
    4,370
    Messages:
    2,182
    Likes Received:
    8
    Trophy Points:
    56
    I've gotten the black bars you refer to to show up on my dv2000t, but I can't remember how the heck I did it...

    Lemme try a few things on my notebook and see if I can figure it out.
     
  3. solmnc

    solmnc Notebook Consultant

    Reputations:
    13
    Messages:
    162
    Likes Received:
    1
    Trophy Points:
    30
    i would love to know this as well.
     
  4. DarkJedi

    DarkJedi Notebook Enthusiast

    Reputations:
    1
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    15
    Easy.

    1. Open up your Nvidia Display Properties
    2. Go to the Digital Flat Panel Settings
    3. Choose Fixed Aspect Ratio Scaling

    I tested this with several games at 1024x768 on my widescreen dv2000t and the black bars appeared on both sides. Everything else remains in widescreen display.

    Edit: I'm running XP. Not sure if this works with Vista.
     
  5. inm8#2

    inm8#2 Notebook Deity

    Reputations:
    295
    Messages:
    762
    Likes Received:
    324
    Trophy Points:
    76
    Hi,

    I have a side question - my dv2000t with nvidia geforce go 7200 seems to be missing a lot of options in the control panel. THe only two things I can change are 3d settings and multiple display options. I would think more options would be available. Any ideas?

    Thanks.
     
  6. DarkJedi

    DarkJedi Notebook Enthusiast

    Reputations:
    1
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    15
    What drivers are you using? I'm using the stock 84.64 drivers for my Go7200 provided by HP. If you're using those, make sure when you go into the settings for the Nvidia display properties you click the arrow in the little green box along the left edge to expand your other settings. Don't ask me why they couldn't just create tabs.
     
  7. Cogitatus

    Cogitatus Notebook Geek

    Reputations:
    24
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    15
    I'm in the same boat, inm8#2 -- after having two laptops with ATI cards, I'm pretty apalled at the lack of control options offered by nVidia. And DarkJedi, I'm running the stock (for me) 97.46 driver, and when i click on that little green arrow on my advanced video properties, it brings up a blank white box that says Launch Page and nothing else. I think it's a vestige from an older version, though, because I do at least have the nVidia control panel available on the same page -- for what it's worth. The nVidia control panel allows me to rotate my display (would be cool, if I had a tablet) and mess with the 3D settings I usually just let the programs mess with, and that's about it.

    I still haven't found a way to stop the automatic screen resizing for smaller resolutions on my HP dv6000t under Vista. There has to be a way, though. Anyone?
     
  8. Cogitatus

    Cogitatus Notebook Geek

    Reputations:
    24
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    15
    So are there no solutions for this? Dell computers have a keyboard toggle that allows the user to choose to stretch smaller screen resolutions to the native panel resolution or show the actual pixels (with black bars). I want to do the same thing: show a 1024x768 fullscreen program on my HP dv6000t 1280x800 widescreen display at the actual pixels, without stretching.

    There has to be a way, because LCD screens want to show the actual pixels natively and have to be forced to stretch. So what is it? Is there a similar hardware-based screen toggle on the HP? Anything in the BIOS? Does the 100.64 beta driver from nVidia support this (finally)? Anyone? Anyone? Buehler?
     
  9. mtor

    mtor Notebook Deity

    Reputations:
    41
    Messages:
    1,031
    Likes Received:
    0
    Trophy Points:
    0


    Thank so much. I gave you rep.
     
  10. Cogitatus

    Cogitatus Notebook Geek

    Reputations:
    24
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    15
    It doesn't work with Vista, if you're talking about Display Settings > Advanced Settings > Adapter > Properties. There are no changeable options on any tabs of the nVidia properties window. I've read on the lv2go forums that scaling is back with the 100.64 beta driver (in some way), so I guess if I want fixed aspect scaling on my laptop I have no choice but install that and hope that it works with all my software.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page