Can I disable AHCI on Vaio Z BIOS ?

Discussion in 'VAIO / Sony' started by pizzicato, Oct 27, 2009.

Thread Status:
Not open for further replies.
  1. nass9500

    nass9500 Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    I reinstalled windows seven for it
     
  2. psyq321

    psyq321 Notebook Evangelist

    Reputations:
    193
    Messages:
    416
    Likes Received:
    4
    Trophy Points:
    31
    This is an age-old problem with Windows - basically Windows loads only current storage drivers (in most cases, those are the drivers installed during the setup process, or Intel Matrix Storage AHCI driver, for those that upgraded the driver with Intel's one).

    So, if you change your IDE controller (changing from AHCI to IDE and vice versa does just that) you are going to have problems booting because the correct driver is not loaded, and Windows Kernel cannot access the files on the system volume.

    I remember that beta versions of Windows Server 2008 R2 loaded all storage drivers at the beginning to avoid this - I thought they are also going to do the same in Win 7 - but it seems I was mistaken.

    Anyway, in order to get Windows to work, you need to activate the "old" IDE drivers - If I remember correctly, the drivers are:

    pciide.sys, pciidex.sys, atapi.sys, intelide.sys (I might forgot some - also, if you are using non-Intel IDE controller the drivers are different)

    Try booting in Recovery Console (starts Windows "Setup") , start regedit (from the console), mount the system registry hive (it is in [YOUR_SYSTEM_DRIVE]/WINDOWS/System32/Config - file name is SYSTEM) and change the startup behavior for those drivers.

    They are in ControlSetXXX/Services/[DRIVER_NAME] inside registry hive

    You need to set the Start DWORD value to 0x00000000
     
  3. achau

    achau Notebook Geek

    Reputations:
    7
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    15

    Thanks for your advice. It works now.
     
  4. achau

    achau Notebook Geek

    Reputations:
    7
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    15
    Are you using Intel X25-M? If you are using X25-M, did you installed the new firmware? I followed psyq321's advice to boot into Windows 7 using IDE mode. Unfortunately, I cannot get your result. What disk driver are you using? Maybe I need to reinstall Windows 7 to try again. Your 4K write is very good. That's the performance of desktop computer.
     
  5. nass9500

    nass9500 Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    yes I have the intel x25-M 80gb. I used the new firmware. you must reinstall Windows 7.
     
  6. Evoss-X

    Evoss-X Notebook Deity

    Reputations:
    65
    Messages:
    814
    Likes Received:
    0
    Trophy Points:
    0
    hi
    very nice 4k write !
     
  7. achau

    achau Notebook Geek

    Reputations:
    7
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    15
    That's great. I will try to re-install Windows 7. Did you install any driver for the disk controller or just install the default disk controller?
     
  8. nass9500

    nass9500 Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    What is your results ?
     
  9. Evoss-X

    Evoss-X Notebook Deity

    Reputations:
    65
    Messages:
    814
    Likes Received:
    0
    Trophy Points:
    0
    mine ? mine is sit :D
     
  10. nass9500

    nass9500 Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    yes,
    your results and achau's results
     
Loading...
Thread Status:
Not open for further replies.

Share This Page