Booting from SSD connected to DVD drive slot

Discussion in 'VAIO / Sony' started by weser, Aug 23, 2017.

  1. weser

    weser Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hello,

    The original RAID0 SSD in my vpcz13c5e died. I decided to get rid of the DVD drive and replaced it with a 2,5" drive adapter with SSD. To make shure that the old SSD does not interfere somehow with a new windows install, I removed it.
    I booted Win10 setup via USB and everything went fine, setup installed to the new SSD. When it was finished, I pulled the USB drive and expected that the new SSD would boot and continue the setup process. But all I got was "operating system not found". The SSD is visible in the BIOS setup, but there doesn't seem to be a way to change a setting to make it boot.
    Since the notebook was happily booting from USB, I tried with a USB drive with sysresccd on it. This one uses syslinux as bootloader and has the option of loading bootsectors from other hard drives and run them. So when I tried that with "drive-1", windows started to boot from the new SSD and successfully finished. Right now this is the only way that I can boot this notebook.

    TL;DR: I can use this notebook with the help of syslinux, but this is a kludge. Has anyone an idea of how to boot natively from a SSD that is connected to the DVD drive SATA port?

    Cheers!

    PS: thanks for the excellent guide on how to get Windows 10 setup perfectly on this PC!
     
  2. galaxyge

    galaxyge Notebook Consultant

    Reputations:
    22
    Messages:
    136
    Likes Received:
    42
    Trophy Points:
    41
    I guess this is solved by now.
    In case it isn't, one idea is that it may be caused by the original RAID setup.
    Enter the BIOS, enable RAID setup and remove all traces of the RAID volume that was created from the SSDs. You might have to connect them again to do so, but I'm not sure.


    Sent from my iPad using Tapatalk
     
Loading...

Share This Page