Block automatic BIOS update?

Discussion in 'Asus' started by pitha1337, Jun 4, 2020.

  1. pitha1337

    pitha1337 Notebook Consultant

    Reputations:
    19
    Messages:
    157
    Likes Received:
    67
    Trophy Points:
    41
    Hi everyone,

    I own an GX701GXR and I want to stay on BIOS 306 because here I can undervolt my CPU. Unfortunately Windows will Update the BIOS every time I reboot.

    I have tried the option in the attached screenshot but this doesn't help. Someone has an idea how I can prevent my device from auto BIOS updating?

    upload_2020-6-4_19-9-8.png
     
  2. senso

    senso Notebook Deity

    Reputations:
    548
    Messages:
    1,627
    Likes Received:
    756
    Trophy Points:
    131
    Check on the BIOS if there isn't some option called something like Allow BIOS Capsule module, or allow BIOS update.
     
  3. pitha1337

    pitha1337 Notebook Consultant

    Reputations:
    19
    Messages:
    157
    Likes Received:
    67
    Trophy Points:
    41
    Unfortunately I don't have this option in BIOS. I know that such an option exists on Alienware notebooks.
     
  4. pitha1337

    pitha1337 Notebook Consultant

    Reputations:
    19
    Messages:
    157
    Likes Received:
    67
    Trophy Points:
    41
  5. heisenberg1122

    heisenberg1122 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    block the permission of all accounts to access Windows\Firmware folder. works for me, model GX701
    [v2004] folder changed to \Windows\System32\DriverStore\FileRepository\gx701xxx_30x.xxxxx
     
    Last edited: Jul 20, 2020
  6. jeffreyC

    jeffreyC Newbie

    Reputations:
    10
    Messages:
    9
    Likes Received:
    8
    Trophy Points:
    6
    Do you have a password on your BIOS?

    Researching a related problem I saw that Windows cannot change a BIOS if it has a password, since it does not have the required permissions.
    Whether that is so with every BIOS I do not know.
     
  7. kdaniel

    kdaniel Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    2
    Trophy Points:
    6
    I did the following to stop this (on a zephyrus s laptop)

    1. Install older bios on the laptop (307), new one was 310
    2. Disable the driver updates like you did
    3. Enter the "Device manager" in the "Control panel"
    3.1 Find "Firmware" -> "System Firmware"
    3.2 On the "Driver" tab, there is a button "Roll back driver", this will remove the updated "bios" driver and won't trigger the automatic update
     
    Clintlgm and pitha1337 like this.
  8. Clintlgm

    Clintlgm Notebook Consultant

    Reputations:
    31
    Messages:
    190
    Likes Received:
    26
    Trophy Points:
    41
    If you have Pro version you can turn off hardware drivers in gpedit
    https://www.tenforums.com/tutorials...iver-automatic-installation-windows-10-a.html
     
    thewizzard1 likes this.
  9. Spartan@HIDevolution

    Spartan@HIDevolution Company Representative

    Reputations:
    33,153
    Messages:
    23,142
    Likes Received:
    35,859
    Trophy Points:
    931
    Download this registry file, unzip it, then double click on Disable Driver Updates.reg to merge it with your registry then reboot

    You can also download the Windows update hide/show tool so you can leave driver updates ON if you wish but selectively hide updates so they won't appear in the future.
     
  10. GX701GXR

    GX701GXR Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    2
    Trophy Points:
    6
    Can somebody send me the oldest BIOS for the zephyrus gx701gxr with the undervolting options??? I'm so frustrated my cpu is reaching 98º under full load and still has warranty so I don't want to change thermal paste yet. Please help :(((
     
Loading...

Share This Page