Bizarre Desktop UI behavior on Alienware 17R4

Discussion in '2015+ Alienware 13 / 15 / 17' started by Azther, Jan 1, 2018.

  1. Azther

    Azther Notebook Enthusiast

    Reputations:
    0
    Messages:
    21
    Likes Received:
    16
    Trophy Points:
    6
    hi there, not sure if anyone can help, but ive been having an odd issue lately where the system UI would freeze when switching apps or opening menus. the system is still running when this happens (music playing in background, can still hear ppl on ts etc) but the whole desktop is frozen including the mouse, and only way to fix it is to close and open the lid( i have it set to do nothing when i close the lid) i can go several days without this happening, then once it does happen, it continues doing it randomly until i restart.
     
  2. Vasudev

    Vasudev Notebook Prophet

    Reputations:
    1,252
    Messages:
    4,280
    Likes Received:
    2,304
    Trophy Points:
    231
    Disable hybrid startup, update intel and nvidia drivers. See if it fixes the issue.
     
  3. Azther

    Azther Notebook Enthusiast

    Reputations:
    0
    Messages:
    21
    Likes Received:
    16
    Trophy Points:
    6
    already had hybrid startup disabled, i switched graphics mode with fn + F7 and back to performance mode for good measure, then installed latest geforce drivers (had latest intel) also updated IRST driver, ill post back if the problem comes up again
     
    Vasudev likes this.
  4. TheBeastDragon

    TheBeastDragon Notebook Consultant

    Reputations:
    32
    Messages:
    235
    Likes Received:
    126
    Trophy Points:
    56
    Try to reinstall win10,
    Maybe this could do!?
     
  5. Razrblade

    Razrblade Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    2
    Trophy Points:
    6
    i had some weird freezing up going on, and what did the trick for me was uninstalling killer wireless software.
     
  6. Azther

    Azther Notebook Enthusiast

    Reputations:
    0
    Messages:
    21
    Likes Received:
    16
    Trophy Points:
    6
    i solved the issue, turns out all i had to do was use the fn + f7 to switch to the igpu, and restart to let the intel drivers auto setup, then do fn + f7 again to put it back into dedicated gpu mode again, i guess a windows update must of messed with that functionality somehow
     
    Vasudev likes this.
Loading...

Share This Page