BIOS update (1.4.4) messed up my laptop

Discussion in '2015+ Alienware 13 / 15 / 17' started by cyberlasha, Feb 13, 2018.

  1. cyberlasha

    cyberlasha Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    6
    Update: sleep is also not an option, when it sleeps, it’s same as shut down (lightings on, not waking up, no reaction on power button until I long press it and turn power off completely)
     
  2. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    5,386
    Messages:
    8,799
    Likes Received:
    6,242
    Trophy Points:
    681
    Update Intel GPU to latest driver from Dell or Intel. Use Control Panel's uninstall option and DDU to cleanup older drivers.
     
  3. cyberlasha

    cyberlasha Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    6
    It didn't help. And this is really getting worse last startup time was about 3 minutes
     
  4. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    5,386
    Messages:
    8,799
    Likes Received:
    6,242
    Trophy Points:
    681
    aren't you using secure boot?
     
  5. cyberlasha

    cyberlasha Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    6
    ofc I’m using secure boot
     
  6. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    5,386
    Messages:
    8,799
    Likes Received:
    6,242
    Trophy Points:
    681
    Then 15 secs is too long on a SSD unless you're using 7.2k rpm HDD.
     
  7. tobyg

    tobyg Notebook Consultant

    Reputations:
    45
    Messages:
    168
    Likes Received:
    91
    Trophy Points:
    41
    This is bad news. Because when I was on 1.2.3 on my 6700hq 17 R4 skylake based system, it started crashing. Now that I'm back on an older bios, it's been rock solid again.
    Based on the file name of the 'new' bios, "Alienware_15R3_17R4_SKL1.2.3_KBL1.2.4.exe", yeah it looks like it's still got 1.2.3 for Skylake, but Kabylake is now 1.2.4.

    I definitely won't be updating any time soon. Not only that, but my m.2 speeds tanked by 1/3rd of their speed.
     
    Vasudev likes this.
  8. ijozic

    ijozic Notebook Deity

    Reputations:
    104
    Messages:
    791
    Likes Received:
    136
    Trophy Points:
    56
    How did you get back to the older BIOS? I thought they locked the 1.2.3 version due to the CPU microcode updates?
     
  9. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    5,386
    Messages:
    8,799
    Likes Received:
    6,242
    Trophy Points:
    681
    You can do a BIOS rollback using USB stick by looking at this thread
     
  10. sethsalien

    sethsalien Notebook Enthusiast

    Reputations:
    10
    Messages:
    39
    Likes Received:
    22
    Trophy Points:
    16
    I updated to the 1.4.4 no startup lag everythings running smoothly, if you dont already have dell support assist app install it and check for other updates besides bios.
     
Loading...

Share This Page