AW17R2 Intel ME Firmware Update

Discussion in '2015+ Alienware 13 / 15 / 17' started by Violent Kain, Apr 11, 2019.

  1. Violent Kain

    Violent Kain Notebook Enthusiast

    Reputations:
    0
    Messages:
    14
    Likes Received:
    4
    Trophy Points:
    6
    Hello,

    Quite a while ago I uptaded my BIOS to A06 on my AW17R2, when it was updating, the computer crashed, leaving the AW bricked.

    I managed to unbrick it with an EEPROM programmer.
    The thing is that I've got an annoying connecting and disconnerting issue with the storage usb devices, a webcam and capture card work fine. This only happens when the NVidia card is enabled, when I disable it, works fine. So this has been the workaround for 1 year or so...

    So my guess is that the Intel ME Firmware didn't flash ok.
    I read on this post: http://forum.notebookreview.com/threads/aw15-r1-aw17-r2-bios-a06.781507/page-7#post-10092882

    Lord Zog posted a firmware update for this model, but the link is broken. Can someone re-upload the file?
    Or maybe guide me for updating the firmware by myself.

    Sorry for creating a post about it, but it seems I dont have the sufficient privileges to reply there.

    Many thanks in advance!
     
  2. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    6,515
    Messages:
    10,066
    Likes Received:
    7,369
    Trophy Points:
    931
    @judal57 Do you remember the MEI FW version we used? Was it 9.1?
     
  3. judal57

    judal57 Notebook Deity

    Reputations:
    241
    Messages:
    1,140
    Likes Received:
    602
    Trophy Points:
    131
    I CANT .... WHERE I CAN SEE IT ?
     
  4. judal57

    judal57 Notebook Deity

    Reputations:
    241
    Messages:
    1,140
    Likes Received:
    602
    Trophy Points:
    131
    but the usb problem is still there since 2015. is the only thing i cant fix on this machine
     
  5. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    6,515
    Messages:
    10,066
    Likes Received:
    7,369
    Trophy Points:
    931
    Still have the issue on 15r2/17r3 and above versions... Haha......
    Check HWINFO64 or MEINfo present in the folder of SA0086 when we did the remote FW upgrade.
     
  6. Violent Kain

    Violent Kain Notebook Enthusiast

    Reputations:
    0
    Messages:
    14
    Likes Received:
    4
    Trophy Points:
    6
    I've flashed the BIOS to ver. A08, and now works. I wonder why it only works with that bios...
     
    Vasudev likes this.
Loading...

Share This Page