AW 17R4 battery issues

Discussion in '2015+ Alienware 13 / 15 / 17' started by NewAgeMessiah, May 19, 2017.

  1. NewAgeMessiah

    NewAgeMessiah Notebook Consultant

    Reputations:
    0
    Messages:
    154
    Likes Received:
    3
    Trophy Points:
    31
    Hi All,
    Apologies for not having the time or device to search the forums.

    Got delivery yesterday and the machine is awesome.
    One issues however is that the battery isnt charging. Slightly annoying considering its a £2,000 laptop.

    Tried diagnotics - battery at 98% health and Ok, as is the Mobo, Cord and AC Adapter so cant find a fault anywhere there.
    Have also run the battery down and decharged but still not charging.

    Anyone else have this issue at all? And if so any resolutions?
    Going to try and give it a BIOS update tonight (from a bootable USB as Windows wont let me run the application with under 10% battery) in the hope that resolves it hopefully, but an idea of peoples experiences would be great.

    Also if anyone has the Alienware tech support number for the UK that'd be great
    N
     
    Last edited: May 19, 2017
  2. Vasudev

    Vasudev Notebook Deity

    Reputations:
    109
    Messages:
    1,026
    Likes Received:
    305
    Trophy Points:
    101
    Disable desktop charge by right click battery icon > Desktop Mode charge. If you want you can hit a button to charge 100% this time option and battery will charge to full capacity.
     
  3. MogRules

    MogRules Notebook Deity

    Reputations:
    815
    Messages:
    1,170
    Likes Received:
    372
    Trophy Points:
    101
    The R4's don't have desktop charging mode.
     
    SimplyJ3sse likes this.
  4. Vasudev

    Vasudev Notebook Deity

    Reputations:
    109
    Messages:
    1,026
    Likes Received:
    305
    Trophy Points:
    101
    Dell/AW OSD is available on Dell website, but I don't know if the success rate is 100% since many users are reporting that the feature is absent.
     
  5. NewAgeMessiah

    NewAgeMessiah Notebook Consultant

    Reputations:
    0
    Messages:
    154
    Likes Received:
    3
    Trophy Points:
    31
    That's the first thing I looked for too.
    Spoke to a decent advisor on the phone after an hour trying to find a number - diagnostics stated the AC adapter was 255w which he believed was the root of the problem.
    Getting an email Monday to confirm an engineer has been booked for Tuesday, fingers crossed.
    If I discover anything else then I will update the thread with specifics for others as reference
    N
     
  6. MogRules

    MogRules Notebook Deity

    Reputations:
    815
    Messages:
    1,170
    Likes Received:
    372
    Trophy Points:
    101
    I have OSD installed, it just isn't available on the R4.
     
    Vasudev and SimplyJ3sse like this.
Loading...

Share This Page