Avira keeps updating avnotify.exe

Discussion in 'Security and Anti-Virus Software' started by SDreamer, Mar 6, 2009.

Thread Status:
Not open for further replies.
  1. SDreamer

    SDreamer Notebook Consultant

    Reputations:
    23
    Messages:
    220
    Likes Received:
    0
    Trophy Points:
    30
    I have avnotify.exe disabled by restricting system access via the security tab in Vista x64, but when Avira updates, it updates that file as well. Any way around this? Probably going to switch back to AVG if this is the case...
     
  2. whizzo

    whizzo Notebook Prophet

    Reputations:
    769
    Messages:
    5,851
    Likes Received:
    2
    Trophy Points:
    206
    there's another file you have to disable as well. not sure which one, but google is omniscient :)
     
  3. coolguy

    coolguy Notebook Prophet

    Reputations:
    805
    Messages:
    4,685
    Likes Received:
    12
    Trophy Points:
    106
    Avira will update avnotify only if you do a product update or have avira to automatically do a product update. Even if avira updates that file, you won't get that pop up ad due to the security restriction.
     
  4. Jakamo5

    Jakamo5 Tetra Vaal

    Reputations:
    630
    Messages:
    1,406
    Likes Received:
    80
    Trophy Points:
    66
  5. kobe

    kobe Notebook Virtuoso

    Reputations:
    374
    Messages:
    2,629
    Likes Received:
    1
    Trophy Points:
    55
    Hey +1 rep for the the premium license.
     
  6. SDreamer

    SDreamer Notebook Consultant

    Reputations:
    23
    Messages:
    220
    Likes Received:
    0
    Trophy Points:
    30
    I Googled, all I found was restrict avnotify.exe, and some group policy things.

    I'll have to see if I have product updates on auto, I don't remember switching it on auto, everything is still default, so it might be that.
    Avira did update it, and it showed in the report that it did, and during the next update, the nag ad popped up, and I checked the security taband it's restrictions were gone, it was like the default settings. Weird thing is, Avira isn't updating it on my parents' computer or my girlfriend's computer I think. Well the ad won't pop up when I update on them anyways. So I'm guessing it's the product update.

    Problem for me is I run Avira on my parents' computer, my girlfriend's computer, and my own as well, and I don't want to have to renew a license for multiple computer just to avoid a giant ad.

    Thanks for the advice, I'll see what happens.
     
  7. skakruk

    skakruk Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    This is how I solved this problem... I added avnotify.exe to avira quarantine - the popups have seized.
     
  8. DarkSilver

    DarkSilver MSI Afterburner

    Reputations:
    378
    Messages:
    2,249
    Likes Received:
    0
    Trophy Points:
    55
    TS, you have Avira Antivir Personal 9(FREE)?
    or you're using Avira paid version?

    Avira Antivir Personal 9 always have pop up message for you.

    Solution/fix:

    Vista

    1. Navigate to C:\Program Files\Avira\AntiVir Desktop\avnotify.exe
    2. Right-click avnotify; Go to Properties - Security - Advanced
    3. Look under the Permissions folder for System.
    4. Edit - Traverse Folder / Execute File - Deny - Click OK

    XP Professional


    1. Go to Start; Run, and type 'secpol.msc'
    2. Click on Software Restriction Policy; go to Action; Create New Restriction Policies
    3. Right-click on Additional Rules (on the right); Choose New Path Rule
    4. Click Browse and find the avnotify.exe file (C:\Program Files\Avira\AntiVir Destop\avnotify.exe)
    5. Make sure the security level is set to Disallowed and click OK.

    XP Home

    1. Boot into Safe Mode (Press F8 after boot)
    2. Login under the Administrator account
    3. Navigate to C:\Program Files\Avira\AntiVir Desktop\avnotify.exe
    4. Right-click avnotify; Go to Properties - Security - Advanced
    5. Look under the Permissions folder for a listing of all the system users. Do the following for all the users:
    6. Edit - Traverse Folder / Execute File - Deny - Click OK
    7. Reboot (into Normal mode) when finished.

    To prevent the minimized update screen from ever showing up;

    1. Start AntiVir. Go to Administration; Scheduler.
    2. Right-click on Daily Update; choose Edit job
    3. Click Next until you reach the Display Mode screen
    4. Select Invisible from the drop-down list.
     
  9. yuyi64

    yuyi64 Notebook Consultant

    Reputations:
    38
    Messages:
    260
    Likes Received:
    0
    Trophy Points:
    30
    The other file you have to disable is avnotify.dll
     
Loading...
Thread Status:
Not open for further replies.

Share This Page