Asus X53E No LED backlight after screen replacement

Discussion in 'Hardware Components and Aftermarket Upgrades' started by mrapter, Jun 25, 2012.

Thread Status:
Not open for further replies.
  1. mrapter

    mrapter Newbie

    Reputations:
    0
    Joined:
    Jun 21, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hello everyone,

    I've got the same issue as mentioned in this thread http://forum.notebookreview.com/del...5-led-screen-no-backlight-10.html#post8647467 .

    I stupidly replaced the LED screen on an asus laptop with the battery in. I've followed this post and a couple of others and tried to locate the right fuse to solder but I cant seem to locate it anywhere.

    here are some pics of both sides of the board near the screen connector cable.

    http://postimage.org/image/41krn3gp7/

    http://postimage.org/image/dnec3e7uz/

    as you can see there are no F anything markings, nor are there any markings like that anywhere on the board.

    any help would be amazing as I've tried everything I can think of!
     
  2. spleenharvester

    spleenharvester Notebook Enthusiast

    Reputations:
    170
    Joined:
    Aug 1, 2012
    Messages:
    35
    Likes Received:
    3
    Trophy Points:
    16
    Hello,

    You probs won't see this but it's worth a shot, did you have any luck with this? Someone I know of is having the same issue with an Asus X5EA.

    Best of luck
     
  3. altamimi

    altamimi Newbie

    Reputations:
    0
    Joined:
    Jan 28, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    hi mrapter, did you find a solution for your laptop? i have the same moel and exactly the same problem, i hope you solved it and give me some hints please where to find that fuse, thank you
     
  4. wishmasteruk

    wishmasteruk Newbie

    Reputations:
    0
    Joined:
    Feb 18, 2014
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    6
    hi just fixed mine today (x53e) after testing just about every part on the board replace the jumper or bridge it like i did good luck

    IMAG1044.jpg
     
    Yaso likes this.
  5. Yaso

    Yaso Newbie

    Reputations:
    0
    Joined:
    Feb 18, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    wishmasteruk thank you so much :cry: :hi2:
    It's was exactly that jumper, i tested it with my continuity tester.
    Soldered it and everything is fine :thumbsup:
    Saved me a lot of money ;)
     
Loading...
Thread Status:
Not open for further replies.

Share This Page