Asus Rog G751JT Black Screen After Re-Paste / Fan Clean

Discussion in 'ASUS Gaming Notebook Forum' started by hal0000, Apr 14, 2018.

  1. hal0000

    hal0000 Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Hi,
    I re-paste my laptop like 10+ times. I'm Studying Computer Engineering, i'm not an amateur.
    After Assembly my laptop, Screen was Blinking so fast and very low brightness so i tought i don't Connect the display cable Properly

    So i remove keyboard ofc. turned off laptop and try to connect display cable again while no keyboard just pressing Power (I/O) button and if i saw still same blinking i repeat this procedure, after 15 try still same issue.BTW all this procedure without battery, I used only charging.

    I try with HDMI Cable to TV and display working well so no GPU damaged. I did stress test about 10 min Both Gpu and Cpu don't even reach to 65 Degree.

    I remove display cable while laptop open and display gone as we expected and i try to connect cable while laptop open i saw spark and heard sound under the MotherBoard, then i shut down laptop and connect everything.

    Right now not even low brightness/blinking screen, only Black Screen. But HDMI with Tv is working well
    Gpu working, games smooth there is nothing wrong exept Black Screen. So guys what's the problem am i destroy the laptop ? Motherboard ? or Panel or just the cable or Condenser ? I will add 2 pictures and both is before all of this i will disassembly laptop tomorrow for checking condenser
    [​IMG]
    Red circle is Display Cable Connector
    [​IMG]
    Red circle is Behind the Display Cable Connector but there is nothing for spark source so maybe in yellow area create spark. BTW. Pictures old not after the spark
     
  2. Clintlgm

    Clintlgm Notebook Consultant

    Reputations:
    30
    Messages:
    147
    Likes Received:
    14
    Trophy Points:
    31
    Well if you have had that notebook apart 10 times I would think its a real good possibility the ribbon, or ribbon connectors area damaged from so many disconnects and reconnects hopefully it not the connector on the screen or MB that have become damaged. I would try a new ribbon.
     
    hmscott likes this.
  3. hal0000

    hal0000 Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    About multiple times, not even a screw disassembly man i just don't assembly keyboard so i can see live fan spinning etc. like picture 1 but screen assembled too.
    I just press power button and check screen if it's not working, i turned off and re attach screen cable not like fully disassembly ıt's just a screen cable i assembly/disassembly
     
    Last edited: Apr 19, 2018
  4. Clintlgm

    Clintlgm Notebook Consultant

    Reputations:
    30
    Messages:
    147
    Likes Received:
    14
    Trophy Points:
    31
    Your opening comment was "I re-paste my laptop like 10+ times" you have had to disassemble your notebook to accomplish repasting. Regardless these ribbon cables and connectors are very fragile and easily damaged I would try to find a new one and replace it.
     
  5. hal0000

    hal0000 Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Don't think so i have everything for this gloves, special table pad, etc. I have full equipment i sent to Asus support and i think they try to scam me visit this link: https://rog.asus.com/forum/showthread.php?101504-ASUS-Service-Problem-!
     
  6. Clintlgm

    Clintlgm Notebook Consultant

    Reputations:
    30
    Messages:
    147
    Likes Received:
    14
    Trophy Points:
    31
    I think we must be having a language issue here. Yes, I have seen your post on ROG forum. My replies are to this thread. I repeat from what you have posted in this thread. the next logical step would be to replace the ribbon If that doesn't fix it then most likely the connector on the screen itself or the motherboard are defective. Or the screen itself.

    " spark and heard sound under the MotherBoard" this does not sound good loud spark coming from motherboard does not sound good at all obviously something shorted out
     
  7. hal0000

    hal0000 Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    My issue was only screen. but Asus service told me my laptop don't even start.. I am living in third world country everything can be happen here. Before I sent my laptop to service, Everything was working well exept screen, but asus service guy told me my laptop don't even boot, lights up. and he offering me 3800 TRY motherboard replacement. as i mention in ROG forum i purchased this laptop 3600 TRY in USA (like 1250 usd) i don't know what to do but i have everything pictured about my motherboard if my laptop really not working. I will try to match motherboard with my pictures because this is wrong ! my laptop fully working exept screen before i send to Asus Service, now they say ıt's not working ?

    Edit: I will find some place have multimeter for finding shortout and can you tell me when i can buy same ribbon or atleast same quality ?
     
    Last edited: Apr 19, 2018
Loading...

Share This Page