ASUS GL703GS keyboard and led issue after Hibernation or Shutdown

Discussion in 'ASUS Gaming Notebook Forum' started by hexaae, Mar 25, 2020.

  1. hexaae

    hexaae Notebook Consultant

    Reputations:
    0
    Messages:
    172
    Likes Received:
    8
    Trophy Points:
    31
    The issue:
    all of a sudden on 16 March 2020 I noticed that when I resume from Hibernation, the keyboard leds won't turn on, but keyboard still works and I can restore leds with ROG AURA Core... but at this point with led off after Hibernation, if I reboot the keyboard will totally stop working except Mousepad and Power button (it also keeps led turned off)! This persists even at BIOS and on next reboots!! Keyboard not working except mousepad and power button all the time.
    To restore leds and keyboard I have to: Shutdown, unplug PSU, and press multiple times Power button...

    I'm afraid it is a Windows 10 1909 issue after recent updates + ASUS software conflict of some kind. I tried to uninstall recent ones (got updates on 7, 11, 14 of March) but didn't help. Have no idea why this happened and hope someone has had similar issues and has a solution because ATM I can't use Sleep and Hibernation reliably anymore [​IMG]

    I tried also to disable ROG Armoury II (I use for Carry Strix mouse) and ledcontrolservice3 but didn't help:
    [​IMG]

    These are my (left) Win updates:
    [​IMG]

    To recap:
    Hibernation or Shutdown now make keyboard leds turn off "forever" even with next reboots. When leds are off only mousepad and power button do work.
    To wake up keyboard (and its led, have no idea why they seem connected now) at this point I have to:
    - enter Hibernation or Shutdown with power cable
    - unplug cable and press Power button to resume laptop using battery: this will wake up leds and keyboard will work fine.

    No idea why... [​IMG]

    Gaming Laptop ASUS GL703GS (BIOS 310)
    CPU i7-8750H (iGPU unavailable)
    GTX 1070 8GB (non-Max-Q, 10DE 1BE1 - 1043 1011, GP104 A1, vbios 86.04.7c.00.24, Samsung VRAM)
    Windows 10 Pro 1909
    Desktop res: 1080p (1920x1080)
    Screen: 144Hz + g-sync AUO B173HAN03.2 [AUO329D]
    Audio: Realtek HD Audio (ALC295 chipset)
    Hard disks: NVMe Samsung, SSD Crucial
    USB Blu-Ray 4K drive: Archgon Star MD-8102P-U3YC-UHDB (Pioneer BDR-UD04)
     
  2. hexaae

    hexaae Notebook Consultant

    Reputations:
    0
    Messages:
    172
    Likes Received:
    8
    Trophy Points:
    31
    Tried to reinstall all ROG Aura Core software but didn't help...

    I've found also old ROG Aura Core Component 1.0.14 on https://ivanrf.com/en/latest-asus-drivers-for-windows-10/ and tried to reinstall everything from scratch (Aura Core from MS Store, Aura Core Component 1.0.14, Aura Service* 3.03.38 hotfix). I've also tested without Aura Core Component as suggested on https://www.asus.com/support/FAQ/1036500/

    *Aura Service == LightingService

    Nothing changed for me, still problems...
     
  3. hexaae

    hexaae Notebook Consultant

    Reputations:
    0
    Messages:
    172
    Likes Received:
    8
    Trophy Points:
    31
    Feedback from other users with GL703GS?
     
  4. senso

    senso Notebook Deity

    Reputations:
    519
    Messages:
    1,588
    Likes Received:
    734
    Trophy Points:
    131
    Are you already running latest BIOS?
     
  5. hexaae

    hexaae Notebook Consultant

    Reputations:
    0
    Messages:
    172
    Likes Received:
    8
    Trophy Points:
    31
    Yes as you can read above in my cfg: 310.
     
  6. Drewbido0

    Drewbido0 Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Hi, I'm facing the same issue, I can't get my keyboard and backlight to work, tried the hybernation, shutting down with and without PSU, also tried downgrading windows updates.
    Mousepad and power button (without backlight) only work.
     
    Last edited: Apr 4, 2020
  7. hexaae

    hexaae Notebook Consultant

    Reputations:
    0
    Messages:
    172
    Likes Received:
    8
    Trophy Points:
    31
    Yep, those are the symptoms. Try more than once to temporarily resume keyboard:
    a. put in Hibernation while in AC mode
    b. unplug power-cord ( = put in DC battery mode)
    c. wait a few secs and resume with Power button while in battery mode
    repeat a,b,c if doesn't work on first try.

    I'm afraid this is an ASUS vs Microsoft issue of some kind and not a HW failure (keyboard would be completely dead). Hope to see it fixed with some ASUS or MS bigger updates soon...
     
    Last edited: Apr 8, 2020
    Drewbido0 likes this.
  8. Drewbido0

    Drewbido0 Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    So, windows update just came up.. But before that - I've set my batery on FC mode, then hibernated and left pc with power-cord plugged, plugged out after roughly between 15sec first time, then followed a bit longer and lastly - 2min... followed what was instructed, with no success, so, I gave up and left pc hibernated with power-cord plugged in for a couple days. Today, opened my laptop, took out power-cord, pressed power button... and everything lit up. Dunno if it's temporary till next turn off and I don't want to try.
    c:
     
  9. hexaae

    hexaae Notebook Consultant

    Reputations:
    0
    Messages:
    172
    Likes Received:
    8
    Trophy Points:
    31
    As I said, you have to repeat A, B, C if doesn't work first time. Don't give up, it's not a HW fault IMHO.
    This is a temp workaround of course. We need a real software/BIOS fix from ASUS & Microsoft!
     
    Last edited: Apr 8, 2020
  10. hexaae

    hexaae Notebook Consultant

    Reputations:
    0
    Messages:
    172
    Likes Received:
    8
    Trophy Points:
    31
    @Drewbido0
    did you try a BIOS reflash or maybe a BIOS reset (someone suggested to try with Power button pressed for 30secs)? I can't do these experiments on my GL703GS ATM since I'm using it for work too...
     
Loading...

Share This Page