Asus G73SW : nividia drivers problem

Discussion in 'ASUS Gaming Notebook Forum' started by NeroTulip, Jun 4, 2011.

  1. NeroTulip

    NeroTulip Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Hi guys, I've had an Asus G73 SW for 2 weeks, and I've encountered a few problems, I wonder if you can help me?

    First of all I can't get to update the nvidia drivers; if I do a clean uninstall of the current one, my graphic card isn't recognised (nothing in the control panel, no question mark). I tried to look in BIOS if there's something wrong with the PCI settings, but I actually can't find anything about PCI...

    Is it a problem for anyone else?

    The other question is a bit off topic (let me know if I should post somewhere else) but I'm wondering about the performance of my machine.
    I'm getting 15-25 fps on crysis 2 on high, 15-25 on metro 2033 on high (with DX 11 tess and DOF turned off), the witcher 2 is unplayable (although I suspect it's got something to do with my driver, which is why I want to update it). Is it normal?

    Also, it's common for my GPU to get as hot as 95C; it's 45 iddle... is there something wrong with my computer?
     
  2. thief1958

    thief1958 Notebook Consultant

    Reputations:
    16
    Messages:
    273
    Likes Received:
    0
    Trophy Points:
    30
    Did you uninstall the old driver from the device manager? ..Once you do this, sometimes the display adapter will disappear from the device manager. Restart the laptop then the vga driver will be installed to the gpu and the display adapter (icon) will be back in the device manager, then you could install your new driver.

    What model G73SW do you have? Does it have the 1.5 Gb GTX 460M (192-bit)? Because if you do, it's hard to believe when you say that Witcher 2 is unplayable. I have finished Witcher 2 in my G73SW-XT1. It auto detected the graphic setting to medium, and I just disabled the other options to make it much more playable than it already is. Low setting is completely playable. Even driver whql 260.61 can play Witcher 2 in my G73SW-XT1. I played it on all drivers (260, 270, 275 and they're all okay).

    If you still have the power4gear hybrid installed, make sure you're at performance mode or entertainment mode before playing witcher 2. Put it on battery mode, then it will be very slow. I've deleted power4hybrid for now so I don't accidentally put battery mode on and play games, ..you can always instal it back when you decide to use the laptop on battery when on trips or using it outside using battery power.

    Have you cleaned all the bloatware and did Windows update?

    [​IMG]

    [​IMG]
     
  3. NeroTulip

    NeroTulip Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Thanks for answering :)

    That's the reason I'm posting, to find out if it's normal. I just got the computer 2 weeks ago. It looks like such a great machine on paper, I feel I'm not getting the performance I should.

    It's the one with the 1.5 gb graphic card by the way, so we seem to have the same model.

    With the Witcher 2 on normal I get 10-15 FPS; when I say it's unplayable I'm not exagerating. It starts ok (although not great either) and after a few minutes it starts going downhill. What other options did you disable? What FPS are you getting? I'd love to be able to compare :)

    As for the control panel, after I do a clean uninstall of my driver there's just nothing in the device manager; no new hardware detected, no question mark either. I can't install any new or old nvidia driver, and am forced to restore the system. This remains even after I reset the computer to factory settings... wonder what's going on.
     
  4. Yiddo

    Yiddo Believe, Achieve, Receive

    Reputations:
    1,086
    Messages:
    4,659
    Likes Received:
    0
    Trophy Points:
    105
    95oC is high and probably the highest I have seen posted from a GtX 460m in an SW I would try stress testing with Furmark and use HWINFO to see what the temps are reaching because it sounds as though you have a bad paste.

    In regards to Witcher 2 can you post a screenshot of your game settings or list what you have them set to. Make sure Ubersampling is turned off as that drops me to about 10-15FPS with it turned on.
     
  5. NeroTulip

    NeroTulip Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    I played a lot with the settings, but right now I tried with these, which are basically normal with V-sync off:

    [​IMG]

    I played 10 minutes, got 15 fps in combat, 20 in town. I know from experience it gets even lower if I play a normal amount of time.

    Also, in just those 10 minutes it got as hot as 93°:

    [​IMG]

    Just noticed there are these weird GPU usage drops too... is it something to do with the heating?

    Keep in mind this is a new computer; did I get a bad one? should I get it replaced?
     
  6. thief1958

    thief1958 Notebook Consultant

    Reputations:
    16
    Messages:
    273
    Likes Received:
    0
    Trophy Points:
    30
    I don't have any fps testing, ..though I don't think I can beat all the bosses in Witcher 2 fairly easy now with fast dodging if my frame rate is slow under normal difficulty.. Even fighting at Vergen with many opponents (10+ soldiers) it's not lagging.

    I'm doing the Vernon Roche path of the story now, since I've finished the game first time choosing Iorveth path.

    I could play 5 hrs. straight of Witcher 2 with my SW-XT1 and the laptop is still quiet, and I'm not exxagerating, no overclocking too. It gets hot ofcourse from the exhaust ports after playing that long. Give it 5 mins. rest (off) then I'm on for another 5 hrs. if I want too or if I could.

    I've played/finished Fallout New Vegas with this same laptop in Ultra High setting and it was flawless (4X anti-aliasing, 16x anistrophic).

    I've had this SW-XT1 for about 5 weeks now. The pics are my actual graphic setting in Witcher 2. All games are played in native resolution of 1080p.

    Does your G73SW have the "New Revision / Certified Design" sticker; With reguards to Sandy Bridge issue?.

    I never had problems with my SW since I bought it from Tiger Direct right at their outlet store here in Toronto, Canada.

    So you mean you don't have a driver for the gpu now, or no display adapter at all in the device manager even after rebooting? That's bad.. Windows should detect a hardware installed even if it doesn't have the appropriate driver, in the case of the SW it will give you atleast a vga driver by windows.

    Were you using system restore often, it could jumble the OS. Maybe do a fresh Windows install, though I never have to do this just to clean all the bloatware. If that doesn't work, I say return and exchange it, you shouldn't be experiencing any of these problems.

    Your SSAO enabled... Try to minimize everything and disable everything, leaving decals medium, texture memory size small, texture downscaling could be none or just small to improve frame rate.

    How about low setting/ spec? You shouldn't have any problems with playability with low spec even at 1080p..
     
  7. NeroTulip

    NeroTulip Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Finally managed to put the older drivers after a full restore...

    ... and I'm disappointed again. Same settings except SSAO off, I am getting 15 fps. I'm pretty sure if you had 15 fps you would notice it.

    I guess I just got a crappy computer, there's no way performance should be that bad with a GTX 460, 8GB and a great cpu. And the fact that I could use my graphic card as an incinerator makes me believe there's just something wrong with it.

    Do you guys know if it should be easy to exchange it?
     
  8. Keith

    Keith Notebook Deity

    Reputations:
    834
    Messages:
    703
    Likes Received:
    109
    Trophy Points:
    56
    This is what TigerDirect's website says about this model:

    "This Product Has Limited Exchange Privileges.
    Only defective exchanges for identical item within 30 days of purchase permitted on this product. After 30 days, please contact the manufacturer at: (888) 678-3688"
     
  9. NeroTulip

    NeroTulip Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Thanks :)

    The problem is that it was a gift, and although I've just had it for 2 weeks I think it was bought over a month ago.

    How about Asus, do they have a history of being good with this? Or am I going to get screwed?
     
  10. wernerml

    wernerml Notebook Enthusiast

    Reputations:
    0
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    5
    MAN, I HAVE THE SAME PROBLEM on my ASUS G73SW-BST6

    I live in Brasil... so I have a MUCH BIGGER problem.... the warranty is valid only there in USA...

    I opened my laptop, REPASTED, with Arctic Silver 5, did ALL things correctly, JUST TO FIND OUT THAT ----->>> THE GPU FAN WAS BLOCKED!!!!!!

    acctually, I have the notebook for 3 months... and it was working FINE before... I used to play for hours, and a couple of time I checked the temperature, and it was FINE... like, 10 HOURS PLAYING it wouldn't go over 67, 70º C.....

    NOW, IT's GETTING 90 with 10 minutes playing... THE FAN SIMPLY STOPPED WORKING!!! WHY???? its NOT DUST, IM SURE! VERY SURE!...


    NOW, here in BRASIL there ISN'T, simply, ISN'T anything that FITS this motherboard... NO COOLER is compatible...

    I think i'm gonna have to BUY FROM USA... wait for like MONTHS...

    very, VERY disappointing...
     
Similar Threads: Asus G73SW
Forum Title Date
ASUS Gaming Notebook Forum ASUS G73SW gpu upgrade to GTX 970M, is it possible? Jan 14, 2015
ASUS Gaming Notebook Forum Asus G73SW - Occasional freezes Aug 24, 2014
ASUS Gaming Notebook Forum Asus ROG G73SW wont power up Feb 10, 2014
ASUS Gaming Notebook Forum Reassembled Asus G73SW not powering on Aug 4, 2013
ASUS Gaming Notebook Forum Asus G73sw some keys not working Apr 25, 2013

Share This Page