1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

asus g72 wireless stuck in off

Discussion in 'ASUS Gaming Notebook Forum' started by stamar, Nov 13, 2010.

Thread Status:
Not open for further replies.
  1. stamar

    stamar Notebook Prophet

    Messages:
    5,802
    Likes Received:
    1
    Trophy Points:
    206
    I just got an asus g72 best buy model. It was a best buy return

    I installed a new windows ultimate on it , not the asus version.
    the wireless is stuck in the mode with a red x over the bars

    when i try to repair it says turn wireless on. I flip the switch on and off and nothing changes

    I hit fn f2 and nothing happens.

    the little wireless icon on the front of the laptop does not light up or change

    device manager claims the device is working fine.

    What is wrong?

    thanks in advance
     
  2. ALLurGroceries

    ALLurGroceries   Super Moderator

    Messages:
    6,815
    Likes Received:
    373
    Trophy Points:
    251
    Maybe the switch is broken. You could try a Linux livecd like Ubuntu to see if it's a software problem. If the LED isn't coming on with the physical switch, you've probably got a hardware issue.
     
  3. teebizzoo

    teebizzoo Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hi there,

    I've had this same problem since I bought the darn thing in March. I had it on the first machine I bought from Best Buy within a few days of purchase. Thinking it was an isolated problem, I then returned that one and got a new one (hey maybe you bought the one I returned--ha). A few months later, had the SAME problem (plus a keyboard issue). Sent it to ASUS to have it fixed under warranty.

    And just yesterday, the wireless switch went out AGAIN. So, this is obviously a hardware problem inherent to this G72 model. (Or Asus laptops in general, who knows?) I've reading different posts on the Internet and it seems that you have to somehow reboot the ADAPTER, not the whole computer, to get it to turn back on. Some people recommend that you turn the switch off, turn the machine off, turn the switch back on, and then turn the machine back on. Worked for them, didn't work for me.

    I just had your same problem and found your post as I was looking for a solution. Since then, I FOUND a solution that worked for me, so I came back to share!

    Here's what did it for me. I used an ethernet cord to hook the laptop into the Internet that way. When I did that, the wireless switch adapter was disabled. I ensured that the Internet was working via ethernet connection.

    I went into Control Panel/Device manager and made sure that the Atheros Wireless Network Adapter was disabled. Good. It seems that when you plug in the ethernet cord, it shuts off the adapter and becomes the primary Internet connection. Then, I removed the ethernet cord, which severed that connection. I then went back into Device Manager, and enabled the Atheros Wireless Network Adapter again. All of a sudden, it worked again. Hallelujah.

    I think it just needs to be "rebooted" like that to get going again. An irritating hardware problem for sure. But at least I got it working again.

    If this doesn't work for you, you might also try hooking up to the Internet via ethernet connection and reinstalling the drivers. I'm glad it didn't come to that for me.

    Good luck--hope it works.

    Trish
     
  4. Chet L.

    Chet L. Notebook Guru

    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    15
    Another G72 owner checking in and mine does the same thing. My solution, after making sure that the switch is in the on position, is to go to device manager and disable the wireless adapter. I then enable the wireless adapter. This does the same thing that teebizzo does without the need to connect the ethernet cord.
     
  5. stamar

    stamar Notebook Prophet

    Messages:
    5,802
    Likes Received:
    1
    Trophy Points:
    206
    in my case it was that i needed to install the asus hotkey utility
     
Thread Status:
Not open for further replies.

Share This Page