1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

Asus G50V LCD Backlight problem

Discussion in 'Asus' started by tilopa88, Feb 20, 2010.

Thread Status:
Not open for further replies.
  1. tilopa88

    tilopa88 Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    I have an Asus G50v and when I boot up the screen is black. If I put an external monitor to it I can see the screen perfectly fine. But when I go back to the laptop screen even though it is black to the eye if I shine a flashlight on the front of the screen I can see the bios text and I can enter CMOS setup and see the text.

    I reseated the LVDS cable from the screen to the MB but that did not help. So I'm wondering if it is the screen backlight, and how can I test or fix this?
    Thanks.
     
  2. ALLurGroceries

    ALLurGroceries   Super Moderator

    Messages:
    6,814
    Likes Received:
    373
    Trophy Points:
    251
    Reseating the LVDS would be the other way around, if it had backlight but no signal. You have signal but no backlight, it's probably the inverter.
     
  3. ALLurGroceries

    ALLurGroceries   Super Moderator

    Messages:
    6,814
    Likes Received:
    373
    Trophy Points:
    251
    Sorry for the double post.. I should have mentioned that the inverter is on the opposite side of the LVDS. LVDS is on the left, inverter is on the right. You need to take the screen bezel off to get to it.

    You can see it all the way to the right in my pic here:

    [​IMG]

    From the disassembly guide posted by David:

    [​IMG]
    [​IMG]
     
  4. tilopa88

    tilopa88 Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Thanks AllurGroceries. I found an inverter on estore for 10 bucks so I'll give that a try, I appreciate the detailed disassembly pics. So, you said if I had backlight but no signal it would be the LSVD, what do you mean exactly, if there where no text from POST but only like a lighted grayish screen? I just want to make sure it is nothing with the connectivity to the MB because I had problems with the MB and had suspected it was in that area.
     
  5. ALLurGroceries

    ALLurGroceries   Super Moderator

    Messages:
    6,814
    Likes Received:
    373
    Trophy Points:
    251
    Right, exactly. If you had light coming from the screen but no text, it would be the LVDS cable which is essentially the display cable. The inverter is most likely your problem, but it could be a grounding issue or something strange like that. It's much more likely to be the inverter, and it's a cheap fix. Good luck!
     
  6. tilopa88

    tilopa88 Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    I swapped out the inverter with a new one and it did not fix it. So, I ended up using a friends whole LCD panel and just plugged it in and still the same problem. So, the issue must be on the motherboard at the LVSD connector. I guess there is not an easy fix for this.
     
  7. ALLurGroceries

    ALLurGroceries   Super Moderator

    Messages:
    6,814
    Likes Received:
    373
    Trophy Points:
    251
    Maybe the CCFL burnt out and you need a whole new backlight. Edit: wait you tried the entire panel? Must be a problem on the motherboard then, supplying power to the inverter. :(

    You could take a multimeter to the inverter to see if it's getting any power.
     
  8. tilopa88

    tilopa88 Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    I wanted to try this but I'm not sure how. The LVDS connector is 30 pins female. If I stick the multimeter red probe in the pin hole where do I put the black probe. Sorry but I'm not too savvy about electronics. Also what type of DC voltage should I be getting?
    Thanks.
     
  9. ALLurGroceries

    ALLurGroceries   Super Moderator

    Messages:
    6,814
    Likes Received:
    373
    Trophy Points:
    251
    Again, the LVDS is not your issue if you have signal but no backlight. The LVDS carries the actual display signal (you can see text on the screen with a flashlight), whereas the inverter supplies power to the backlight. The idea is to check the inverter and the power connector for the inverter at the motherboard to see if it is the point of failure. Here are two guides which should help you test it with a multimeter:
    http://www.fonerbooks.com/test.htm
    http://www.laptoprepair101.com/laptop/2009/05/04/how-test-lcd-screen-inverter-in-laptop/

    Edit: Also if you don't have a good meter around, only a cheap multimeter, don't even bother with the test. You can tell if the inverter is getting power by listening to it, it should make a hissing noise that cycles a bit. If your problem is at the motherboard, there isn't much you can do, except to try and GENTLY wiggle the inverter's power connection around a bit to see if the problem is with the actual connector.
     
  10. tilopa88

    tilopa88 Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    So, I'm a little confused now. And I appreciate all your replies and the helpful links, and at this point it is probably the MB and a hopeless fix, but I need to understand this final piece.

    Again, I swapped out the inverter and no change. Then I took the whole back panel piece from another G50v and swapped it out, and still no change. The panel connects to the MB at only 2 places. One is a 40 pin male connector on the MB side at the left if you are facing the front of the laptop - this is what I was calling the LVDS. On the right side of the MB there is a 20 pin male connector, which now I realize is the inverter connector after looking at the disassembly guide again. Ok, I was testing the wrong connector as you stated.

    But when I turn on the laptop and put the + probe of the multimeter to the first of the 20 pins and put the black probe to part of the metal case near it I only get - 0.1 DC volts. What am I doing wrong here, and what DC volt reading should I be seeing?

    Thanks again for all your help
     
  11. ALLurGroceries

    ALLurGroceries   Super Moderator

    Messages:
    6,814
    Likes Received:
    373
    Trophy Points:
    251
    First off, it's probably a bad idea to be doing it willy-nilly. You can short it out if it isn't already shorted. Look at the pics in the second link I posted above if you are going to do it. The voltage reading will be all over the place (again, there are references in the links I posted), so it's hard to say, but it should not be -0.1v.
     
  12. E.B.E.

    E.B.E. NBR Procrastinator

    Messages:
    8,625
    Likes Received:
    1
    Trophy Points:
    206
    Did you check the cables themselves? (mainbd --> inverter, inverter --> screen). Those could also be the problem.

    If not, then indeed it's the mainboard.
     
Thread Status:
Not open for further replies.

Share This Page