Aorus X5 V7, X7 V7, DT X7 all estimated for June release in USA

Discussion in 'Gigabyte and Aorus' started by laserbullet, May 18, 2017.

  1. Jared_T

    Jared_T Notebook Evangelist

    Reputations:
    13
    Messages:
    376
    Likes Received:
    179
    Trophy Points:
    56
    What is that stuff anyways? Theres bad contact on a couple of my VRAM chips

    Sent from my ONEPLUS A5000 using Tapatalk
     
  2. Derek712

    Derek712 Notebook Virtuoso

    Reputations:
    424
    Messages:
    2,306
    Likes Received:
    784
    Trophy Points:
    131
    What stuff?
     
  3. Derek712

    Derek712 Notebook Virtuoso

    Reputations:
    424
    Messages:
    2,306
    Likes Received:
    784
    Trophy Points:
    131
    BTW, I forgot to mention that my GPU heat sink screws were loose when I did my teardown. Screw 1 was completely undone! I'm not sure if that's the case with anyone else...
     
    RMXO and hmscott like this.
  4. RMXO

    RMXO Notebook Evangelist

    Reputations:
    225
    Messages:
    624
    Likes Received:
    202
    Trophy Points:
    56
    I'll check tonight when i pull my nvme & ram from my X5 and put it back in my X7 DT. The non-DT I returned, didn't have that issue, as I took took out the heatsink to see what was used and repasted afterwards.
     
  5. alawadhi3000

    alawadhi3000 Notebook Geek

    Reputations:
    1
    Messages:
    94
    Likes Received:
    26
    Trophy Points:
    26
    Did you test the temps using fixed fan speed or auto?

    If its on auto then the difference is larger than 12C which is huge.
     
  6. RMXO

    RMXO Notebook Evangelist

    Reputations:
    225
    Messages:
    624
    Likes Received:
    202
    Trophy Points:
    56
    So I opened both of my X5 and X7 DT last night and the screws in question were screwed on tight. My X5 was re-pasted by HID and my X7 DT came from NewEgg.

    Sent from my SM-G955U using Tapatalk
     
    Vistar Shook and Derek712 like this.
  7. eddi3x3x3

    eddi3x3x3 Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    I just received my Aorus x7 v7 and the touchpad doesn't work :( does anyone have any suggestions on how I can get it working? I tried to enable it in the nf + f10 combination, re-installing drivers but no luck. Not sure if I should open up the laptop and check the connection of the touchpad. Can someone show me how it's supposed to show up in device manager? I have a few mouse devices showing up in device manager but not sure if that's it.
     
  8. Intuos

    Intuos Notebook Enthusiast

    Reputations:
    5
    Messages:
    18
    Likes Received:
    6
    Trophy Points:
    6
  9. Svegetto

    Svegetto Notebook Consultant

    Reputations:
    11
    Messages:
    243
    Likes Received:
    89
    Trophy Points:
    41
  10. Svegetto

    Svegetto Notebook Consultant

    Reputations:
    11
    Messages:
    243
    Likes Received:
    89
    Trophy Points:
    41
    Also, since I've upgraded my laptop to 4x16GB (and I still need to post a teardown/upgrade guide; I already have the pics from the teardown, just haven't had time to write up a detailed post), I have my original 2x8GB G.Skill Ripjaws for sale and I'll be posting it in the 'for sale section' but figured I'd mention it here in case anyone wants to upgrade their aorus x5/x7 using the exact same RAM that came with their laptop (if so PM me).
     
    laserbullet, MiSJAH and RMXO like this.
Loading...

Share This Page