Anyone with a Clevo P950HR (or similar) with GTX1070 MaxQ tried the new 400+ nvidia drivers?

Discussion in 'Sager and Clevo' started by djsubtronic, Oct 29, 2018.

  1. hackness

    hackness Notebook Virtuoso

    Reputations:
    1,229
    Messages:
    2,325
    Likes Received:
    390
    Trophy Points:
    101
    It was also an issue on the MSI,

    MSI AB and Steam webhelper becomes the cause of waking the dGPU on series 400+ driver.

    You could try the fixed I posted here:
    http://forum.notebookreview.com/posts/10812428/

    The current version of the MSI Afterburner does keep waking the dGPU.

    Fix is not coming any sooner stated by the author since he lacks hardware to test, you could do OC'ing using Nvidia Inspector on start up and use HWINFO64 to monitor.

    Link here:
    http://forum.notebookreview.com/thr...us-fix-doesnt-seem-to-come-any-sooner.825788/
     
    Last edited: Nov 21, 2018
    yeoldegamer1979 likes this.
  2. djsubtronic

    djsubtronic Notebook Evangelist

    Reputations:
    83
    Messages:
    334
    Likes Received:
    29
    Trophy Points:
    41
    Ah, interesting. I'm going to test this. I wanted to use Nvidia Inspecter for the OC as well as it's less intrusive. But for some reason it doesn't work with the app I wrote (that disables/reenables dGPU after DisplayPort and power are disconnected). Upon re-enabling, it also needs to re-enable the OC. By calling the OC shortcut for Nvidia Inspecter, it doesn't actually apply. But also killing and restarting MSI AB after re-enabling GPU did work, so I stuck with that.
     
  3. djsubtronic

    djsubtronic Notebook Evangelist

    Reputations:
    83
    Messages:
    334
    Likes Received:
    29
    Trophy Points:
    41
    Ok I just tried without MSI Afterburner (and I don't have Steam Web Helper)... still the same issue. I guess the disabling/reenabling of the device just has issues on its own with v400+.
     
  4. hackness

    hackness Notebook Virtuoso

    Reputations:
    1,229
    Messages:
    2,325
    Likes Received:
    390
    Trophy Points:
    101
    I see, this method did work for me when I was digging through the problem.

    Sometimes the NVIDIA defaults steam to dGPU, but if you don't use steam, maybe it is something else.

    Also I added many of the possible exe to the windows graphic list, the one you saw in the guide, just to eliminate any other possibilities.

    The way I found that the steam web helper is using the dGPU is through the task manager, there is a GPU usage column, maybe you can start from there.

    I've been using NVIDIA Inspector's set OC command with Task Scheduler with a 45 seconds delay, counting starts once a user has logged in. And also set Windows 7 under compatibility mode. I believe it needs to wait for all the NVIDIA components to load before applying the OC, as I was getting memory not accessible error in the past, after doing this, all errors are eliminated.

    I didn't force disabling / re-enabling the dGPU though, I just let it does what it do.

    A lot of the modern laptops nowadays have the HDMI and other video output ports hooked up with the dGPU directly, if you are worrying about the battery life in video output mode, you can try some thunderbolt or USB to HDMI adapter which maybe more suitable in battery mode.
     
    djsubtronic likes this.
  5. djsubtronic

    djsubtronic Notebook Evangelist

    Reputations:
    83
    Messages:
    334
    Likes Received:
    29
    Trophy Points:
    41
    Ok, did a bit more testing. Switched my app to use Nvidia Inspector lnk to re-apply OC instead of MSIAB in a different manner, it's now working. But when I still saw the high System use and GPU staying awake, it was actually because GPU-Z was running (I had it open to see if the OC was re-applied or not). Closing GPU-Z makes everything OK again. So I guess your fix does work. It looks like certain GPU-monitoring apps cause this high CPU usage of "System", and MSI AB is probably one of them.
     
    hackness likes this.
  6. djsubtronic

    djsubtronic Notebook Evangelist

    Reputations:
    83
    Messages:
    334
    Likes Received:
    29
    Trophy Points:
    41
    Funnily enough, without MSI AB now always running in the background using the new OC method and 416.94 drivers, I actually get even more battery life than the previous configuration, by about 30-40 minutes.
     
    hackness likes this.
  7. hackness

    hackness Notebook Virtuoso

    Reputations:
    1,229
    Messages:
    2,325
    Likes Received:
    390
    Trophy Points:
    101
    Glad it worked.

    That list is actually the master list of switchable graphic, it seems to have a higher privilege than the NVIDIA panel. So it is basically assign once in the list, then you can leave it be, it'll still be there even you update the NVIDA driver. But the settings inside the NVIDIA panel is another story, I'll actually tweak in the NVIDIA panel again just to make sure both are correctly assigned.

    If you need the NVIDIA panel to take over, you can set it to Default in the list, and the change regarding the switchable graphic within the NVIDIA panel shall apply.
     
    djsubtronic likes this.
  8. codral

    codral Notebook Guru

    Reputations:
    0
    Messages:
    53
    Likes Received:
    9
    Trophy Points:
    16
    What this guy above me said is what i've been having success with i'm on 418 at the moment and haven't had any issues but am noticing more and more apps want to use my nVidia instead of my Intel GPU which results in my GPU staying awake more (but not my CPU usage increasing) Also three parts of the Nvidia software now seem to want to keep things open. Anyway I was just going to suggest enable the Notification Icon in Nvidia Control Panel to keep an easier eye on what's using it, as windows only reports what's currently using it in foreground by the look of it, whereas the notification icon seems to be constantly monitoring? Don't know if that'll help but yeah I reckon every week i'm swapping the software defaults to Intel on more and more things.
     
  9. gunemalli

    gunemalli Notebook Geek

    Reputations:
    9
    Messages:
    97
    Likes Received:
    10
    Trophy Points:
    16
    This happens to me as well. I use an external monitor via miniDP for work and it's connected directly to Mains Power. Whenever there's a power outage, everything happily moves back on to the laptop screen however, the applications that was opened on the external monitor continue to run via the dGPU. You can see this list via the NVIDIA GPU Activity monitor. What I normally do is close all the applications shown on this list and re-open them. This causes the dGPU to go back to sleep. If not even my battery life is almost halved to about 1.5-2 hrs compared to iGPU 4-4.5hrs

    upload_2019-3-8_10-0-39.png
     
  10. djsubtronic

    djsubtronic Notebook Evangelist

    Reputations:
    83
    Messages:
    334
    Likes Received:
    29
    Trophy Points:
    41
    This has always been the case for me, especially when using an external monitor. I created an app that runs in the background and monitors your power state and display count. If you switch to battery and have no external monitors connected, it will disable the 1070 device and re-enable it automatically 1 minute after removing the power. It can also be triggered by a hotkey on demand.

    What this does is release the GPU and all apps using it, and when it's reenabled it stays "inactive" (does not consume any battery). Apps continue running just fine, 3D apps will obviously crash if they were actively using the GPU at the time that it was disabled. Browsers using GPU acceleration will be fine though but may require a page refresh.

    Overall it works great for me because I can just unplug and move to the couch or something, and not worry about getting only 1hour of battery.
     
Loading...

Share This Page