Anyone ever nailed the Dell Inspiron e1505 T7600G overclocking?

Discussion in 'Hardware Components and Aftermarket Upgrades' started by RVF16, Aug 13, 2013.

  1. RVF16

    RVF16 Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Hello to everyone.

    In short : How can this system get overclocked to 2,83GHz or beyond (preferably under linux) ?

    In long : My main (and only) system is this Dell e1505 with locked bios which hopefully i will keep for at least 2 years.
    I bought it in 2007 and since i never played games or did anything too resourceful it was adequate until the need for virtual machines arose (virtual box).
    I maximized RAM to 3,2GB (4GB installed) and found several threads regarding the overclockable Intel Core 2 Duo T7600G.
    Searching around i thought i found a bios mod that would unlock the overclocking feature, only to realize it was just for SLIC2.1.
    Unfortunately i had already ordered the T7600G so am now stack with it on it's standard range of values (1Gz - 2,33Ghz).

    There was someone in another forum that searched for a lost bios mod that took the overclocking ability part from an Inspiron m1710 bios and added it to the e1505 6400 bios for the T7600G.
    I searched everywhere i could, no such bios mod was found.

    The motherboards PLL is not supported by any overclocking software.
    Under Windows, only minor success i had was in SetFSB choosing the Dell XPS M1730 option (CY28547 FSLx) which managed to read FSB.
    I moved the sliders slightly without knowing where exactly to settle them but CPU-z showed no change.
    Under Windows, ClockGen wouldn't read FSB with any PLL selection.
    Under Windows, using crystalcpuid and multiplier management to raise the FBS from 667 to 1111 (according to someone's directions) i only managed to lock my system
    Link : i overclocked dell e1505 duo core fbs to 1111 - Guru3D.com Forums
    Under linux wrmsr and c2ctl work as long as the values in the standard range are used (1Gz - 2,33Ghz).
    Under linux SMBus seems enabled according to lspci.

    Finally there is a thread about PIN mod :
    Method 2: FSLx mod to hardwire PLL for higher FSB
    where the author describes how to cut and ground the FSLB/TEST_MODE pin using an example of 9LPR501S chip (pin 57).
    My CY28447LFXC (allegedly) has FSB/TEST_MODE (pin 45) but i don't know if this is applicable.
    Link : http://forum.notebookreview.com/har...nmod-overclocking-methods-examples-print.html

    Under Windows, the Intel Processor Identification Utility verifies the T7600G properties.

    I have noticed there is a member of this forum, K-TRON, with identical system and CPU, who has managed to overclock it.

    If anyone could point me to the right direction i would much appreciate it.
    Thank you in advance.
    Regards

    System Info

    General

























    System Dell Inspiron E1505
    Mother Board YD612
    BIOS MM016
    BIOS Revision A17
    PLL (Clock Generator) cy28447lfxc (allegedly)
    Northbridge Intel i945PM rev. 03
    Southbridge Intel 82801GHM (ICH7-M/U) rev. A1
    Graphic Interface PCI-Express
    Processor





































    Name Intel Mobile Core 2 Duo T7600G
    Codename Merom
    Specification Intel(R) Core(TM)2 CPU T7600 @ 2.33GHz
    Package (platform ID) Socket 479 mPGA (0x5)
    actualFSB 166 MHz
    ratedFSB 667 MHz
    Stock Core Speed range 998.7 MHz - 2333 MHz
    FID/VID Control yes
    Stock Multiplier (FID) range 6.0 - 14.0
    Stock Voltage range 1 - 1.213 V (CPU-z)
    Stock VID range 23 - 40 (ThrottleStop)
    Voltage range 1.0375 - 1.3 V (wikipedia)
    Memory

























    Memory Type DDR2 SDRAM
    Form Factor SO-DIMM
    Standard PC2-5300
    Number of Pins 200
    Installed Memory Size 4 GB (2 x 2 GB)
    Available Memory Size 3.2 GB
    Width 64 bits
    Bus Speed 667 MHz (1ns)
    Display Adapter
















    Name NVIDIA GeForce Go 7300
    Revision A3
    Codename G72
    Technology 90 nm
    Memory size 128 MB

    Linux + lspci
    Code:
    # lspci
    00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
    00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
    00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
    00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
    00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
    00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
    00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
    00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
    00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
    00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
    00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] (rev 01)
    [COLOR=#FF0000]00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)[/COLOR]
    01:00.0 VGA compatible controller: NVIDIA Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)
    03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
    03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
    03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
    03:01.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 01)
    03:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
    03:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)
    0b:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
    Linux + i2c
    Code:
    # i2cdetect -y 0
         0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
    00:          -- -- -- -- -- 08 -- -- -- -- -- -- -- 
    10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
    50: 50 -- 52 -- -- -- -- -- -- -- -- -- -- -- -- -- 
    60: -- -- -- -- -- -- -- -- -- 69 -- -- -- -- -- -- 
    70: -- -- -- -- -- -- -- --                   
    Code:
    # i2cdump -y 0 0x69 s 0
         0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f    0123456789abcdef
    00: 79 ef ff 00 01 00 3b 18 06 0e f0 00 5a 7f 80 80    y?..?.;????.Z???
    10: 10 08 04 01                                        ????
    Code:
    # i2cdump -y 0 0x69 s 0xd
         0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f    0123456789abcdef
    00: 7f 80 80 10 08 04 01 bc 90 04 04 04 04 04 89 8c    ????????????????
    10: 00 00 03 79                                        ..?y
    SetFSB (only FSB-readable selection)










    Dell XPS M1730 CY28547 FSLx
    Normal Speed 200Mhz PLL
    OC Speed 266Mhz PLL
    Linux + msr-tools + T7600G
    06 13 0E 28 86 00 0E 28
    == -- -- -- -- -- -- -- this is the minimum FID
    -- == -- -- -- -- -- -- this is the minimum VID
    -- -- == -- -- -- -- -- this is the maximum FID
    -- -- -- == -- -- -- -- this is the maximum VID
    -- -- -- -- == -- -- -- unsure
    -- -- -- -- -- == -- -- unsure
    -- -- -- -- -- -- == -- this is the current FID
    -- -- -- -- -- -- -- == this is the current VID


    Following code outputs following 2 tables
    Based upon code from this Link : https://bugzilla.redhat.com/show_bug.cgi?id=468802#c5
    Code:
    # MSRs="198 199 1A0"
    # CPUs=$(sed -rn 's@^processor[\t]: ([0-9]+)$@\1@p' /proc/cpuinfo)
    # for MSR in $MSRs;do
                         for CPU in $CPUs;do
                                            echo -n "CPU${CPU} ${MSR}: "
                                            rdmsr -0 -X -p ${CPU} 0x${MSR}
                                          done
                       done
    Speed Step = 1
    FREQ = 1.00 Ghz
    Governor = Userspace
    Code:
    CPU0 198: 06130E2886000613
    CPU1 198: 06130E2886000613
    CPU0 199: 0000000000000613
    CPU1 199: 0000000000000613
    CPU0 1A0: 0000004264952489
    CPU1 1A0: 0000004264952489
    Speed Step = 1
    FREQ = 2.33 Ghz
    Governor = Userspace
    Code:
    CPU0 198: 06130E2886000E28
    CPU1 198: 06130E2886000E28
    CPU0 199: 0000000000000E28
    CPU1 199: 0000000000000E28
    CPU0 1A0: 0000004264952489
    CPU1 1A0: 0000004264952489
    CY28447LFXC image
    Link : https://www.dropbox.com/s/9m3srwc3g1z13in/CY28447LFXC.png

    CY28447LFXC Data Sheet
    Link : CY28447LFXC pdf, CY28447LFXC description, CY28447LFXC datasheets, CY28447LFXC view ::: ALLDATASHEET :::
    Link : https://www.dropbox.com/s/y5w4fn8mp247fht/CY28447LFXC-datasheet.pdf

    Complete T7600G processor info
    Link : https://www.dropbox.com/s/5d3qoxz4npliz22/T7600G.txt
    Link : List of Intel Core 2 microprocessors - Wikipedia, the free encyclopedia
    Link : Intel Core 2 Duo T7600G processor - LF80537GF0534MU
     
    Lasted edited by : May 6, 2015
  2. Erekson7

    Erekson7 Notebook Enthusiast

    Reputations:
    0
    Messages:
    36
    Likes Received:
    2
    Trophy Points:
    16
    The T7600G was a special processor made by intel specifically for the XPS M1710, and It might work with a modified bios for your laptop, but is $300 is what the t7600g going for really to be worth it for you ? along with taking apart the laptop and "Hoping" for it to work. And what if it doesn't ? then more likely you could have damaged your laptop or be refused a refund by the seller !:rolleyes:

    now if you had a xps m1710 buying a t7600g to upgrade would be a different story :)
     
  3. RVF16

    RVF16 Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Hello Erekson7

    I already have the CPU, second hand from eBay at less than half the price you state.
    Took me 45 minutes to install it, was a good opportunity to give my hairy heatsinks a haircut too :D.
    I dismantle my laptop at least 3 times a year to remove dust after all.
    Also this is an old (2006) obsolete model (out of warranty).
    It works great, temperatures (CPU0, CPU1, GPU0) are fine according to Open Hardware Monitor and SpeedFan.
    It's the overclocking i am interested in.

    I have managed to overclock it following The ThrottleStop Guide on this forum.
    Link : http://forum.notebookreview.com/har...arket-upgrades/531329-throttlestop-guide.html

    Procedure
    I run the ThrottleStop
    Reduced FID in Set Multiplier to lowest value 6 (6*166=0,996GHz~1GHz | actualFSB=166MHz for T7600G)
    Unchecked Clock Modulation and Chipset Clock Mod (if checked)
    Pressed Reset
    Pressed Turn On
    Pressed UNLK (unlock)
    Increased VID in Set Multiplier to 1,3 (this is UCpu voltage in V | x1000 for mV)
    Increased FID in Set Multiplier to 18 (2,988GHz)

    For Mobile Core 2 CPUs the equation for converting VID to Voltage seems to be :
    UCpu = 712.5 mV + VID*12.5 mV
    The equation for converting FID to frequency is :
    FCpu = FID * actualFSB
    LINK : c2ctl

    Actual FSB is available in ThrottleStop's main window.
    In linux lshw offers complete system information, including FID :
    Portable Computer -> Motherboard -> CPU [clock]
    LINK : ezIX

    The system is unfortunately not stable but haven't spent enough time testing.

    Now how do i apply this unlock under Linux?

    Edit:
    Under windows Open Hardware Monitor doesn't output the correct overclocked frequency while CPU-z does.
     
  4. Erekson7

    Erekson7 Notebook Enthusiast

    Reputations:
    0
    Messages:
    36
    Likes Received:
    2
    Trophy Points:
    16
    Well im glad it worked for you :) didn't mean to bash lol. You just have to play around with different multipliers and see what's the most stable for you. I have a xps m1710 and the e1505 has a similar chassis so temps might be around the same. I can't say it will work or not since anything is possible with computers these days :D sooo just play around with it and slowly increase the multiplier till as far as it can go !
     
  5. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    5,211
    Messages:
    4,138
    Likes Received:
    417
    Trophy Points:
    151
    Hint: When playing around with ThrottleStop, keep an eye on MSR 0x194. You should be able to figure out what needs to be adjusted to do this overclocking in Linux.

    MSR Tool
    MSR.zip

    Changing the maximum multi screws up some monitoring tools.
     
  6. RVF16

    RVF16 Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Hello again.
    It took me awhile to test several values, check result behavior and search for answers before posting back.
    I have also uploaded a simple arithmetic conversion (DEC to HEX to BIN) table to my DropBox space.
    Link : https://www.dropbox.com/s/e3r6macjukfuw3n/DEC2HEX2BIN.txt
    One can also use online arithmetic conversion tools.
    Link : HEXADECIMAL to BINARY conversion, HEX to Decimal converter, Hexdecimal convertor

    Thank you unclewebb for your hint, that did the trick under linux.
    I run simultaneously ThrottleStop and MSR.
    Everytime i changed FID/VID in ThrottleStop i read/refreshed in MSR window the registers 0x194 0x198 0x199.
    Warning :
    1. The following combinations of FID/VID are under testing and not final for my system.
    2. The following combinations of FID/VID are for Intel Core 2 DUO T7600G CPU with actual FSB 166MHz.
      One has to set FID and VID values for other CPUs accordingly.

    The registers' values are :

    FCpu = 2496 MHz
    UCpu = 1.3000V
    FID = 15 (HEX : 0F)
    VID = 47 (HEX : 2F)
    MSR 0x194 (EDX[63..32]|EAX[31..0]) 0x00000000|0x00010F2F 0x0000000000010F2F
    MSR 0x198 (EDX[63..32]|EAX[31..0]) 0x06130F2F|0x86000F2F 0x06130F2F86000F2F
    MSR 0x199 (EDX[63..32]|EAX[31..0]) 0x00000001|0x00000F2F 0x0000000100000F2F


    FCpu = 2663 MHz
    UCpu = 1.3000V
    FID = 16 (HEX : 10)
    VID = 47 (HEX : 2F)
    MSR 0x194 (EDX[63..32]|EAX[31..0]) 0x00000000|0x0001102F 0x000000000001102F
    MSR 0x198 (EDX[63..32]|EAX[31..0]) 0x0613102F|0x8600102F 0x0613102F8600102F
    MSR 0x199 (EDX[63..32]|EAX[31..0]) 0x00000001|0x0000102F 0x000000010000102F


    FCpu = 2829 MHz
    UCpu = 1.3375V
    FID = 17 (HEX : 11)
    VID = 50 (HEX : 32)
    MSR 0x194 (EDX[63..32]|EAX[31..0]) 0x00000000|0x00011132 0x0000000000011132
    MSR 0x198 (EDX[63..32]|EAX[31..0]) 0x06131132|0x86001132 0x0613113286001132
    MSR 0x199 (EDX[63..32]|EAX[31..0]) 0x00000001|0x00001132 0x0000000100001132


    FCpu = 2998 MHz
    UCpu = 1.4000V
    FID = 18 (HEX : 12)
    VID = 55 (HEX : 37)
    MSR 0x194 (EDX[63..32]|EAX[31..0]) 0x00000000|0x00011237 0x0000000000011237
    MSR 0x198 (EDX[63..32]|EAX[31..0]) 0x06131237|0x86001237 0x0613123786001237
    MSR 0x199 (EDX[63..32]|EAX[31..0]) 0x00000001|0x00001237 0x0000000100001237


    FCpu = 3162 MHz
    UCpu = 1.4000V
    FID = 19 (HEX : 13)
    VID = 55 (HEX : 37)
    MSR 0x194 (EDX[63..32]|EAX[31..0]) 0x00000000|0x00011337 0x0000000000011337
    MSR 0x198 (EDX[63..32]|EAX[31..0]) 0x06131337|0x86001337 0x0613133786001337
    MSR 0x199 (EDX[63..32]|EAX[31..0]) 0x00000001|0x00001337 0x0000000100001337


    So i easily noticed that at register 0x194 i had to set (from right to left) the digit 4 value to 1 and also fill the digits 0-1 and 2-3 with VID and FID values respectively.
    By default the register 0x194 is set to 0x00000000.
    The commands in linux bash to set the above CPU frequencies are :

    2496 MHz
    Code:
    wrmsr -p 0 0x194 0x00010F2F
    wrmsr -p 0 0x199 0x06130F2F
    2663 MHz
    Code:
    wrmsr -p 0 0x194 0x0001102F
    wrmsr -p 0 0x199 0x0613102F
    2829 MHz
    Code:
    wrmsr -p 0 0x194 0x00011132
    wrmsr -p 0 0x199 0x06131132
    2998 MHz
    Code:
    wrmsr -p 0 0x194 0x00011237
    wrmsr -p 0 0x199 0x06131237
    3162 MHz
    Code:
    wrmsr -p 0 0x194 0x00011337
    wrmsr -p 0 0x199 0x06131337
    Searching on the internet for more information about register 0x194 i stepped upon a very informative thread in which member haarp provides linux bash script code, c2e-overclock v0.5.5, for his system which does all the work.
    Warning : This code needs editing to suit different CPUs.
    Link : Gentoo Forums :: View topic - How to check CPU voltage...
    I took the liberty to upload it on my DropBox space.
    Link : https://www.dropbox.com/s/jyekgw258j54rfe/c2e-overclock
    Big thanks to haarp for his contribution and i must say Gentoo and Arch users are always the best coders in Linux community.

    Going through that code i noticed a small variation in the equation for calculating CPU voltage from VID so i updated post #4 accordingly.
    I also noticed a reference to register 0x regarding Clock Modulation.
    From c2e-overclock v0.5.5 :
    The script disables, upon request, Clockmod by setting register 0x19A to 0x00 for each CPU core :
    Code:
    for i in $cpulist; do 
        wrmsr -p$i 0x19A 0x00
    I checked that register on my system and it is always 0x0000000000000000 so it seems no further action needs to be taken.

    Unfortunately two problems appear which make overclocking my system a definite fail, for the time being :
    1. The system becomes sluggish in both Windows and Linux.
      Movement, opening, closing of any window or switching between workspaces and viewports is very slow, with missing frames.
    2. After a while in both Windows and Linux the frequency automatically reduces to standard values (1000 MHz - 2333 MHz) even though all temperatures (CPU0, CPU1, GPU0, THM) are below 70°C (SpeedFan)

    Going again through haarp's code i noticed that the application of values to register 0x199 resides in an endless loop.
    For reasons unknown to me he repeats setting the FID and VID values endlessly with a delay of 0.25 seconds each time.
    By doing the same thing (example for 2998 MHz) :
    Code:
    FD=1237
    while :;do wrmsr -p 0 0x194 0x0001$FD; wrmsr -p 0 0x199 0x0613$FD; sleep 0.25s; done
    i manage to keep the registers' values constant even though this somehow doesn't feel right.
    By the way ThrottleStop's Power Saver feature is turned off.
    Speed Step is enabled in BIOS.

    If someone knows how that slugginess can be avoided and why CPU automatically reduces frequency i would much appreciate it.
    Thank you.
     
  7. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    5,211
    Messages:
    4,138
    Likes Received:
    417
    Trophy Points:
    151
    There are 2 main types of Clock Modulation throttling. One is controlled by the CPU so it is easy to disable this by writing 0 to MSR 0x19A but the other type is controlled by the chipset. It's more difficult to get to this and I don't know if it is possible to disable this from the Linux command line.

    In Windows, when your system gets super sluggish, have a look at the ChipM column in ThrottleStop. Both types of clock modulation should always be at 100.0%. Post a screenshot of ThrottleStop when it is sluggish to move windows around the desktop.

    EIST / SpeedStep needs to always be enabled when using MSR 0x199 to control the FID / VID.

    There are 2 different formulas to convert VID to voltage. One formula is for desktop CPUs and the other formula is used for mobile CPUs.

    MSR 0x194 bit[16] is the unlock enable bit but it looks like you figured that out. My MSR Finder tool can be useful when trying to do some reverse engineering.

    MSR Finder
    http://www.mediafire.com/?b2tg2yfjt27csy3

    It takes a snapshot of the CPU registers and then you can take another snapshot and it will try to compare to see what register has changed. It will save a list of registers that have changed recently and can really speed up the hacking process. :)
     
  8. RVF16

    RVF16 Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Hello unclewebb and thank you for your support.

    When the system gets sluggish it appears to run in 1333MHz or lower, in both Windows and Linux.
    Under Linux i see Xorg toping CPU usage as if it is running at 1000MHz, while switching virtual desktops.
    The problem seems to appear immediately after i do anything that demands high CPU usage, even for a shortwhile.
    I have watched ThrottleStop's CMod column but values stay at 100 constantly.
    Even though FID is locked at 18x (2998MHz) in ThrottleStop, CPU-Z presents lower values of CPU frequency.
    I have uploaded an image of ThrottleStop, under Windows, while the system is sluggish :
    Link : https://www.dropbox.com/s/s23fqziwm6pmw2v/OC.Freq.Prob.jpg

    I have also run your MSR finder tool in several scenarios, tried applying all values under Linux without any change.(without a loop CPU will drop frequency after a while).
    Register 0x01AA switches between 0x000000005EFF103F and 0x000000005E7F103F values even at 1000MHz so i don't think i have found anything useful.
    I have uploaded the comparison results
    Link : https://www.dropbox.com/s/e5ms7l0c47gufvr/CMP.txt

    Regards
     
Similar Threads: Anyone ever
Forum Title Date
Hardware Components and Aftermarket Upgrades Has anyone ever played with the RTM890N-397? Aug 14, 2014
Hardware Components and Aftermarket Upgrades Anyone ever nailed the Dell Inspiron e1505 overclocking? Aug 13, 2013
Hardware Components and Aftermarket Upgrades Has anyone ever seen something like this? Apr 10, 2013
Hardware Components and Aftermarket Upgrades Has anyone here ever replaced their keyboard keys with luminous ones ? Mar 13, 2012
Hardware Components and Aftermarket Upgrades Anyone ever ordered from laptopscreen.com? Mar 17, 2011

Share This Page