Anybody having problems with Rivatuner statistics server in msiab?

Discussion in 'Gaming (Software and Graphics Cards)' started by hertzian56, Nov 20, 2019.

  1. hertzian56

    hertzian56 Notebook Consultant

    Reputations:
    12
    Messages:
    146
    Likes Received:
    52
    Trophy Points:
    41
    I've been using msiab w rtss for gaming onscreen stats for a while but out of the blue about a week ago I get a constant attack of windows saying the "hook" is not working etc and then another saying rtss crashed. Once I click ok they just come back, only after I exit out of msiab does it stop. If I start up msiab it starts all over, so uninstall rtss and msiab works fine. I've searched the internet but all I get is "make sure everything is up to date" etc type stuff. I didn't change drivers at all before or after this started happening. I uninstalled and reinstalled the latest I could find which is 4.6.2, still the same, kinda a bummer. Anyone encounter this an get it working?
    win7x64
    980m
    441.12
     
  2. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,546
    Messages:
    10,459
    Likes Received:
    7,744
    Trophy Points:
    931
    Have you tried downloading latest RTSS package separately?
    I got the same messages after upgrading to 1909 but OSD was working. Backup your settings files of MSI AB and then completely uninstall using Revo or Wise Program uninstaller.
     
  3. hertzian56

    hertzian56 Notebook Consultant

    Reputations:
    12
    Messages:
    146
    Likes Received:
    52
    Trophy Points:
    41
    Yeah I did try that and reinstalled separately. I also just uninstalled msiab/rtss using revo pro and reinstalled the latest msiab/rtss package I could find 4.6.2. I noticed that when I don't have anything setup for OSD it doesn't show the crash though, guess rtss isn't used otherwise or the error I'm getting is tied to the OSD.
    Once I click ok or close program it just keeps cycling again and again. Like I said once I don't have any osd metrics specified it stops and msiab runs just fine. This just came out of nowhere, all of it was working fine for months, I may try an older version I have and get back.
     

    Attached Files:

  4. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,546
    Messages:
    10,459
    Likes Received:
    7,744
    Trophy Points:
    931
    I opened RTSS settings and Reset Cache and some Injection thing and restarted MSI AB/RTSS and it was solved! Check if your AV is blocking RTSS.
     
  5. hertzian56

    hertzian56 Notebook Consultant

    Reputations:
    12
    Messages:
    146
    Likes Received:
    52
    Trophy Points:
    41
    No av dude never had any problems, 3rd party firewall that asks permission for every program. I have had maybe 3-4 problems over 5+ years which I just used bleepingcomputer stuff to get rid of. The way I do things now I'm modular and the OS can be reinstalled quickly, portable programs rock lol. Idk I'll try that and keep with it, it's really only important for new games getting them to 60fps or as close as possible, and temps but never had anything out of the ordinary in anything there really. Fraps still works on most games, I don't think it works with vulcan but afaik I've never used vulcan in a game, heard it's better for rdr2 though but that has dx11 compatibility so not sure have to wait and see on that.

    Edit: AND I use it for light OC, 135, 200. but that's just msiab. that oc didn't change my firestrike score at all though lol
     
    Vasudev likes this.
  6. hertzian56

    hertzian56 Notebook Consultant

    Reputations:
    12
    Messages:
    146
    Likes Received:
    52
    Trophy Points:
    41
    maybe zonealarm blocking it checking online is most I can think of but I don't think that would break it and it was fine b4, idk maybe i did change nvidia drivers in there somewhere I'll reinstall and get back.
     
    Vasudev likes this.
  7. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,546
    Messages:
    10,459
    Likes Received:
    7,744
    Trophy Points:
    931
    Zonealarm doesn't play nice with hooks and stuffs. I faced this issue long time ago and switched to MSFT AV and FW ever since!
     
Loading...

Share This Page