AMD CQ62 CPU post-upgrade problems: keyboard and touch pad not working

Discussion in 'HP' started by ammark, Jan 15, 2012.

Thread Status:
Not open for further replies.
  1. ammark

    ammark Newbie

    Likes Received:
    Trophy Points:
    Hi all,

    I've been googling for answers past 3 days, but havent found anything that works for me conclusively, hence this thread.

    On Thursday I installed the F.27 bios update retrieved from my Compaq model's website through Windows 7. On Friday I opened up the laptop and being the klutz that I am, mistakenly took off the black plastic latches from on top off the ZIF connector for the keyboard. (Despite this warning that I'd forgotten about). Same goes for the small white plastic latches for the Power, USB, Touchpad and Touchpad button ZIFs. Then I replaced my AMD V140 processor with a Turion II P540 processor.

    When reassembling the laptop, the USB zif connector and the Power ZIF connector was put back in place (with some difficulty, and they're still a bit loose) and taped over with scotch tape. Same thing has been done with the Touchpad and Touchpad button ZIF connectors and latches. For the keyboard latch, one of the edges is broken, yet I managed to put it in place and tape it over with the connection set in.

    Now I am having some peculiar problems:

    Initially the Keyboard was not responding despite the F12/WiFi light coming on. I narrowed that problem down to static, and after some hard resets, and more tinkering with the Keyboard connection to the motherboard I've come to the current problem.

    The keyboard now turns on and works in POST and within BIOS. I can even select F8 at Windows boot and select the options with the Keyboard arrows. The Caps Lock light comes on if pressed, and turns off normally when pressed again.

    However, once within Windows, there is no response from Keyboard input. The caps lock key doesnt light up, the Windows key does not open up the program menu, none of the keys work. As for the touchpad and button, neither of those work from the very beginning, and the touchpad lock light doesnt turn on ever when pressed, whether in BIOS, POST or Windows. To navigate, I use a mouse from the right side USB (the one with the ZIF connector that I taped).

    Initially I thought this was a Windows problem, perhaps some drivers or files messed up during one of my aborted boot-ups. However, I tried to run Ubuntu linux live off my pen drive and a similar thing happens. I can initially use the Keyboard and arrow keys to select the Ubuntu options after pressing Esc. But once inside the Unity desktop session, the keyboard does not work as in Windows, and the touch pad also does not work at all.

    Since then I've updated my BIOS to F.29 from the HP site link given in these forums, but still no joy. Should I try installing the WinFlash BIOS update as found here? This isnt listed as compatible with the CQ62s though. However I read that this is an HP BIOS driver issue for HP touchpads here.

    Any ideas on getting the Keyboard working within a running OS?

    Also, what about the ZIF connection makes it work (for the touchpad and touchpad button)? I think the pressure and contact of the cable with the pins is fine, but through the more than 10 computer startups, The touchpad hasnt shown any life once, while the USB and power switch works.

    My setup:
    Compaq CQ62-310AU
    upgraded to AMD Turion II P540 processor
    1x4GB DDR3 RAM
    Windows 7 Home Premium 64-bit
Thread Status:
Not open for further replies.

Share This Page