Alienware M18x R2 PCIe speed stuck at x1 3.0

Discussion in 'Alienware 18 and M18x' started by Mikkel Eriksen, Nov 13, 2018.

  1. Mikkel Eriksen

    Mikkel Eriksen Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    Hello.

    Been using a GTX 870M for some time and decided to upgrade to a GTX 980M.
    installation went good but i noticed my PCIe speed is stuck at X1 3.0

    • Windows 10
    • Using BIOS A13
    • GPU tested under load.
    • using nvidia driver 416.81
    • 980M VBIOS 84.04.2F.00.79
    • GPU-Z Reports it supports PCIe X16 3.0

    anyone experienced the same issue ?

    Best Regards
    Mikkel E.
     
  2. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,287
    Messages:
    5,021
    Likes Received:
    3,314
    Trophy Points:
    431
    Are you in SG or PEG mode?
     
  3. Khenglish

    Khenglish Notebook Deity

    Reputations:
    500
    Messages:
    714
    Likes Received:
    500
    Trophy Points:
    106
    Clean off the GPU's mxm connector with rubbing alcohol. The slightest film on the pci-e pins will prevent it from connecting properly.
     
    Ashtrix likes this.
  4. Mikkel Eriksen

    Mikkel Eriksen Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    Im using stock A13 BIOS. there is no options for either SG or PEG.
    If I want to change those settings i need to flash A12 modded BIOS right ?
    I will try to clean the MXM connector tomorrow :)
     
  5. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,287
    Messages:
    5,021
    Likes Received:
    3,314
    Trophy Points:
    431
    Easy way to check, open device manager and see if only Nvidia GPU is present or also intel GPU.
     
  6. Mikkel Eriksen

    Mikkel Eriksen Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    only GTX 980M is present
     
  7. ssj92

    ssj92 Neutron Star

    Reputations:
    1,186
    Messages:
    2,650
    Likes Received:
    2,721
    Trophy Points:
    181
    How are you measuring that the system is running at x1 speeds?
     
  8. Mikkel Eriksen

    Mikkel Eriksen Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
  9. Mikkel Eriksen

    Mikkel Eriksen Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
  10. ssj92

    ssj92 Neutron Star

    Reputations:
    1,186
    Messages:
    2,650
    Likes Received:
    2,721
    Trophy Points:
    181
    Maybe I missed it but how exactly are you determining it's for sure running at x1 speeds?
     
Loading...

Share This Page