Alienware M17x r4 intel+AMD driver installation

Discussion in 'Alienware 17 and M17x' started by Vermillion1790, Mar 20, 2017.

Thread Status:
Not open for further replies.
  1. Vermillion1790

    Vermillion1790 Notebook Enthusiast

    Reputations:
    0
    Messages:
    47
    Likes Received:
    1
    Trophy Points:
    16
    Hi, i'm an owner of an aliewnare m17 r4 with the following configuration:
    i7-3610QM
    16GB RAM
    1TB SSHD - 500GB - 500GB
    ATI HD7970M 2Gb
    Intel HD 4000
    Bios: A12
    Windows 10 64bit PRO

    Now the problem is only one, i can't install the intel and the amd graphic drivers properly. Both GPU in the device manager display like this:

    vga standard with yellow triangle (the 7970M)
    vga standard (intel hd 4000)

    When i'm going to install (first the AMD drivers and then intel drivers or viceversa tho) the screen become blank (which is normal) during installation, the problem is still blank without any success. I must shut down of course the machine and when i boot it up (with windows 7 was stuck at the windows start up logo and with windows 10 i'm able to go into windows but on the device manager the amd 7970M will be displayed like this):

    ATI HD7970M yellow triangle.

    And just randomly i got again blank screen (this with windows 10 only). Now, i saw somewhere that i should install AMD drivers when only the amd card is avaible (so i should disable the integrated one) i tried even that without success, infact during the amd driver installation the screen goes and remain blank....Could someone tell me the exact order and/or if i should keep both gpu on during drivers installation? Really thank you for replies guys. Hope in some good answers :D

    I tried the latest (15/03/2017 - Crimson ReLive Edition 17.3.2 Optional) and previous (Crimson ReLive Edition 17.2.1 - 22/02/2017) amd drivers, which i took from AMD webside. I even tried the stock alienware on dell support one without success.
     
  2. deadsmiley

    deadsmiley Notebook Deity

    Reputations:
    1,147
    Messages:
    1,614
    Likes Received:
    694
    Trophy Points:
    131
    I always install the Intel driver first if I am not using dedicated mode. I prefer dedicated mode because I can overclock my display if I want to.
     
  3. aaronne

    aaronne Notebook Evangelist

    Reputations:
    321
    Messages:
    465
    Likes Received:
    520
    Trophy Points:
    106
    Use Wagnard's DDU to get rid of old driver (making it in safe mode is better, you must run DDU two times, one for each gpu),

    then install the intel's chipset and gpu driver(start from Dell's one aviable from them site to avoid compatibility issue) and then the Amd's one(mobile one from amd or guru3d).

    Also make sure you can switch beetween them (fn+f7 works only if Alienware OSD was installed) or check bios to see what "graphic mode"is currently set.
     
  4. Vermillion1790

    Vermillion1790 Notebook Enthusiast

    Reputations:
    0
    Messages:
    47
    Likes Received:
    1
    Trophy Points:
    16
    Thank you for reply and support me. Ok, do i have to install them when both vga standard adapters are in the device manager? So i do not need to install intell first then switch into only the AMD one and install the amd drivers right? Because i have read something about this.

    When i'm going to install AMD drivers, do i need to disable driver signin trough f8 menu?

    Also it's my first laptop in UEFI mode. Do i need to enable or disable something in the BIOS, because trough gpu-z it say this

    [​IMG]
     
    Last edited: Mar 21, 2017
  5. aaronne

    aaronne Notebook Evangelist

    Reputations:
    321
    Messages:
    465
    Likes Received:
    520
    Trophy Points:
    106
    Can you post some screenshot or describe your BIOS version?
    Is to investigate about what graphic mode is in use, because seeing both GPUs mean optimus mode..

    To exclude other issue is good to disable "driver signature enforcement". Good catch

    The Alienware's Rep say about the order, don't remember them but usually, starting from chipset's driver, I don't have any issues when reinstalling OS

    UEFI vbios doesn't change anything here, so no need to modify nothing. Gpuz says your gpu's vbios is full uefi compatible (if you want to disable the legacy boot option).
     
  6. Vermillion1790

    Vermillion1790 Notebook Enthusiast

    Reputations:
    0
    Messages:
    47
    Likes Received:
    1
    Trophy Points:
    16
    Here we are. BIOS screens:
    http://imgur.com/a/CdDNL

    Am i missing something? this is the first time i got 2x HDD separate i was thinking maybe i missed up something in the BIOS.

    This afternoon i have proceed to install first intel graphic then i reboot with fn+f7 (switched into amd 7970M) and i have installed 2 type of drivers the latest one: 17.3.2 from amd for be more specific this one:

    non-whql-win7-64bit-radeon-software-crimson-relive-17.3.2-mar15 -
    with this once the computer make the same issues (during installation the screen goes blank than pop up for 1 sec and goes blank again for ever.

    WHQL-Radeon-Software-Crimson-Edition-16.1-64Bit-Win10-Win8.1-Win7-Jan7 -
    with this once seems the drivers working fine but after i launched a game (right after i have installed amd drivers, so only with amd 7970M on the device manager) i got freeze/buzzing and only lines, i didn't repeat this. i only did one time:

    https://missespresso.files.wordpress.com/2011/04/freeze-2.jpg

    Looks like this (i took a photo from google image) but is the same, plus endless freeze/buzzing noise....

    Now i have re-installed windows 10 64bit. Should i download the drivers from dell support site under windows 7 64bit? Which drivers and where you took them? Really thanks for the support. I don't know what can i do....
     
    Last edited: Mar 21, 2017
  7. aaronne

    aaronne Notebook Evangelist

    Reputations:
    321
    Messages:
    465
    Likes Received:
    520
    Trophy Points:
    106
    The screenshot you posted isn't good..I think your 7970m will die shortly;
    Please check with HWINFO32 all your temp (disable in software the "EC" support) if is in accettable range.


    From AMD site remeber to choose the notebook's drivers, on win7 "16.2.2" was the last driver I used,

    Edited:
    on win10 "15.6b" is the only one I remember works well(look to disable WU to prevent driver override).


    For win10 Use Win8/win8.1 drivers from Dell (but you only need Alienware OSD and CC, plus creative software where you must uncheck "extra"during installation).

    I'm really sorry to hear this man
     
    Last edited: Mar 22, 2017
  8. Rymesis

    Rymesis Notebook Consultant

    Reputations:
    5
    Messages:
    104
    Likes Received:
    15
    Trophy Points:
    31
    I'm having the same issue with a 6970M on an Alienware M17x R3, I'll update if I can end up figuring it out.
     
  9. Vermillion1790

    Vermillion1790 Notebook Enthusiast

    Reputations:
    0
    Messages:
    47
    Likes Received:
    1
    Trophy Points:
    16
    About my amd health, i knew there was something wrong. Last time i have fixed an nvidia 260M on my previous alienware m17x r1 by reflowing the chip (i documented well that on this forum) But before doing that i need to throubleshoot everything, you know.

    Ok so about temps. I can't check the temps before installing the drivers of course. Will post the temp later, for what i know with the previously drivers (before get that lines) was about 55°/60°c. About AMD 16.2.2 I think (but not sure) i have found the page, link below for those who have the same problems as me.

    http://support.amd.com/en-us/kb-articles/Pages/AMD_Radeon_Software_Crimson_Edition_16.2.aspx

    Are this drivers right?

    About win10 amd 15.6 i think i have found the right one:

    http://www.hwupgrade.it/download/scheda/5034/driver-amd-catalyst-156-beta/
    This is the only drivers (15.6) what i have found online i think. Otherwise i have found some thread which they say its 15.6 but when i'm going to click on the link it will redirect me on the amd site with the 15.11. This one

    http://support.amd.com/en-us/kb-articles/Pages/AMD_Radeon_Software_Crimson_Edition_16.2.aspx

    About the creative software, what you mean. What software is that? could i find it on dell driver page? under which category in that case? As always thanks for reply
     
    Last edited: Mar 22, 2017
  10. aaronne

    aaronne Notebook Evangelist

    Reputations:
    321
    Messages:
    465
    Likes Received:
    520
    Trophy Points:
    106
Loading...
Thread Status:
Not open for further replies.

Share This Page