Alienware M17X-R2 WON'T TURN ON BY BATTERY OR AC ADAPTOR!!

Discussion in 'Alienware 17 and M17x' started by metlmania1, Sep 3, 2018.

Thread Status:
Not open for further replies.
  1. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    4
    Trophy Points:
    6
    Hi!
    I really need some help as to why my new alienware i have is not working and not coming on here's what happens:

    When i plug in my 220 watt AC Adapter the blue light on the adapter goes off and only comes back on when it is unplugged!!????
    (i bought this on ebay and that's what the description says..)
    lol
    I already have my own dell OEM 240 Watt adapter but NOT the alienware adapter.

    So i am assuming a few of you know what the problem may be but i don't know...

    Can someone enlighten me as to what i can do like reseat the ram or something??

    I am supposed to get it tomorrow and that's why i cannot do any tests on it now because i do not have it yet..

    But when i get it i will keep you guys updated.

    Please FEEL FREE to post any kind of potential fixes for this problem!
     
    Last edited: Sep 5, 2018
    Rengsey R. H. Jr. likes this.
  2. Rengsey R. H. Jr.

    Rengsey R. H. Jr. I Never Slept

    Reputations:
    1,011
    Messages:
    2,638
    Likes Received:
    862
    Trophy Points:
    131
  3. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    4
    Trophy Points:
    6
    so you think the GPU is fried in this situation?

    Thanks and keep posting please! ;)
     
  4. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    4
    Trophy Points:
    6
    because IF it is i think i can fix that with a backup one...
    or even with a gtx 675xm i have..
     
  5. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,481
    Messages:
    5,414
    Likes Received:
    3,856
    Trophy Points:
    431
    Typically a short either in the GPU or the motherboard causes the AC adapter light to go out.
     
  6. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    4
    Trophy Points:
    6
    oh ok
    Well, HOPEFULLY for my sake it is only the GPU... :(:(:(
    But can that be fixed WITHOUT replacing the motherboard or soldering as i suck at soldering lmao
     
  7. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,481
    Messages:
    5,414
    Likes Received:
    3,856
    Trophy Points:
    431
    easy way to test, if you have two cards, remove primary card (left slot), install card from right slot, see if problem persists. if only one card present, buy a cheapo card to test.
     
    metlmania1 likes this.
  8. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    4
    Trophy Points:
    6
    Ahhhhh oh ok =D
    Thank You!
    Also will two gtx 675mx's work in this beast??

    Thank you again!
     
  9. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,481
    Messages:
    5,414
    Likes Received:
    3,856
    Trophy Points:
    431
    675m is terrible card, very prone to dying, slow performance. better to get 680m (broken fan control all models), late 7970M (dell broken fan control, so is clevo v 1.1, clevo v1.2 works fine), or 8970M (clevo 8970M work perfect, but pricey). I have spare dell 680M if you would like to purchase, preflashed with svl7 performance vBIOS. Note: for 675m, 680m, dell/clevo v1.1 7970M, or dell r9 m290x, you will need hwinfo to control fans. only clevo 8970M has native fan control
     
  10. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    4
    Trophy Points:
    6
    hmm..
    how much??

    (On A Strict budget too i have to mention)
     
Loading...
Thread Status:
Not open for further replies.

Share This Page