Alienware m17x R2 wiht GTX 680M

Discussion in 'Alienware 17 and M17x' started by Dwarf King, Aug 26, 2020.

  1. Dwarf King

    Dwarf King Notebook Evangelist

    Reputations:
    47
    Messages:
    323
    Likes Received:
    3
    Trophy Points:
    31
    Hi,
    I recently tried to install a GTX 680M on my Alienware m17x R2 system since my current setup with the 7970m Dell cards seems a bit shaky. After one hour of testing out the witcher 1 the temp reaches around 80 celcius. We all know what happens with that card if it reached 83-85... shutdown.

    Anyway so I went on Ebay and got this GTX 680M card and installed it. However, when I boot up the machine I get a black screen. No Alienware logo, no Windows logo. Just a machine that is powered on with lights in the keyboard.

    How should I understand this? I have googled and done quiet a few researched on it and found only a few ideas. Any GTX 680M users out there with an Alineware m17x R2 system that might wish to share there install and user experiences?

    Best,

    Dwarf King
     
  2. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,565
    Messages:
    5,601
    Likes Received:
    4,029
    Trophy Points:
    431
    If your 7970M still works I strongly recommend you undervolt the card and apply some high end thermal compound. It will outperform the 680M and still receives driver updates, unlike the 680M which stopped last year. You will probably need hwinfo to ramp the fans up. I've had both cards in my M17x R2 and ended up going with the Clevo 8970M as it does not need HWInfo, and undervolts very well. I can play Doom on ultra for hours on end and never crack 80C
     
    TR2N likes this.
Loading...

Share This Page