Alienware 18 BIOS A12 Findings & Fixes

Discussion in 'Alienware 18 and M18x' started by Ultra Male, Sep 26, 2015.

Thread Status:
Not open for further replies.
  1. @tomX

    @tomX Notebook Evangelist

    Reputations:
    135
    Messages:
    555
    Likes Received:
    51
    Trophy Points:
    41
    So let me get this straight : flashing this new vbios on the older AW18 (not the just released one which should come with this vbios as a factory default) with the A12 system bios IS in the end worth it righ?
     
  2. Prema

    Prema Your Freedom, Your Choice

    Reputations:
    8,260
    Messages:
    6,100
    Likes Received:
    15,565
    Trophy Points:
    681
    The new stock AW18 system bios adds legacy support as well as brings throttle to normal levels.

    The new stock AW18 vBIOS (as well as the upcoming mod based on it) fixes the second FAN problem.

    The old and new AW18 are one and the same old system.
     
    reborn2003 and jaybee83 like this.
  3. Tulius

    Tulius Notebook Consultant

    Reputations:
    5
    Messages:
    242
    Likes Received:
    76
    Trophy Points:
    41
    And about the M18X-R2, the new vBIOS would fix the second fan too? Now also analysing the new sBIOS do you think in future the owners of the old M18X-R1 could install the 980M in their machines?
     
  4. Prema

    Prema Your Freedom, Your Choice

    Reputations:
    8,260
    Messages:
    6,100
    Likes Received:
    15,565
    Trophy Points:
    681
    On M18x R2 the new stock vbios throttles down to 400Mhz during benchmarks...

    But you will be able to use the upcoming mod version to fix the FAN until I get around making a specific mod for the throttle bugged systems (like Nikos is testing).

    I haven't looked at the BIOS, yet...
     
    @tomX likes this.
  5. GodlikeRU

    GodlikeRU Notebook Deity

    Reputations:
    165
    Messages:
    1,254
    Likes Received:
    559
    Trophy Points:
    131
    @Tulius I doubt it as M18xR1 can't switch to full uefi
     
  6. rerfy

    rerfy Notebook Enthusiast

    Reputations:
    5
    Messages:
    46
    Likes Received:
    17
    Trophy Points:
    16
    After upgrade sBIOS to A12, my 980M throttles in Whitcher 3 up to 1000Mhz. On A10 works continuously on 1200Mhz (+75Mhz)
    Second GPU FAN works, DELL H/W test all pass without errors, Legacy (CSM) boot and win7 works.
     
    Kade Storm and Mr. Fox like this.
  7. Koonchao

    Koonchao Notebook Enthusiast

    Reputations:
    5
    Messages:
    13
    Likes Received:
    10
    Trophy Points:
    6
    Hi Prema. I'm a fairly new AW18 (880m sli) owner and I recall reading about the gpu throttling issues and fan table problems users where having after they bought their machines last year. What you just posted kind of sounds like the recent update fixes all of that and suggests it's basically giving AW18 owners the machine they were supposed to have one year ago (ignoring some or most of the overclocking aspects). Would you agree with that conclusion or am I misunderstanding something?
     
    Prema likes this.
  8. Awhispersecho

    Awhispersecho Notebook Evangelist

    Reputations:
    66
    Messages:
    350
    Likes Received:
    305
    Trophy Points:
    76
    I was actually waiting to see the response to your question here. Did you flash to the new A12? If you did, how does it seem? Curious as to whether this really gives us non throttling 880's that we paid for. Fans aren't as big a deal to me. Even under heavy load, I don't ever go above 80c and I can manually tweak the fans so I am in no rush to start fooling around with things right now unless this fixes the throttling so I can use newer drivers. Let me know.
     
  9. rerfy

    rerfy Notebook Enthusiast

    Reputations:
    5
    Messages:
    46
    Likes Received:
    17
    Trophy Points:
    16
    Mr. Fox likes this.
  10. kenny27

    kenny27 Notebook Deity

    Reputations:
    293
    Messages:
    908
    Likes Received:
    164
    Trophy Points:
    56
    I'm not sure why your second fan doesn't work, mine works fine, I thought that was only a problem on the 18...

    I am using the dell vbios and its working ok... the clocks fluctuate between 1038-1127 but I still get 19.0-19.3K gpu score in Firestrike using j95's 350.12 drivers. 3DMark11 gpu is around 23K
    I did get excited yesterday and tried legacy mode with the "new" vbios after hearing legacy mode what working on the 18, but was greeted by 8 beeps... should have known better.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page