Alienware 17 R5 (R1) BIOS Unlocked!

Discussion in 'Alienware 17 and M17x' started by Striker1234, Mar 12, 2017.

  1. jaximus

    jaximus Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    15
    So I've just tested my 780m and 4930mx with the other laptop and they still work fine. I also tried to start the problematic one without any gpu but no luck. Still 8 beeps. Did an NVRAM reset for the nth time and still just the 5 beeps first, then 8 beeps after restart. Also tried with an external tv using HDMI. So looks like I'll be doing some lcd swapping. First the 60hz to test if I have a bricked panel, then 120hz to see if the edp connector overrides the disabled igpu setting somehow. Or kick starts the non-igpu mode I guess. If nothing, then its time to order a new bios chip and wait the daunting 2 months.
     
    Last edited: Aug 7, 2020
  2. jaximus

    jaximus Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    15
    So I just threw in the 120Hz screen and now the 8 beeps are gone only I get a blank screen with some very faint, almost unnoticeable horizontal distorting lines (intermittently). Only the cpu fan is turning on and not the gpu's. I've got a 770m in there and have also tried with the 880m. Don't want to risk putting in my 780m. I tried an NVRAM reset again and also a blind flash with the USB as per Striker123s method. And yes, I'm being super careful in following the instructions exactly! At this point I don't think it's a soft brick anymore. Although the hdd light on palmrest blinks for a while, stops. Then blinks again and all the FX lighting powers up just like it always did. Which, leads me to try one more thing -put my 4930mx back in once more because I'm using the 120hz screen.

    Anyone with a comment or advice please post.
    Thanks!
     
  3. Danlem

    Danlem Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hello, I have a laptop with a 60Hz screen, installed gtx 970m 6gb, where can I download the BIOS so that the usual drivers can be installed on it? If I disable the built-in card, 8 beeps. I have to reset the bios. I also found the unlocked bios aw17-A17 + Unlocked_v1.3 and aw17-A16 + Unlocked_v1.4, which line to change in the Hex editor. Thanks for the help
     
  4. jaximus

    jaximus Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    15
     
  5. jaximus

    jaximus Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    15
    You can only change the ST in the A16+ not the A14+. For that one and (the A17+ I believe), you have to send your ST to someone who can do it for you. For the A16+ do a search and replace all for “YOUR_ST” and put in your 7 character ST.
     
  6. Danlem

    Danlem Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Thank you for the answer. Please tell me which BIOS does gtx 970m support without driver mod, in standard mode? There are links in the topic, but there are no data files for them.
     
  7. jaximus

    jaximus Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    15
    Any unlocked Bios will work with anything after an 880m. But you still have to do a vBios update with all those cards for the ranger. I don't know how to do it because I never ran past kepler.
     
  8. Baqir

    Baqir Notebook Consultant

    Reputations:
    0
    Messages:
    263
    Likes Received:
    19
    Trophy Points:
    31
    Hey can i know the process of unlocked bios last time i did i bricked the mobo ended up buying a new one
     
  9. Danlem

    Danlem Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    well, I wrote my service tag, installed the BIOS a14+, still when you turn off the igfx card have 8 beeps. Maybe someone has a file from (#183;#184 post) this topic. They seem to have changed the device id for the video card. I am using windows 7 and have a problem installing drivers. I also tried the 1060m card, 8 beeps. Most likely I need a 120Hz screen via edp. just 970m should work without Optimus? or am I wrong? vbioses is from dell.
     
Loading...

Share This Page