Alienware 17 R5 (R1) BIOS Unlocked!

Discussion in 'Alienware 17 and M17x' started by Striker1234, Mar 12, 2017.

  1. otterrat

    otterrat Notebook Enthusiast

    Reputations:
    0
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    6
    ....but both panels are 1080p, the laptop came out in 2013, bro :)
     
  2. jaximus

    jaximus Notebook Enthusiast

    Reputations:
    0
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    15
    Your right, but your still pushing the bandwidth enough I'm assuming -that you need to update/change the vbios on the gpu. The 980m was never officially supported. I'd love to do the upgrade to a 980m too but I've got a lot of xp 32bit apps that won't run in win 7 or win 10 so I dual boot with xp. And the UEFI firmware on 95% of laptops is 64bit, so that makes me SOL.

    I can't even update my bios to the unlocked because its got these protected range registers (microcode that Dell puts in place because they don't want people flashing them). So I either need to find another laptop and have all my fingers and toes crossed that its not "protected", or another "proper" revision screen.

    More, even if I don't need an unlocked bios to run the 780m card and 120hz screen in legacy, When I try it I get a black screen with some flickering and NO 7 or 8 beeps like everyone is talking about. I've got the right D02 3D screen too.
     
    Last edited: Jun 30, 2020
  3. IVHOTEP

    IVHOTEP Notebook Consultant

    Reputations:
    20
    Messages:
    142
    Likes Received:
    45
    Trophy Points:
    41
    Just curious..what BIOS load time you people have at task manager?
    Mine is 12.something secs now with this unlocked bios, sure it was about 5 with stock.
     
    Last edited: Jul 17, 2020
  4. IVHOTEP

    IVHOTEP Notebook Consultant

    Reputations:
    20
    Messages:
    142
    Likes Received:
    45
    Trophy Points:
    41
    Edit: Now its 27!
    I added more RAM so thats probably it, but i'm pretty sure that once on 4*4GB 1600Hz I had 5 sec, on 2*8 1867Hz it was 12 and now on 4*8GB 1867Hz its 27secs.
    Bought 4*8GB HyperX 1867 RAM a while ago but one stick was faulty so today I got another one

    Something weird with RAM, I can't get it to work at 1867Hz, it stays at 1600.
    I tried that xm1 profile in bios and had to do a nvram reset coz it softbricked.
    Now having those extra two sticks under palmrest I kind of don't want to mess with another nvram reset.
    Any manual procedure? Am I missing something?
    Thought it was plug&play
     
  5. Ashtrix

    Ashtrix ψυχή υπεροχή

    Reputations:
    2,071
    Messages:
    1,927
    Likes Received:
    2,667
    Trophy Points:
    181
    Mine is at 7.7 seconds right now (do not know if it's same or not for every boot, also has the impact with the applications added to the startup), if I connect my big SATA HDDs to the USB and boot it up it ramps up to 20 due to checking the HDDs, apparently the BIOS bootup is also related to any mechanical disks as well USB + SATA both I guess even if you disable the USB boot up or such, have to check.

    As for the RAM kit in my sig, it was PnP, did nothing it just worked when I plugged them into the system, replacing the old 8GB 1600MHz 2x4GB kit.
     
  6. Field Alienware17

    Field Alienware17 Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Hi guys, I've downgarade my BIOS to A14 and deleted mcuupdate.dll in System32 folder, and now I can see my CPU Microcode is 1C in HWiNFO64.
    However, after all that, i still cannot utilzie the 'sleep bug'. No matter what I do, CMD always give this alert - Error 28: Protected Range Registers are currently set by BIOS.

    Anyway, I just want to chech with you guys, is there an option to adjust TDP (power consumption) for MXM slot in the unlocked BIOS?
    Alienware set video card TDP to 100w, and GTX 1070mxm requries at least 115w. If TDP is not adjsutable in unlocked BIOS, I shall quit all that effort.

    Many thanks!

    Alienware 17R1/4940mx/MSI 1070 mxm/Win10 19041.388
     
  7. Reciever

    Reciever D! For Dragon!

    Reputations:
    922
    Messages:
    4,300
    Likes Received:
    2,629
    Trophy Points:
    231
    Im not aware of any 100w limit on the MXM. There is an EC lock at about 118w with my 1070 though, 115w shouldnt have any issues. Highest stock TDP for the 1070 is 115w, simply tune for best performance under that limit and leave it alone after that.
     
  8. Field Alienware17

    Field Alienware17 Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Yep, it was written in MSI 1070 Vbios that target power supply is 115w, but 17R5 can only provide 100w through MXM port. I assume it could be adjsuted through motherboard BIOS.

    But the 'sleep bug' doesn't work for me, so I never have a chance to explore the unlocked BIOS.
     
  9. IVHOTEP

    IVHOTEP Notebook Consultant

    Reputations:
    20
    Messages:
    142
    Likes Received:
    45
    Trophy Points:
    41
    Didnt work for me either, I almost gave up.
    Try disabling virtualization in stock bios, get offline and try again
     
  10. Reciever

    Reciever D! For Dragon!

    Reputations:
    922
    Messages:
    4,300
    Likes Received:
    2,629
    Trophy Points:
    231
    This is false, I adjust nothing MXM port will supply it.
     
Loading...

Share This Page