Alienware 17 R5 LCD Error.

Discussion in '2015+ Alienware 13 / 15 / 17' started by code9523, Jan 31, 2020.

  1. code9523

    code9523 Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    12
    Trophy Points:
    6
    Hello!
    I have 17 R5 (i9 1080) with an issue. Recently I broke my screen (4k) I decide that i can replace it with Full HD screen and cable as there are 17 R5 with full hd resolution so i purchased the whole lid assembly on ebay. After i connect it the lid laptop gives me lcd error code! It beeps 8 times and it blinks power button 8 times. I connect my cracked 4k and it works fine without any errors so connection is good. I replaced the full hd lid and purchased another one same full hd and i get same error! What can be wrong with it? It looks like a bios error to me as on of a times i got laptop started with external monitor and it gave me: video subsystem error! Laptop works fine the GPU and CPU pass all tests. Just need advice how to connect the FHD creen and get rid of the error code.

    Thank You!
     
  2. TriBeard

    TriBeard Notebook Consultant

    Reputations:
    23
    Messages:
    286
    Likes Received:
    52
    Trophy Points:
    41
    I'm not sure what the issue could be there, I know some people have gone from the 1080 screens to 4k/1440p and haven't had issues. I don't know what you spent on the lid assembly, but I bought a 4k screen on amazon for about 150 bucks or less and have been using that in mine for more than a year now. That's probably the way I would go instead of spending more time and effort on how to get the downgrade to work right.
     
  3. code9523

    code9523 Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    12
    Trophy Points:
    6
    My goal was to get FHD screen working. And yes 4k screen works fine. I just want to figure out what is wrong with it or have i just switch something or it is laptop limitation?
     
Loading...

Share This Page