Alienware 17 R1 vs 980m. Going to need help on this one.

Discussion in 'Alienware 17 and M17x' started by Confused Troll, Apr 5, 2020.

  1. javers

    javers Notebook Guru

    Reputations:
    42
    Messages:
    74
    Likes Received:
    47
    Trophy Points:
    26
    Hi @Confused Troll

    If you have a regular 980m (non-gsync) it should also be possible to make a custom system bios that you could flash onto your R1 to give native driver support. This would also rule out errors in the inf and then we are just down to making sure you have the correct vbios on the card (but in my experience most seem to 'just work' as is).

    Javers
     
  2. Confused Troll

    Confused Troll Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Hello javers
    I think you got me there, I don't actually know whether it's a g-sync card or not. Here should be where I bought it from, and they list G-sync as a feature, but from what I've found, the g-sync feature seems to be a part of the 980m. Do correct me if I'm wrong.

    As for flashing a custom sBIOS, I guess we can try. Let me know what is needed to make it and how to backup just in case.
     
  3. javers

    javers Notebook Guru

    Reputations:
    42
    Messages:
    74
    Likes Received:
    47
    Trophy Points:
    26
    OK lets check and make sure one way or the other, could you post a screen shot of the card's Hardware ids from device manager (properties the card -> details tab -> hardware ids) like below.
    upload_2020-4-6_15-2-19.png
    Javers
     
  4. Confused Troll

    Confused Troll Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Here you go.
     

    Attached Files:

  5. Baqir

    Baqir Notebook Consultant

    Reputations:
    0
    Messages:
    293
    Likes Received:
    21
    Trophy Points:
    31
    let me know when you make it working. because i am playing to upgrade too
     
  6. Baqir

    Baqir Notebook Consultant

    Reputations:
    0
    Messages:
    293
    Likes Received:
    21
    Trophy Points:
    31
    Were you able to make it work? Any updates
     
  7. Confused Troll

    Confused Troll Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Hello Baqir.

    Javers is helping me with this, but we are not done yet. Currently, we're at an A17 unlocked BIOS that changes the hardware ID in SG, but not PEG and the card still won't work as it should.
     
  8. IVHOTEP

    IVHOTEP Notebook Consultant

    Reputations:
    25
    Messages:
    152
    Likes Received:
    48
    Trophy Points:
    41
    A17 unlocked, where?
     
  9. javers

    javers Notebook Guru

    Reputations:
    42
    Messages:
    74
    Likes Received:
    47
    Trophy Points:
    26
    @IVHOTEP We're still working on it, will post here as soon as its done. Hopefully not much longer!

    Javers
     
  10. Confused Troll

    Confused Troll Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Well, sadly the results so far are not promising. I'm now running an A16 unlocked sBIOS which should allow for the 980m to work, but nope. We tried a couple of vbioses and the closest we got was (as far as gpu-z is concerned) to see everything but the Bandwidth and Bus Width. Of course, the issue that I can best describe as "fuzzy lines" had never ceased while on PEG mode.

    The fuzzy lines I can detail as lines of digital fuzz that would cover most of the screen with spaces in-between. I found that they stopped fuzzing (became static) when mousing over them and windows inverted cursors would adjust appropriately to the background pixels. But there would always be a minimum amount of screen covered by them, which is not to say they would cover the whole screen, I would say less than 50% of it. They would be on the screen from the moment the screen lights up while booting.

    I will try to get my laptop to the worshop that installed the card on Monday or Tuesday, if cleaning the contacts would help, although they were cleaned on installation.

    So, thoughts, ideas and whatnots?
     
Loading...

Share This Page