Alienware 17 R1 unlock bios - disable intel GPU?

Discussion in 'Alienware 17 and M17x' started by ThisIsBrutus, Mar 13, 2017.

  1. ThisIsBrutus

    ThisIsBrutus Notebook Consultant

    Reputations:
    20
    Messages:
    250
    Likes Received:
    30
    Trophy Points:
    41
    Hello everyone,

    So, here's the story:

    I've been having some troubles with my AW17 and some screen artifacts, long story short I/we/Dell have kinda narrowed it down to being CPU or motherboard issues.

    Here is the link if you want to read but tbh its just troubleshooting back and forth: http://forum.notebookreview.com/threads/alienware-17-880m-screen-artifacts.802347/

    MickeyD suggested that I tried unlocking the bios and disabling the intel GPU, and this is where I need your help:

    First question - Is this possible on a AW17 R1?

    Second - If yes, how? My knowledge of bios is very limited so I am a bit cautious before jumping into it.


    Looking forward to your answers - Thanks :)
     
    MickyD1234 likes this.
  2. goodstone

    goodstone Notebook Consultant

    Reputations:
    176
    Messages:
    140
    Likes Received:
    3
    Trophy Points:
    31
    You don't need unlocked bios to enable nvidia only.

    ID-GFX key on function key at top of keyboard disables/enable intergrated graphics.

    I use this for oculus.
     
  3. ThisIsBrutus

    ThisIsBrutus Notebook Consultant

    Reputations:
    20
    Messages:
    250
    Likes Received:
    30
    Trophy Points:
    41
    Either it's not what I am looking for or it's not working as I hoped it would do. Thanks alot for the response anyways :)
     
  4. Raidriar

    Raidriar Notebook Virtuoso

    Reputations:
    862
    Messages:
    3,739
    Likes Received:
    1,986
    Trophy Points:
    231
    You can switch gfx in unlock BIOS from IGFX (intel only) to PEG (AMD or NVIDIA only) to test if dGPU is failing or notebook panel is failing. My money is on the dGPU.
     
  5. ThisIsBrutus

    ThisIsBrutus Notebook Consultant

    Reputations:
    20
    Messages:
    250
    Likes Received:
    30
    Trophy Points:
    41
    @Raidriar

    Thanks! I think the dGPU is working fine as it is able to output to an external monitor without artifacts, and the artifacts are there even with the dGPU physically removed from the laptop.

    But according to a dell rep all output to the integrated monitor goes through the CPU/iGPU, which is not the case when outputting to an external monitor, which is why I want to figure out a way to completely disable the iGPU since that may be what the problem is.
     
  6. Raidriar

    Raidriar Notebook Virtuoso

    Reputations:
    862
    Messages:
    3,739
    Likes Received:
    1,986
    Trophy Points:
    231
    Dell reps are borderline retarded 99% of the time. When you do fn + F7 to switch to dGPU (or set BIOS to PEG, that's all FN + F7 does), the intel GPU is set to passthrough and is not active at all. Not active in the BIOS, not active in Windows. It literally passes right through it. think like an open gate. if you have it set to SG (optimus + intel gpu), the gate is open, but with a filter (intel GPU filters signal to activate dGPU when necessary).

    That being said, if your issue doesn't appear on external monitors, your internal LVDS display cable is probably damaged and needs replacing. I've never heard of an onboard intel GPU failing. Not intel hd 2000, 3000, 4000, or 4600.
     
    Ashtrix and goodstone like this.
  7. ThisIsBrutus

    ThisIsBrutus Notebook Consultant

    Reputations:
    20
    Messages:
    250
    Likes Received:
    30
    Trophy Points:
    41
    Thanks for your response!

    F7 is volume down, F5 is "I/D GFX" so i tried that. Nothing seems to happen at all.

    Looking through the BIOS now and I can't seem to find anything about PEG.

    The only mention is under Advance - Overclocking feature, there is "DMI/PEG Ratio" set at 5:5, but I don't think this is what I'm looking for no?

    Edit: About the LVDS cable - the Internal monitor works fine when using the HDMI-in on the laptop, not sure if thar debunks anything.
     
  8. Raidriar

    Raidriar Notebook Virtuoso

    Reputations:
    862
    Messages:
    3,739
    Likes Received:
    1,986
    Trophy Points:
    231
    My mistake, it is FN F7 on the M18x/M17x. PEG/SG only appears in the unlocked BIOS. If you are able to see the intel hd graphics after rebooting with FN +F5 and you are unable to disable it, this means that the 880M is also running in tandem. Most likely you have an issue with the 880M.
     
  9. ThisIsBrutus

    ThisIsBrutus Notebook Consultant

    Reputations:
    20
    Messages:
    250
    Likes Received:
    30
    Trophy Points:
    41
    @Raidriar

    I can disable it from the device manager but the fn - f5 does nothing.

    I'm open to all suggestions at this point but I just don't think the 880m is to blame.

    Simply because of the fact that the computer has exactly the same problems with the 880m physically removed from the case and sitting on the desk.
     
  10. maxslo

    maxslo Notebook Deity

    Reputations:
    211
    Messages:
    838
    Likes Received:
    188
    Trophy Points:
    56
    i can comfirm that this sounds a lot like a problem i had, and it was infact the motherboards fault, ive even replaced the cpu but it made no difference, when running off iGPU there would be heavy pixel artifacting on screen, but when running on 6990M there was none. PEG should not solve your problem, but atleayt it will make it go away as long as you dont need to switch to IG again ;)

    Sent from my LG-H850 using Tapatalk
     
Loading...

Share This Page