Alienware 17 R1 - GTX 970m upgrade strange issue - please hepl! :P

Discussion in 'Alienware 17 and M17x' started by Qrac, Feb 23, 2019.

  1. Qrac

    Qrac Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    6
    Hi guys, I need some advice from someone experienced enough with this kind of things. Thing is that I took GTX 970m card from MSI GT72 (DEV.1618), not sure but possibly GSYNC card which is probably reason of what I'm just going to elaborate.

    Issue is that if using Optimus, Nvidia is not used, I cannot make it to run even everything seems to be fine under device management.

    If I disable IGFX I can use Nvidia normally without issues EXCEPT: after Alienware POST logo and rotating circle screen remains black and I have to put it to sleep, after waking it displays normally and everything else is normal.

    I tried various different drivers, 344, 388, 417, 419,... etc, every driver is acting same.
    Tried also various VBIOS, from MSI, Clevo, unverified,.. everything same.
    Currently using unlocked A14+ but on official A16 also couldn't use Nvidia with Optimus active.
    My screen is ordinary FHD 60Hz panel.

    I don't know what makes it display after waking from sleep, but I guess with some script I could trigger it manually. However, any advise would be appreciated :)
     
  2. javers

    javers Notebook Guru

    Reputations:
    36
    Messages:
    54
    Likes Received:
    33
    Trophy Points:
    26
    Hi Qrac,

    I had exactly the same problem with an MSI 970m in the R1, screen would always black out when windows started and nvidia driver kicked in, sleep / resume wouuld bring it back. Like you tried every combination of vbios / nvidia driver but couldn't solve it. My guess was something is slightly different with the msi revision of the 970m pcb.

    In the end i used Optimus to get around the problem, if yours isn't switching between nvidia / intel gfx then the modified .inf file probably isn't right. Have you tried using the J95 Optimus versions? They worked for me. https://premamod.wordpress.com/2017/08/15/j95-nvidia-inf/

    Javers
     
Loading...

Share This Page