Alienware 17 R1 from 880m to 980m problem

Discussion in 'Alienware 17 and M17x' started by merco0, Jul 9, 2020.

  1. merco0

    merco0 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Hello friends,

    Short story: my old 880m burnt down so I had to get a new gpu so I chose gtx 980m. Got it from aliexpress.
    Right after I've installed it I started getting 8 beeps. So i plugged in to my TV via hdmi cable and then my laptop booted up normally. So then I downloaded the latest GPU drivers (451.48) for 980M. I had to modify nvdmi.inf file, disabled driver signature authentication and installed the drivers without an error. Everything seems to be good with the gpu, I can play games etc. but after every restart I keep getting 8 beeps until I connect my laptop to TV via hdmi cable. Anyway I can fix this?

    Alienware 17. A17BIOS
    i7-4910MQ

    Hardware ID:
    PCI\VEN_10DE&DEV_13D7&SUBSYS_05AE1028&REV_A1
    PCI\VEN_10DE&DEV_13D7&SUBSYS_05AE1028
    PCI\VEN_10DE&DEV_13D7&CC_030000
    PCI\VEN_10DE&DEV_13D7&CC_0300

    Lines I've changed:
    %NVIDIA_DEV.13D7.05AE.1028% = Section043, PCI\VEN_10DE&DEV_13D7&SUBSYS_05AE1028

    NVIDIA_DEV.13D7.05AE.1028 = "NVIDIA GeForce GTX 980M"
     
    Last edited: Jul 10, 2020
  2. Baqir

    Baqir Notebook Consultant

    Reputations:
    0
    Messages:
    274
    Likes Received:
    20
    Trophy Points:
    31
    can you post the picture of your vbios i mean gpu z. because drivers has nothing to do with the 8 beeps code
     
    Last edited: Jul 9, 2020
  3. merco0

    merco0 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
  4. merco0

    merco0 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Hope that helps
     
  5. Baqir

    Baqir Notebook Consultant

    Reputations:
    0
    Messages:
    274
    Likes Received:
    20
    Trophy Points:
    31
    can you flash this vbios after backing up your official one if this one doesn't work the problem is with your screen.
     

    Attached Files:

  6. merco0

    merco0 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    So I'v flashed the vbios with your given file but no success. But the screen is working fine, I only need to turn on the computer using hdmi cable connected to TV then I can use the laptop without it. I doubt it's the screens problem.
     
  7. Baqir

    Baqir Notebook Consultant

    Reputations:
    0
    Messages:
    274
    Likes Received:
    20
    Trophy Points:
    31
    Are you on 60hz or 120hz, could be a faulty gpu does the laptop work fine without the gpu
     
  8. merco0

    merco0 Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Well, either on 60 hz or 120 hz I still get the beeps. I can't really try testing without the gpu since I don't have integrated one. I'll bring the laptop to someone who fixes them, maybe I'll get some answers. Thanks anyway.
     
Loading...

Share This Page