Alienware 17 R1 780m change to 1070 gtx no screen

Discussion in 'Alienware 17 and M17x' started by chokolademan, Mar 9, 2019.

  1. TheReciever

    TheReciever D! For Dragon!

    Reputations:
    490
    Messages:
    2,872
    Likes Received:
    1,687
    Trophy Points:
    181
    If he got the laptop with a 120hz panel its unlikely he/she has the LVDS panel.
     
    chokolademan likes this.
  2. chokolademan

    chokolademan Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    6
    Originally the laptop didn't have a lvds 60hz panel. But maybe that is an option which I could invest in if all else fails.

    For now I ordered a hardware flasher, hopefully the 6 beeps could also mean the vBios was incompatible and only needs the MSI one.
    When the flasher arrives, I want to put the MSI vBios on, fixes PEG output and restores world peace. I think it's the last thing I can do (I can think of anyway :) )
     
  3. chokolademan

    chokolademan Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    6
    Did someone who also put in the en1070 zotac model also had to external flash it?
    And also got no screen (no backlight, no bios, no logo, no hdmi)?
     
  4. Striker1234

    Striker1234 Notebook Consultant

    Reputations:
    81
    Messages:
    240
    Likes Received:
    249
    Trophy Points:
    56
    Hello!

    You should be able to flash with the normal software since is not a modded firmware.

    Just boot with HDMI Connected and use the external screen to flash it.

    From what I'm reading, maybe the card is damage... :S

    You will have to flash it with external programmer to be sure.
     
    chokolademan and Ashtrix like this.
  5. chokolademan

    chokolademan Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    6
    I got the equipment for external flashing and could succesfully flash the bios. But unfortunately the card still didn't work and still got error codes about gpu failure and no internal or external output. So it's definitely damaged.
    But thanks for all the help. Learned and documented a lot about all the different setups and hardware of the Alienware, plus software and hardware flashing of chips.
    Problably I'll give it another go with a different mxm :)
     
  6. TheReciever

    TheReciever D! For Dragon!

    Reputations:
    490
    Messages:
    2,872
    Likes Received:
    1,687
    Trophy Points:
    181
    Yeah its likely to have died on the way in shipment then.
     
  7. Rengsey R. H. Jr.

    Rengsey R. H. Jr. I Never Slept

    Reputations:
    972
    Messages:
    2,492
    Likes Received:
    760
    Trophy Points:
    131
    Never made it out of delivery ... let’s have a moment of silent...
     
  8. TheReciever

    TheReciever D! For Dragon!

    Reputations:
    490
    Messages:
    2,872
    Likes Received:
    1,687
    Trophy Points:
    181
    I had a number of failed upgrades and each was more disheartening than the last. Almost started to think I just couldn't upgrade the gpu but this last time worked out nicely. Keep that info and try again after you get your money back.
     
  9. kaibsora

    kaibsora Notebook Consultant

    Reputations:
    10
    Messages:
    131
    Likes Received:
    22
    Trophy Points:
    31
    Did you happen to make sure that legacy mode was turned off? I also remembered reading somewhere that windows 8.1 didnt play well with maxwell and up gpu's on our machines

    Sent from my overclocked dumb phone using a smartapp
     
  10. chokolademan

    chokolademan Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    6
    Sorry for my late reply, the card was broken and left the laptop alone for a while. Legacy mode was off where possible. Maybe I'll try windows 10 :) But the card would not even get into bios or display anything.
    But I'm not giving up, I'm now going for a second try with a Eurocom :)
     
Loading...

Share This Page