Alienware 15 disappointing performance in BF4

Discussion in '2015+ Alienware 13 / 15 / 17' started by jivemaster, Feb 17, 2015.

Thread Status:
Not open for further replies.
  1. jivemaster

    jivemaster Notebook Consultant

    Reputations:
    0
    Messages:
    106
    Likes Received:
    2
    Trophy Points:
    31
    Hi guys, my Alienware 15 finally showed up yesterday so I've being playing some Battlefield 4 to check out the performance. So far I'm a bit disappointed and not sure if it's me or not, and wanted to see if others are experiencing the same as me.

    My config is the i7 4710HQ CPU, 8GB ram, 980m GPU, 1080p screen, 256GB SSD, running Windows 8.1.

    In BF4, I'm finding I'm only averaging about 30-35fps on high settings, which just doesn't seem right. Reviews of the 980m peg the card capable of average frames around 60fps on ultra. So 30fps on high seems to be under half the expected performance in BF4 for this GPU. On ultra the game is unplayable (about 20-25fps).

    This is with both the stock 344.27 drivers that ship with the machine as well as the newer 347.xx drivers. I have the power plan on high performance (but I have not checked the settings there thoroughly). I'm pretty sure however that the GPU is set to max performance under that plan.

    I understand that the performance *will not be identical* to other machines in the market due to the weaker PSU that ships with the Alienware 15, as well as the differences in configurations (eg: different RAM, CPU etc), but I would have expected that I'd be getting close to the above frames per second (certainly not half).

    Is anyone else getting disappointing frames in Battlefield 4 (or other games)?
     
  2. Game7a1

    Game7a1 ?

    Reputations:
    470
    Messages:
    3,075
    Likes Received:
    936
    Trophy Points:
    181
    Have you updated the BIOS? It might fix this issue.
     
  3. jivemaster

    jivemaster Notebook Consultant

    Reputations:
    0
    Messages:
    106
    Likes Received:
    2
    Trophy Points:
    31
    The A02 update? Not yet. Worth trying?
     
  4. Game7a1

    Game7a1 ?

    Reputations:
    470
    Messages:
    3,075
    Likes Received:
    936
    Trophy Points:
    181
  5. scodino

    scodino Notebook Enthusiast

    Reputations:
    0
    Messages:
    13
    Likes Received:
    2
    Trophy Points:
    6
    That performance is really disappointing. Are you using the stock 180W PSU?

    Let me know if you get a better performance after Bios update. I'm waiting my Alienware 17 with similar spec and the only game that I play is BF4.


    Sent from my iPhone using Tapatalk
     
  6. jivemaster

    jivemaster Notebook Consultant

    Reputations:
    0
    Messages:
    106
    Likes Received:
    2
    Trophy Points:
    31
    Yep just the stock 180w PSU at the moment.

    I haven't tried any other games yet, but not looking great so far. Will perform the suggested BIOS update tonight and report back.

    I will mention that the machine does not sound like its being taxed under current load - the fan is hardly audible and nothing is overly hot to the touch. The hope is something is artificially holding it back software wise and/or the PSU just isn't enough.
     
  7. Mrtoad88

    Mrtoad88 Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    Make sure bf4 is utilizing the 980m and not the igpu. Nvidia control panel.
     
  8. craigery81

    craigery81 Notebook Evangelist

    Reputations:
    13
    Messages:
    312
    Likes Received:
    52
    Trophy Points:
    41

    Yeah I would say the same thing. Make sure you are actually using the gtx 980m instead of the igpu. Make sure you change your performance to high. Make sure you are connected to your ac adapter as well.
     
  9. jivemaster

    jivemaster Notebook Consultant

    Reputations:
    0
    Messages:
    106
    Likes Received:
    2
    Trophy Points:
    31
    It's definitely utilising the 980m (I've had a few Optimus machines in the past). But yes that was one of the first things I checked. Forcing the game to the Intel GPU gives a measly 5fps ;)

    As mentioned in the OP power plan is set to high performance (but may need to recheck the settings in there). PSU is definitely connected.

    Many thanks for these suggestions though, hopefully we'll find the answer.

    Would like to hear from other Alienware 15 owners if they're around. Very interested to hear what kind of performance they're having in BF4 (and other games for that matter).
     
    Last edited: Feb 18, 2015
  10. craigery81

    craigery81 Notebook Evangelist

    Reputations:
    13
    Messages:
    312
    Likes Received:
    52
    Trophy Points:
    41
    Check your temps and let us know what you are reading.

    I am curious about this as well because I am about to place an order for a 15...if the performance suffers this bad from an insufficient psu then I will have to make sure to get the 240w when I order.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page