Acer Predator (Vega 56+Ryzen 2) Helios 500

Discussion in 'Acer' started by ThatOldGuy, Jun 3, 2018.

Tags:
  1. Deks

    Deks Notebook Prophet

    Reputations:
    1,145
    Messages:
    4,771
    Likes Received:
    1,906
    Trophy Points:
    231
    The Acer Helios 500 has a desktop Vega 56 GPU in it... so, technically, the desktop drivers should work fine...
    Admittedly, the laptop version was modified to work in a laptop (even though it uses desktop grade drivers).
     
  2. Uckaynotebook

    Uckaynotebook Notebook Enthusiast

    Reputations:
    0
    Messages:
    22
    Likes Received:
    13
    Trophy Points:
    6
    Tried fresh install and with ddu, still not fixed. Tried different versions of adrenalin 2020 and nothing. Just settled with the recomended version. Dont really mind the sleep anyways.
     
  3. Megol

    Megol Notebook Evangelist

    Reputations:
    111
    Messages:
    554
    Likes Received:
    74
    Trophy Points:
    41
    Didn't work here either.
     
  4. valerboss

    valerboss Newbie

    Reputations:
    5
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    6
    Has anyone succeeded pushing the GPU higher than 1500Mhz? I tried different power play tables, including desktop ones for 56 and 64, but no matter what I'm getting black screen crash if I apply more than 1480 under load. Any recommendations? Right now I'm running 1450/920 as somewhat stable OC, still a big improvement over stock, with only 150-170W max!
     
    hmscott likes this.
  5. Uckaynotebook

    Uckaynotebook Notebook Enthusiast

    Reputations:
    0
    Messages:
    22
    Likes Received:
    13
    Trophy Points:
    6
    I think its because the voltage on vbios of the vega 56 is locked. Thats why we cant push Past 1500 mhz.
     
    valerboss and SMGJohn like this.
  6. Deks

    Deks Notebook Prophet

    Reputations:
    1,145
    Messages:
    4,771
    Likes Received:
    1,906
    Trophy Points:
    231
    You can't push it more probably because the voltage is hard-locked.
    Just be happy with the existing OC and happily move on.
     
    valerboss likes this.
  7. Deks

    Deks Notebook Prophet

    Reputations:
    1,145
    Messages:
    4,771
    Likes Received:
    1,906
    Trophy Points:
    231
    You can use Hybernate mode instead (that seems to work fine).
     
  8. bobzdar

    bobzdar Notebook Guru

    Reputations:
    0
    Messages:
    57
    Likes Received:
    36
    Trophy Points:
    26
  9. Deks

    Deks Notebook Prophet

    Reputations:
    1,145
    Messages:
    4,771
    Likes Received:
    1,906
    Trophy Points:
    231
    Guys, has anyone tried to do a clean install of the latest drivers using DDU or AMD driver removal utility with latest chipset drivers as well but in a way that you DISABLE Internet connection BEFORE you remove the existing drivers?

    Also, try disabling ULPS after doing all of that and see if that may solve the static noise problem.

    A lot of the problems can be attributed to Windows installing their own drivers once you removed the AMD ones from the system.
    I'm just curious to see if that helps.
     
    hmscott likes this.
  10. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    7,007
    Messages:
    20,427
    Likes Received:
    25,217
    Trophy Points:
    931
    Yup, I've done that many times before over the years to beat Windows Update to the install with my drivers over theirs.

    DDU booted in Safe Mode, remove the ethernet cable, boot into Windows and install the new driver(s) and then reconnect the ethernet cable.

    Sometimes Windows Update will prefer it's driver choice even after going through that, so maybe disable Windows Update before going into Safe Mode would work too.
     
Loading...

Share This Page