1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

Acer Aspire One D150 Boot Problems

Discussion in 'Acer' started by SHutchie, Mar 18, 2011.

Thread Status:
Not open for further replies.
  1. SHutchie

    SHutchie Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Hey all
    I got an Acer Aspire One D150. When I press the power button, the power button lights up, I hear the CPU fan spool up for about 2seconds, then nothing. The hard drive activity light is blank, the monitor is blank but the power button light is still illuminated. I don't even get to POST.

    However, when I hold function+escape and then press the power button it boots (~75%) of the time. Windows and everything works fine until I shut down and have to boot up again.

    I googled and thought it may be a corrupted BIOS, so I updated the BIOS to the latest version (1.13) and the problem persists.

    Press power button - no go.
    Hold fn+esc - go most of the time.

    Any ideas what could cause this?
     
  2. downloads

    downloads Super Moderator Super Moderator

    Reputations:
    6,279
    Messages:
    7,712
    Likes Received:
    599
    Trophy Points:
    281
    Try exchanging CMOS battery with a new one.
    That most likely will require you to dismantle the netbook.
     
  3. SHutchie

    SHutchie Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Is it a 2032 battery?
     
  4. downloads

    downloads Super Moderator Super Moderator

    Reputations:
    6,279
    Messages:
    7,712
    Likes Received:
    599
    Trophy Points:
    281
    It's probably not just a battery- like it would be on a desktop mobo.
    This will most likely look something like this but I can't see it anywhere here.
     
  5. SHutchie

    SHutchie Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    I assume this it in the bottom right corner?
    [​IMG]
     
  6. SHutchie

    SHutchie Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Cancel that. That is the internal speaker.

    From the site you sent me (which I was already using for disassembly):

    [​IMG]

    Is it possible that is it in the bottom right?
     
  7. downloads

    downloads Super Moderator Super Moderator

    Reputations:
    6,279
    Messages:
    7,712
    Likes Received:
    599
    Trophy Points:
    281
    No. It's- unfortunately- soldiered to the mobo.
    It's here:

    [​IMG]
     
  8. SHutchie

    SHutchie Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Yep, noticed that and noticed it was soldered.

    I reassmebled and now the power button is getting it to boot up 1 in every 2-3 tries. However, the power switch LED no longer works :S. Any idea which cable that is?

    It was the mini track cable top right just under the keyboard that wasn't properly plugged and was responsible for the power button LED.

    However, same boot problem. Boots every 1 - 5 tries. Anything else I can try? Maybe downgrade BIOS to a early version?
     
  9. prikolchik

    prikolchik Notebook Evangelist

    Reputations:
    255
    Messages:
    362
    Likes Received:
    0
    Trophy Points:
    30
    I am just speculating, but I think the difference between booting with power button vs booting with Fn+ESC, is that Fn+ESC is a BIOS recovery hot key and it boots your laptop from a bootblock and probably skips some BIOS checks. Perhaps, when you boot off the power button, BIOS is waiting for a signal from every device to say "I am ok, continue booting" and one of the devices doesn't return this signal and the BIOS ends up waiting for it and never completes POST. I am just guessing here.


    I was fixing a Toshiba Satellite M70 and it had have somewhat similar behaviour. Here are the things you can do:

    1. Reset CMOS to defaults. There is a "hardware gap" or a jumper you can short to reset BIOS to defaults (this information can be found in the service manual for your netbook). That is the best way to go, but alternatively you can try "Load Default Settings" in the BIOS.

    2. If that doesn't help, take apart notebook and only keep as little components as possible plugged into the motherboard. Use a known working stick of RAM (as your RAM could be a problem here). For example, keep only motherboard, RAM and internal/external display. Try turning it on. Even without the keyboard, bluetooth, touchpad, etc, it should still boot. If all works great every time, keep adding components and trying to turn it on. The goal is to figure out what makes you laptop not boot via the power button. Once you figure out what it is, you can always replace it.

    3. I doubt that is the problem, but you could try different BIOS versions.

    In the Toshiba I was repairing, the problem was 1) dried coffee on the motherboard 2) dried coffee inside the touchpad button board connector. Once I cleaned the coffee off the motherboard and disconnected the touchpad -- the laptop could boot up from the first try in 100% of the cases.

    Also, I really doubt it is the CMOS battery. You could try measuring the battery's charge with a voltmeter just to be sure.
     
  10. Markoya

    Markoya Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    can you teach me how this kind of problem.?? thanks

    is anyone help me how to fixed this problem?? acer aspire 5750
     

Thread Status:
Not open for further replies.

Share This Page