Acer Aspire 8940g, trying to upgrade graphic card.

Discussion in 'Acer' started by FrEaZeR, Jun 2, 2018.

  1. FrEaZeR

    FrEaZeR Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Hey , i own 2x 8940g , one of them bought it new since it came out and the other got it recently from ebay.de USED(for testing and parts) .

    So far i tried an Nvidia Quadro M1000M 2GB GDDR5 (from DELL laptop) - laptop is booting normally (i can hear the windows startup sound) but the screen stays black .

    Second try , with an Nvidia Quadro M1200 4GB GDDR5 (DELL laptop) - same thing as the first card .


    My aim is M2200(if i'll find one to buy) > M1200 > M1000M .

    Any advice or help to get this done ?

    Thank you .
     
    Last edited: Jun 2, 2018
  2. Grant B Gibson

    Grant B Gibson Notebook Deity

    Reputations:
    278
    Messages:
    1,374
    Likes Received:
    560
    Trophy Points:
    131
    Have you tried using an external screen? The issue seems to be an issue initializing the internal screen
     
  3. FrEaZeR

    FrEaZeR Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    yes , i tried and no signal .

    Going to try one more M1200 and M2200(seems like i found one) , and i think both of them and the other 2 will go to sale 50% off.
     
  4. Grant B Gibson

    Grant B Gibson Notebook Deity

    Reputations:
    278
    Messages:
    1,374
    Likes Received:
    560
    Trophy Points:
    131
  5. FrEaZeR

    FrEaZeR Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    That is where i got the info for Nvidia Quadro , it was supposed to be a "plug&play" , but it pretty much seems like not .
    gonna come back after trying the other 2 cards .
     
  6. FrEaZeR

    FrEaZeR Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Just tried another card . Nvidia GTX 460M , this time the screen does turn on , but the laptop doesn't seem to detect it .
     
  7. Grant B Gibson

    Grant B Gibson Notebook Deity

    Reputations:
    278
    Messages:
    1,374
    Likes Received:
    560
    Trophy Points:
    131
    Wow, that's a really old card
     
  8. Punk_Oll

    Punk_Oll Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Well I did get the fire pro m4000 to work and I have just sent an offer on a w5170m on ebay that I am going to try on my 8935g,
    also I found a website http://www.tulembedded.com/products_detail.asp?id=68 which looks interesting about mxm upgrades.

    quick update just got the W5170m (dell bios) off ebay so I shall post back once I have it installed
     
    Last edited: Jul 6, 2018
  9. Punk_Oll

    Punk_Oll Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    yep yep it installed just fine boots and shows in BIOS works in Windows but for the life of me I cannot get anything on the internal display, it only shows on HDMI out
    I'm wondering if there is someway of forcing the card to initiate the internal display? the m4000 worked p&p
     
  10. Grant B Gibson

    Grant B Gibson Notebook Deity

    Reputations:
    278
    Messages:
    1,374
    Likes Received:
    560
    Trophy Points:
    131
    Maybe it needs a modified driver, thats what seems to be the issue, as it posts in BIOS. I don't know where to get one or how to manufacture a modified driver, but maybe someone can help you out
     
Loading...

Share This Page