Acer 4752G: Boot screen hangs; Cannot enter bios setup / boot menu

Discussion in 'Acer' started by mucaaco, Nov 24, 2011.

Thread Status:
Not open for further replies.
  1. mucaaco

    mucaaco Newbie

    Likes Received:
    Trophy Points:
    Hi, I have an Acer Aspire 4752G, which my brother bought about 2 months ago in Dubai and shipped here in Philippines. The problem started when i was making the laptop dual boot Windows 7 with Linux Mint. I successfully installed Linux mint but I used Easybcd to edit the boot loader so that the grub will be recognized in the windows boot loader. I restarted then poof! The system cannot boot anymore. I may have messed up with the MBR and partitions in the hard disk.

    Here's what happened. When I power on the laptop, the boot screen shows up, with the progress bar below, moves up to 75%. When I press F2 or F12, is says waiting.... But the progress bar doesn't go 100%. I tried waiting up to about 30 minutes but there's no luck, the system won't let mo go to setup bios or boot menu. I tried removing the hard disk ang booting it but the same problem occurs.

    I have read in the forums about the crysisdisk and tried it many times using different versions. But i can't make it work. I used 1gb Sandisk and followed these steps:

    1) Download Crisis Disk maker.
    2) Create Crisis Disk using WINCRIS (need a floppy disk or usb pen drive/usb flash drive).
    3) Remember to replaced the "BIOS.WPH" file with yours. It is important to rename the BIOS file to "BIOS.WPH".(I got the ROM from Acer support)
    4) Make sure the battery and the power cord are connected to the laptop. Also laptop need to be in power-off state.
    5) Hold in Fn+Esc and then press the power button (without releasing Fn+Esc key).
    6) The USB floppy drive/pen drive/flash drive light will flash as it reads the BIOS file from the disk. You can release Fn+Esc key.

    But there's no progress. When I press fn + esc, and then the power button, the system responds by not turning on the display. The dvd drive spins for a moment, followed by short blinks in flash drive, but the power button does not blink. After waiting for about 20 minutes, the system does not restart. When I turn it off manually by long press power button and powering it again, the startup screen is still the same as before. I thought of using usb floppy but my BIOS.WPH is about 2MB and it won't fit in floppy.

    Can you suggest me anything I can do?

    I don't know if my laptop is UEFI based but from the startup screen I can see that my BIOS is from Phoenix technology.

    By the way here is my system specs:
    Intel Corei5-2430M 2.4GHz
    Intel HD and Nvidia Gforce Gt520M
    4GB ram DDR3
    WD Hard disk 500GB.
    DVD drive
    Card reader.

    Thank you for helping me out. :)
Thread Status:
Not open for further replies.

Share This Page