A lot of typos on MacBook Pro

Discussion in 'Apple and Mac OS X' started by improwise, Apr 25, 2008.

Thread Status:
Not open for further replies.
  1. cathy

    cathy Notebook Evangelist

    Reputations:
    47
    Messages:
    551
    Likes Received:
    0
    Trophy Points:
    30
    I don't really have any problems with my MBP keyboard. In the past I used mainly Logitect keyboards btw. The main issue I have is that my Caps Lock key has to be pressed harder than the rest of my keys to register, but it's not at all a big thing. Other than that would be the Fn, Ctrl, Alt, Command keys being swapped around.
     
  2. jjfcpa

    jjfcpa Notebook Evangelist

    Reputations:
    15
    Messages:
    418
    Likes Received:
    0
    Trophy Points:
    30

    I've been running into this quite a bit lately, but what happens to me is that I'll be typing and the mouse cursor will jump to another part of my text. Since I just enabled "tap to click" in the system preferences, I determined that it was my accidental taping of the trackpad that was causing the problem and disabled this option again. Seems like that fixed it because it's not happening any more.

    Check out the system preferences because that are a lot of settings that could be causing this problem - especially those related to the trackpad.
     
  3. codeoverride

    codeoverride Notebook Evangelist

    Reputations:
    40
    Messages:
    327
    Likes Received:
    0
    Trophy Points:
    30
    I experience more typos and keys not registering with my MBP as well. I think that it's just the keyboard layout and key sensitivity and not a hardware problem. I personally preferred the Dell notebook keyboard.. oh well.. guess nothing is perfect :rolleyes:
     
  4. asmallchild

    asmallchild Notebook Consultant

    Reputations:
    3
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    30
    I haven't noticed too many typos. (Then again, I type fairly fast and make plenty of mistakes normally anyway so this is about my baseline)

    If you are having a significant problem, I'd recommend taking it to the Apple Store and getting it checked out.
     
  5. hollownail

    hollownail Individual 11

    Reputations:
    374
    Messages:
    2,916
    Likes Received:
    0
    Trophy Points:
    55
    Yup... I hate that. It's like, you accidently click the mouse by putting pressure on the palm rests.

    They really should reinforce the palm rest :-/
     
  6. count_schemula

    count_schemula Notebook Deity

    Reputations:
    331
    Messages:
    1,445
    Likes Received:
    0
    Trophy Points:
    55
    essential in my opinion...
     
  7. hollownail

    hollownail Individual 11

    Reputations:
    374
    Messages:
    2,916
    Likes Received:
    0
    Trophy Points:
    55
    Yeah... but that doesn't fix the issue of the clicks.

    Accidental trackpad input will take care of moving the cursor... maybe accidental tap clicks (i have that turned off).

    but it will not help when you put a bit too much pressure on the palm rest and it clicks the mouse.
     
  8. jjahshik32

    jjahshik32 Notebook Deity

    Reputations:
    78
    Messages:
    1,333
    Likes Received:
    0
    Trophy Points:
    55
    Yea the 17" hi res mbp I had some keys wont register.. but for some reason the 15" mbp I have no problems with the keyboard and types very well.
     
  9. burningrave101

    burningrave101 Notebook Deity

    Reputations:
    109
    Messages:
    756
    Likes Received:
    0
    Trophy Points:
    30
    For some commands it just requires using a keyboard shortcut instead of a single key. For delete hit Command + Delete.
     
  10. burningrave101

    burningrave101 Notebook Deity

    Reputations:
    109
    Messages:
    756
    Likes Received:
    0
    Trophy Points:
    30
    I don't even see the option. Where is it at?
     
Loading...
Thread Status:
Not open for further replies.

Share This Page