980m on Clevo P370EM / Sager NP9370

Discussion in 'Sager and Clevo' started by SirShade, Jul 9, 2017.

Thread Status:
Not open for further replies.
  1. SirShade

    SirShade Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    4
    Trophy Points:
    6
    Hello
    Recently i upgraded my GPU from a nvidia 680m to a 980m

    Everything works fine except the laptop is not recognizing the GPU

    I know that prema had mods for the bios and vBios but his website is closed
    Dose anyone still have the bios and vBios for this model or infos for an alternative?


    ! windows key on the left, FN on the right

    update: tried prema 2t ver bios, flashed the vbios with a few roms that i found on another forum, bios mentions slot is empty and nvidia driver will not still install (with modified inf file also)
    -main issue from the beginning bios cant see the gpu and nvidia drivers dont install
    Hope you guys can help
     

    Attached Files:

  2. bennyg

    bennyg Notebook Virtuoso

    Reputations:
    1,552
    Messages:
    2,353
    Likes Received:
    2,349
    Trophy Points:
    181
    Are you sure you disabled driver signature enforcement

    That is *exactly* what it looked like when I tried to install the modded INF driver without disabling DSE first

    also check your PM :)
     
  3. SirShade

    SirShade Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    4
    Trophy Points:
    6
    yes i did
    i believe this is the command
    bcdedit.exe /set nointegritychecks on
    -but correct me if something is wrong
     

    Attached Files:

  4. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,566
    Messages:
    53,429
    Likes Received:
    15,377
    Trophy Points:
    931
    Do an advanced restart (shift click restart for the shortcut) and select driver signing enforcement to be sure.
     
  5. SirShade

    SirShade Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    4
    Trophy Points:
    6
    yep did it already
     
  6. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,566
    Messages:
    53,429
    Likes Received:
    15,377
    Trophy Points:
    931
    Try some older drivers first.
     
  7. SirShade

    SirShade Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    4
    Trophy Points:
    6
    also did this till .30 with nvidia drivers
     
  8. yotano21

    yotano21 Notebook Evangelist

    Reputations:
    67
    Messages:
    570
    Likes Received:
    332
    Trophy Points:
    76
    Go get a new laptop, problem solved.
     
  9. Omgzpwnd

    Omgzpwnd Notebook Enthusiast

    Reputations:
    2
    Messages:
    12
    Likes Received:
    2
    Trophy Points:
    6
    Keep such ideas to yourself. Thanks.
     
    yeoldegamer1979 likes this.
  10. SirShade

    SirShade Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    4
    Trophy Points:
    6
    Success!
    -here is how i got it to work In win 10 only
    -with nvidia driver ver 382.05 (tried 382.33 also, among others, but nope)

    You will need
    -the files that my new bff posted above
    -DDU (use it every time (in safe mode) you install or fail to install the driver)
    -These commands brings win 10 in test mode and the other gets you out after you get it working
    bcdedit /set testsigning on
    bcdedit /set testsigning off

    The process:
    1 Activate test mode (CMD with admin priv)
    2 Use DDU (clean it and restart)
    3 restart in with no driver signature for win 10(you can find this info online)
    After you pasted the .inf files in the nvidia driver folder c:\nvidia\International\Display.Driver
    -I had some errors here so i copied the international folder from C: drive to D and pasted the .inf files there and installed it from there also, but do step 2 with ddu to clean the files in C before install from D
    4 right click nvidia driver .exe in the international folder in D and run with admin
    privileges
    5 it should work, now disable test mode in win 10

    Tuk me a few tries (3) before it worked

    I also have premamod bios v2_2T on it, with the prema bios V2 did not work

    the god damn funny part is that it works with the orig vbios only (that i backed up beforehand)
    flashed the vbios 150+ times with compatible roms ! to exclude other variables


    I like to thank everyone for all the feedback
     

    Attached Files:

    t456 and sicily428 like this.
Loading...
Thread Status:
Not open for further replies.

Share This Page