980M (non SLI) Driver for AW18

Discussion in 'Alienware 18 and M18x' started by DoubleHelixx, Aug 22, 2020.

  1. DoubleHelixx

    DoubleHelixx Notebook Guru

    Reputations:
    2
    Messages:
    50
    Likes Received:
    15
    Trophy Points:
    16
    Hello!

    I just upgraded my CPU, RAM, GPU and SSD: 4940MX, 16GB DDR3L 2130, Nvidia 980M and EVO 860 Pro 1TB.

    I've installed a clean copy off Windows 10. I ran a clean and restart of DDU in safe mode, rebooted with Driver Signature Enforcement disabled.

    I'm getting Driver Failed error when trying to install the Eurocom 9xx driver "18_9xxM_378.49_W10". I've tried 3 times and the same error comes right up every time.

    Any advice would be greatly appreciated!
     
  2. DoubleHelixx

    DoubleHelixx Notebook Guru

    Reputations:
    2
    Messages:
    50
    Likes Received:
    15
    Trophy Points:
    16
    ahhh...nevermind. I went to Windows update and to my surprise it automatically installed a working driver? Wonders will never cease.
     
  3. Leomn

    Leomn Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    6
    Hi.
    I have Aw18 Sli version. Came with dual Gtx 765m.
    I'm upgrading to a single Gtx 980m, but having difficult times with it.
    Even the driver that windows update installed, give me problems. Laptop freezes at starting windows.
    4 times it could load windows normally, but started Gpuz and the system freezes again.
    2 times, I've started a Gpu stress test and it ran for 20 to 30 seconds, temperature of the gpu in 75°c but than it freezes again...

    Did you had any problem like this??
    Wich driver are you using now?

    Any tip will be really appreciate
     
  4. Maxware79

    Maxware79 Notebook Deity

    Reputations:
    158
    Messages:
    1,017
    Likes Received:
    688
    Trophy Points:
    131
    Do you know if the GPU fan spins at all? If not, can you run the ePSA diagnostic and see if the GPU fan spins for the test?

    Can you also use GPU-Z to see what the GPU vBIOS version is? Post what it says on here. Hopefully you can get it before it freezes or try in SG mode.

    There is a chance that your 980M was pulled from another 18 but from the slave port. If it has, then it will need a new vBIOS flashed or it won't work properly and you also won't get fan control and the card will overheat.
     
  5. Leomn

    Leomn Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    6
    Hi. Thx for the reply.
    Yes, the fan spins.
    Started the diagnostics and gpu 1 and 2 fans spins (secondary gpu is empty).

    I'm with the A12 unlocked Bios.

    If I go PGE mode (discrete card only, I have pink stripes all over).
    With SG mode (intel and nvidia gpu), when windows starts loading, it freezes with black screen.
    Only way to load windows normally, is booting into safe mode and remove mvidia drivers with DDU.
    Then, I can load windows 10 with no problem.
    Just did a fresh install now, and windows 10 loaded with no problems. When I tried do open gpuz for the first time, no problem too.
    Rebooted to see if it was going to load w10 normally, it did, but when tried to open gpuz again, screen freezed....

    Bios with 00.12 is the original bios that came with the gpu
    The other with 0D is the new one that I flashed. Found it in Dell website, with the Vbios flash for 980m sli Viking model (AW18). Whem unzipped, gave me to .rom files. Ng16x primary and secondary. I flashed the primary.
    Same problem too..
     

    Attached Files:

  6. Maxware79

    Maxware79 Notebook Deity

    Reputations:
    158
    Messages:
    1,017
    Likes Received:
    688
    Trophy Points:
    131
    If you're getting pink strips then my guess is that the GPU is on it's way to the grave.
     
  7. Mastersbest

    Mastersbest Notebook Geek

    Reputations:
    2
    Messages:
    79
    Likes Received:
    15
    Trophy Points:
    16
    Yes, I say this is not a video chip, I had it this memory flies off some of the 16 pieces, I am engaged in repair and not for the first time I see it.
     
  8. Leomn

    Leomn Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    6
    But when I uninstall the drivers, that pink stripes don't happen.. I was thinking it was problem with drivers. Ocasionally, I can boot with no problem, but when I try to run any gpu test, it freezes.
    I've runned the gpuz test one time for about 1 min and 20 seconds. Nothing happend..
    Than, tried to run furmark and then screen freezed. But the pink stripes only in boot.
    I've attached a picture from the end of the gpuz stress test.
     

    Attached Files:

  9. Maxware79

    Maxware79 Notebook Deity

    Reputations:
    158
    Messages:
    1,017
    Likes Received:
    688
    Trophy Points:
    131
    Without a driver, the GPU works with just basic functions. The driver is what unleashes the power of the card. This is why you'd only be getting issues when the driver is installed. I have a bunch of cards that run without a driver and are cactus once the driver is installed.
    What driver version did you get to install?
     
  10. Leomn

    Leomn Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    6
    Well, windows update install a a March, 7, 2018 driver at first. It gives me problems too. But sometimes, it works. When worked, I've then installed the las ones from downloaded direct from Nvidia, December, 2020. Sometimes, it works, sometimes, don't..
    I was thinking to test Prema v2 bios on it, from what I read it, it works with nvidia drivers, but couldn't find the bios, and got no clue how to contact him..
     
Loading...

Share This Page