970M Stock vBIOS

Discussion in 'Razer' started by Habulda, Mar 15, 2018.

  1. Habulda

    Habulda Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    4
    Trophy Points:
    6
    Hello, so I tried to flash a custom vBIOS for my 970m 2016 Blade and it did not work out. I made a backup of the default vBIOS but when I was cleaning out the other ones that I made I accidentally deleted it. Can someone upload their vBIOS or lead me to where I can find one that works? I flashed a Clevo vBIOS so I could get my graphics card to at least not give me constant errors but its capped at 405mHz. Any help is appreciated thanks.

    PS - if anyone also has an unlocked vBIOS for 970m that would be great too.
     
  2. t456

    t456 1977-09-05, 12:56:00 UTC Moderator

    Reputations:
    1,240
    Messages:
    2,302
    Likes Received:
    1,530
    Trophy Points:
    181
    Seem to have three versions, one of them might be unlocked:
    GTX 970M vbioses.7z

    None of them are Razer and didn't test any of them, so flash at your own peril :vboops: .
     
    Vistar Shook and Vasudev like this.
  3. Habulda

    Habulda Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    4
    Trophy Points:
    6
    I tried to flash all of them but I keep getting BoardID mismatch errors. I tried using different version of NVFlash and I tried skipping ID mismatch and nothing seemed to work. Do you have any sugestion on what else I could try?
     
  4. KY_BULLET

    KY_BULLET Notebook Evangelist

    Reputations:
    650
    Messages:
    631
    Likes Received:
    744
    Trophy Points:
    106
    Vasudev likes this.
  5. Habulda

    Habulda Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    4
    Trophy Points:
    6
    Yeah I checked that page. I don't think the 3GB will work since I have 6GB. I tried the 6GB Clevo one and it flashed fine and had no error, but it's capping my core clock to 405 and my mem clock to 810. I didn't try the MSI one yet though.
     
    KY_BULLET likes this.
  6. t456

    t456 1977-09-05, 12:56:00 UTC Moderator

    Reputations:
    1,240
    Messages:
    2,302
    Likes Received:
    1,530
    Trophy Points:
    181
    Did you use both '-5' and '-6'? And the eeprom might've been locked after the earlier flash, so perhaps use '-r' first in order to remove the write-protect from the chip.
     
    Vasudev likes this.
  7. Habulda

    Habulda Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    4
    Trophy Points:
    6
    When I type anything other than -6, it shows the list of possible commands I can execute. Now, the problem also got worse. It keeps saying that the "nvflash driver cannot be installed".
     
  8. t456

    t456 1977-09-05, 12:56:00 UTC Moderator

    Reputations:
    1,240
    Messages:
    2,302
    Likes Received:
    1,530
    Trophy Points:
    181
    Weird. You're trying from within DOS, right? And could you upload the Clevo version somewhere? We might modify the 405MHz entry to something more amiable.
     
    Vasudev likes this.
  9. Habulda

    Habulda Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    4
    Trophy Points:
    6
    Sorry for not replying, I got busy. But I got the problem fixed. I had a user from the techniferno forums help me (Klem)
    The biggest problem that I had faced was that I kept getting a board id mismatch. I tried different version of nvflash, but in the end, only 1.99 worked fine.
    It asked to overwrite the id, and then flashed the bios. I'm happily back to stock 970m, and it's even unlocked. Already tried overlcoking and everything seems to be going well.
    For those who want unlocked bios, I am attaching it here. If you find this useful, support the guy who helped me : https://goo.gl/DxyK55
    Thanks for the help, if anyone has any questions, I'd be happy to assist. Cheers
     

    Attached Files:

    t456 and KY_BULLET like this.
Loading...

Share This Page