8560w GPU upgrade - use empty DVD slot to fit MXM 3.0b (higher spec) video cards

Discussion in 'HP Business Class Notebooks' started by nickelaus, Dec 31, 2014.

  1. PATRICK NDZENGUE

    PATRICK NDZENGUE Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    6
    Hey guys. Please will this card work on my 8560w?hd 7870m
     
  2. AlleyKat

    AlleyKat Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    6
    hello all! recently purchased an 8560w with i5 2540m/8GB/FirePro M5950 locally with the intention of upgrading the GPU, a decision partially informed thanks to the excellent research y'all have done in this thread. I have an MXM 3a FirePro M5100 (this one, precisely) just arrived in the post and I'm going to give it a try once i've done some benchmarking with the stock GPU and am satisfied the system is running well. (Windows 8.1 x64 by the way)
    I also have a FirePro M6100( one of these) on the way as well as a 230W Delta AC adapter to try the mod for myself- I've been working on a custom heatsink solution for the expansion bay and I will be sure to post what I come up with!
     
    Last edited: Jul 6, 2018
    AlienHack and triturbo like this.
  3. AlleyKat

    AlleyKat Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    6
    Tried both the M5100 and M6100 and neither want to work. M5100 doesn't show anything on the LCD (even when I shine a light at it) and VGA monitor detects a signal but there's no image. M6100 lights the LCD backlight but no image and no signal from VGA.

    Thoughts: I see that at least some of the panels in the Dell laptops these cards came out of (7510 & M6800) are eDP, is it possible one or both of these cards can't output LVDS? I forgot to check that before ordering :(

    I'm going to figure out how to blindly install drivers, and if that doesn't work I'll need to decide whether to attempt a blind VBIOS flash or to return the cards and try something else.

    There are so many BIOS versions out there for both cards, how to choose which to try?
     
  4. AlleyKat

    AlleyKat Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    6
    so the plot thickens, perhaps: I enabled Remote Desktop on the 8560w and tested with the FirePro M5950 that the system would come up unattended, even with the internal keyboard and trackpad disconnected (to allow faster GPU swapping). Works fine. Try the M5100 and M6100 and nothing, RDP on my other laptop can't find the host. Put the M5950 back in, RDP works again. I also tried reconnecting the laptop keyboard and hitting F1 on boot in case it was halting on an error but no change- seems like Windows isn't coming up for some reason and likely the system isn't booting at all. I don't think this laptop likes these particular cards much.
     
  5. silverchairbg

    silverchairbg Notebook Enthusiast

    Reputations:
    0
    Messages:
    31
    Likes Received:
    7
    Trophy Points:
    16
    Hi guys,

    I've just upgraded from 8560w to Zbook 15 G2 QHD+ (3200 x 1800) and moved the GTX 965m to my new machine. However the laptop display would never light up. The laptop boots successfully, I can hear the Windows 10 loading sound, but screen is black. Putting bright light against it (like I did on the 8560w) does not show any signs of life. When I connect the laptop to a docking station, then the external monitor lights up successfully and I can login successfully, install the Nvidia modified drivers for this laptop and the GTX 965m is recognized successfully. However as soon as I undock the laptop, its display never light up, even after the modified drivers have been installed. Already watched this video () and I thoroughly checked BIOS, but this variation Zbook does not appear to have Hybrid graphics option in it.

    I would appreciate any help I could get on this, as I was going to primary use this as laptop and only occasionally dock it. @ChanceJackson

    Regards
     
  6. AlienHack

    AlienHack Notebook Evangelist

    Reputations:
    51
    Messages:
    477
    Likes Received:
    69
    Trophy Points:
    41
    hmmm thats a strange one...
     
  7. AlleyKat

    AlleyKat Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    6
    Maybe I'm remembering wrong, but I think i saw that the zBooks use eDP cards instead of LVDS(?). maybe the card isn't outputting the type of signal the panel wants?
     
  8. silverchairbg

    silverchairbg Notebook Enthusiast

    Reputations:
    0
    Messages:
    31
    Likes Received:
    7
    Trophy Points:
    16
    @AlleyKat I am sick of this HP sh*t. You might be on to something .. since the k2100m came with zbooks and was successfully upgraded in both 8560w and 8570w with standard (non Dreamcolor) screens, I assumed it is using lvds and all would be fine. I just added the k2100m from the Zbook to my 8560w to test this theory and guess what - no screen, this time permanently, no laptop screen, no external monitor screen. I found this topic:

    http://forum.hpfocus.com/viewtopic.php?t=3599

    where people comment that k2100m can output both eDP and lvds depending on the vbios. Could the same be applied to the GTX 965m? Or I am out of luck and should aim for 1050Ti or P1000? I cannot find any of those on ebay or amazon ..
     
  9. AlienHack

    AlienHack Notebook Evangelist

    Reputations:
    51
    Messages:
    477
    Likes Received:
    69
    Trophy Points:
    41
    in your zbook what kind of bios setting ou have? true UEFI? legacy?
    depending on your cards vbios it might only work in true uefi (if its edp ) or only legacy mode (if its lvds)
     
  10. silverchairbg

    silverchairbg Notebook Enthusiast

    Reputations:
    0
    Messages:
    31
    Likes Received:
    7
    Trophy Points:
    16
    @AlienHack no, UEFI is not relevant here .. it's legacy on both 8560w and Zbook and has been ever since I have them. It's just neither of the 2 graphic cards work on the other machine. I never would have thought the k2100m would not fire up on the 8560w, having in mind how many people have made that conversion. I am still hoping a vbios reflash could be a solution, cause I don't have any other options at the moment (can't find GTX 1050Ti Type A card or P1000 card). Quite frankly I would prefer the latter. I still hope for @ChanceJackson to jump in and make me look like a morron with a simple solution.
     
Loading...

Share This Page