7970M Dim Screen Fix on R3, Sort Of....

Discussion in 'Alienware 17 and M17x' started by SkylineLvr, Jul 22, 2012.

Thread Status:
Not open for further replies.
  1. SkylineLvr

    SkylineLvr Notebook Deity

    Reputations:
    441
    Messages:
    884
    Likes Received:
    196
    Trophy Points:
    56
    While trying to get switching to work and failing at it, I decided to just give up. Since I didn't like the screen dim issue, I reinstalled HWiNFO64. I had to do a clean install of Windows (don't remember why), and just used the newest version of HWiNFO64. When it loaded up, my screen stayed dim. This was strange because before I did a clean install, HWiNFO64 would brighten my screen up.

    I realized that previously I used an older version, version 3.96-1640, and it worked perfectly. I uninstalled the newest version, and reinstalled version 3.96-1640. Once it loaded up, my screen dim issue has been fixed. I remember stating a few times on some threads for others to try and run HWiNFO64 to fix their dimming issues. They reported back that it didn't work for them. I now realize that they may be using a different version. I have tried a few versions, and for some reason, only version 3.96-1640 works for me.

    I have to run HWiNFO64 every time I start up my laptop. Not too big of a hassle for those of us that can't get switching to work properly on the R3s. If you guys are having issues with the dimming, give HWiNFO64 version 3.96-1640 a try. I'm curious to see if this helps others out. Please chime in if it does or doesn't.

    You can download the portable version here or the installer here. I did a google search, and these are the only 2 sites that still have this version up. The second site is in Polish, but all you have to do is click on the orange download button. I hope I'm not breaking any rules posting these links.

    Edit: I've uploaded the file on MediaFire. HWiNFO64 3.96
     
    reborn2003 likes this.
  2. juliant

    juliant Notebook Deity

    Reputations:
    1,015
    Messages:
    1,409
    Likes Received:
    27
    Trophy Points:
    66
    I must agree with you that if you have only the AMD 7970m enabled on the R3 and you remove the driver (control panel remove all amd drivers / driver sweeper / ccleaner) reinstall the latest AMD driver and have the only version you mentioned of the hdinfo the brightness does go up at 100%. Great fix, thank you +rep. Don't you love this forum?! :)
     
    reborn2003 likes this.
  3. SkylineLvr

    SkylineLvr Notebook Deity

    Reputations:
    441
    Messages:
    884
    Likes Received:
    196
    Trophy Points:
    56
    No matter what I did, I always ended up having 2 monitors showing. So I just said forget it and disabled the iGPU. Hopefully I'll be able to figure it out sooner or later.
     
  4. Alienware-L_Porras

    Alienware-L_Porras Company Representative

    Reputations:
    3,658
    Messages:
    6,874
    Likes Received:
    968
    Trophy Points:
    281
    Great Stuff! Thanks for the fix. +1Rep. Hopefully lots of people will see it and have their computers running at 100%.
     
  5. GeoCake

    GeoCake http://ted.ph

    Reputations:
    1,491
    Messages:
    1,232
    Likes Received:
    2
    Trophy Points:
    56
    Easiest fix so far. Any chance you can upload the program to mediafire or some other file host just in case?

    Rep.
     
    reborn2003 likes this.
  6. SlickDude80

    SlickDude80 Notebook Prophet

    Reputations:
    3,262
    Messages:
    4,997
    Likes Received:
    3
    Trophy Points:
    106
    thanks for posting this Sky...I'll rep when i get home

    Sent from my SGH-T989D using Tapatalk 2
     
    reborn2003 likes this.
  7. SkylineLvr

    SkylineLvr Notebook Deity

    Reputations:
    441
    Messages:
    884
    Likes Received:
    196
    Trophy Points:
    56
    I'll do that after I get home from work.
     
  8. juliant

    juliant Notebook Deity

    Reputations:
    1,015
    Messages:
    1,409
    Likes Received:
    27
    Trophy Points:
    66
    Luis, that's not actually running at 100%. If you do not use your computer for a while, you will still have the dim issue until you restart hdinfo. It is a temporary fix and I hope that one of your tech team will look into releasing some kind of a driver (which I think is impossible since 7970m is not released with this model). Many will love to see the switch working on this system and make use of the IGP.
     
  9. Joe85

    Joe85 Notebook Deity

    Reputations:
    587
    Messages:
    1,024
    Likes Received:
    4
    Trophy Points:
    56
    Guys what is this dim screen issue? Will it effect me connecting to an external monitor?
     
  10. juliant

    juliant Notebook Deity

    Reputations:
    1,015
    Messages:
    1,409
    Likes Received:
    27
    Trophy Points:
    66
    The screen issue is because of turning off the IGP... We have to keep it that way until we will have a driver to fix this issue (or maybe there will never be one); most probably you should not have any problems with an external monitor, I tried it on an 50" plasma tv and it worked just fine...
     
Loading...
Thread Status:
Not open for further replies.

Share This Page