7970m and windows 10 driver installation problems

Discussion in 'Windows OS and Software' started by AoutoCooper, Nov 4, 2020.

Thread Status:
Not open for further replies.
  1. AoutoCooper

    AoutoCooper Notebook Guru

    Reputations:
    0
    Messages:
    64
    Likes Received:
    1
    Trophy Points:
    16
    hey all,
    tl;dr - installing 7970m drivers causes system to freeze up mid process, can't install them from any 9safe/normal) mode
    i know this subject's been discussed many many times across the internet but i can't seem to solve it even after sitting for about 4 hours straight just today.

    i own an NP9150 with intel 4000 and 7970m. obviously ever since a certain windows 10 update the laptop doesn't work properly, and until i uninstalled the 7970m's driver it actually wouldn't even boot up outside of safe mode.
    now i can't install the drivers again. depending on how i install them (DDU, amd's driver sweeping, safe mode, normal mode, etc) i get different errors, where the most common thing is simply the PC locking up, freezing, and requiring a hard reboot from the physical button.

    i have managed to boot up the PC normally and even play games with the 7970m on win10 with no problems a few months ago, which makes me even more stubborn to make this work.
    here's what i tried so far (didn't work obviously):
    unless i state otherwise, the driver package is 20.9.1.
    windows version: 18362

    DDU and reinstalling from normal mode and safe
    AMD driver cleaning tool and reinstalling from normal and safe
    installing catalyst driver 15.6 fails (the only "old" package i found), after both driver uninstalling tools, in safe and normal mode (says some processes "have failed" and than the installer stops responding)
    disabling and / or uninstalling "microsoft basic display adapter" and trying to reinstall the amd drivers, it install itself back after a few restarts

    i tried setting the enableULPS to 0, but i can't find that setting in the registry since i can't progress enough in the installation of AMD's drivers.

    thanks folks
     
  2. StormJumper

    StormJumper Notebook Virtuoso

    Reputations:
    579
    Messages:
    3,523
    Likes Received:
    486
    Trophy Points:
    151
    Did you check to see if there as a W7 driver first? If it was originally W7 only then you will have to W7 drivers for this to work. Unless Sager has driver for W10 then you can use that otherwise you will have to use the drivers that was only for that O/S originally.
     
  3. kothletino

    kothletino Notebook Evangelist

    Reputations:
    65
    Messages:
    304
    Likes Received:
    109
    Trophy Points:
    56
    I am afraid that your gpu is dying, and that is the reason of your problems with driver installation.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page