7590, 4K IPS screen flickering!

Discussion in 'Dell XPS and Studio XPS' started by Dan Jones, Apr 28, 2020.

  1. Dan Jones

    Dan Jones Notebook Enthusiast

    Reputations:
    7
    Messages:
    34
    Likes Received:
    3
    Trophy Points:
    16
    Hi,

    I have a brand new 7590 with the 4k IPS touch screen. But I am having a weird issue with the screen flickering.

    When on minimum/low brightness the flickering is like random drops in brightness, it seems to be triggered more often when I click on the trackpad to move a window. Its most noticeable on white.

    I tried a different charger and the issue went away, but the issue also persist to a lesser extend when on battery.

    It seems to affect the left hand side of the screen only.

    Is this normal?

    I am in the 14 days return period so I can swap it no issue.

    Thanks
     
    Last edited: May 1, 2020
  2. rchallenger

    rchallenger Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I have the same issue on my new 15" XPS 7590. It is something related to dynamic brightness adjustment. I've found this feature in Intel video driver. But even disabling it does not fix the problem. Did you manage to solve it on your own, @Dan Jones ?
     
  3. Dan Jones

    Dan Jones Notebook Enthusiast

    Reputations:
    7
    Messages:
    34
    Likes Received:
    3
    Trophy Points:
    16
    I found no software based resolution, and I tried everything.

    Even non standard video drivers and weird settings.

    Nothing fixes it.

    To Dells shame, they have refused to accept the item back.
     
  4. _sem_

    _sem_ Notebook Deity

    Reputations:
    100
    Messages:
    776
    Likes Received:
    271
    Trophy Points:
    76
    XPS 15 has a looooong history of flickering. My 9550 still flickers a bit. It didn't at the start though, it started with a certain bios update that fixed another bug.
     
  5. Dan Jones

    Dan Jones Notebook Enthusiast

    Reputations:
    7
    Messages:
    34
    Likes Received:
    3
    Trophy Points:
    16
    @_sem_, I found it very random. Sometimes it did it, other times it did not.

    Changing the charger would sometimes fix it for a few hours.

    I tried two bios versions, no difference for me.
     
Loading...

Share This Page