3820TG Owner's Lounge - Part Two

Discussion in 'Acer' started by Bronsky, Mar 13, 2011.

  1. KingSized

    KingSized Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    I just bought an Acter 3820TG with the following hardware:

    Intel Core i5-480M
    4 GB RAM
    750 GB
    AMD Radeon HD 6550M(1024 MB)
    Windows 7 Home Premium 64 Bit

    Which drivers (especially for the switchable grafics) do you recommend?
    I would love to be able to switch the grafics manually in Windows. Would be perfect to be able to turn automatic switching on/off.

    Thanks very much
     
  2. Dr. K6

    Dr. K6 Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    8
    Trophy Points:
    16
    Hey guys, somehow over the last 6 months I ended up breaking my graphics switching options (perhaps by using the modded drivers). I've tried uninstalling, sweeping, and reinstalling several drivers to no avail. Right now I have the 12.8's installed and the newest Intel drivers, and I can switch from the AMD card to the integrated intel chip, but I can't switch back. The option in the CCC completely disappears, previously it would list that I'm under the power saving GPU. Any ideas?
     
  3. Apex84

    Apex84 Notebook Consultant

    Reputations:
    10
    Messages:
    153
    Likes Received:
    0
    Trophy Points:
    30
    I can't switch back to AMD either. It works for a while after a reboot but then something seems to break it. I was on Leshcat's 12.3 when it first started happening last week so I uninstalled it and cleaned up (very thoroughly) and tried Leshcat's 12.6 which worked for a couple of hours before that something broke it. Also when this happens, the LED on the right side indicating that the Intel GPU is enabled doesn't light up. Yesterday I just gave up and switched to dedicated GPU in BIOS. Will try to fix it again sometime in the future.
     
  4. tome

    tome Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Hi,

    As posted earlier I had a dead lan board on my 3820TG. Yesterday I got the new part and today I exchanged the lan board. The first boot after the re-assembly showed the installation of the lan drivers. Lan works well now. But now I have stripe on the LCD screen which "move" when I use the touch pad. There are not permanently but come and go.

    Foto 1a.jpg

    I disassembled the 3820TG to look for bad connection etc. but found nothing. Any ideas what went wrong?

    tome
     
  5. Dr. K6

    Dr. K6 Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    8
    Trophy Points:
    16
    Yep, that's where I am. I've found I can switch back to AMD by manually enabling it in the Device Manager, but my biggest problem is that the power cutting functions aren't working, so my battery life is abysmal. I think leshcat's drivers were the culprit in my case as well. Driver sweeper cleans a lot but doesn't seem to get everything since the function is still off. Eventually I'll probably just nuke this install and reload everything when I get a moment.
     
  6. Bronsky

    Bronsky Wait and Hope.

    Reputations:
    1,653
    Messages:
    9,239
    Likes Received:
    246
    Trophy Points:
    231
    I think the shareware version of 3820Tray supports this. http://forum.notebookreview.com/acer/562583-3820tray-hardware-control-powerprofiles-cpumonitor.html

    BTW all ... I sold my 3820TG:eek:. Since we have a new mobile workstation in my office, I just didn't need the graphics power anymore. It has been a great little computer. I'll be selling my slate 500 next and picking up a new W8 tablet/notebook to use as my new portable/travel unit, probably a Microsoft Surface Pro or a Samsung S7H Hybrid. Both will have an I5ULV IB CPU and HD 4000 graphics and will be decent presentation devices. I will miss my old Acer. It was the best all-around notebook I've ever owned.
     
  7. Dr. K6

    Dr. K6 Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    8
    Trophy Points:
    16
    Wow, end of an era. Thanks for all the help and support you've given. :thumbsup:
     
  8. coltsmild

    coltsmild Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    Did anyone successfully install catalyst 12.8 with switchable graphics? It wold let me boot unless I had discrete set in bios. I had to revert to 12.7 (beta) to have switchable on.

    And Bronsky, thanks for all your help in these forums. My 3820tg wouldn't be as it is now without you.
     
  9. Ranrick

    Ranrick Notebook Enthusiast

    Reputations:
    0
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    5
    yeah same here. I installed 12.8 on discrete and when I switched back to switchable graphics, I got a bluescreen on startup.
     
  10. Lennong

    Lennong Notebook Consultant

    Reputations:
    122
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    30
    Same here, BSOD on startup.
     
Loading...

Share This Page