2020 SSD's not recognized Pre-Dell M17R1

Discussion in 'Alienware 17 and M17x' started by rrh, May 27, 2020.

  1. rrh

    rrh Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    I have the black laptop w the two drive drawers on the side, what could be easier? supposedly one could even hot-swap 2.5" SATA drives here?

    I inherited this machine from my gamer brother in law who probly paid a premium for this machine new in 2008 / 09.

    I recently upgraded / maxxed out RAM @ 8gb.

    I am running MX Linux19.1

    Bios is the final W841.B10

    It came w Seagate 160gb HDD, recently I bought 2 ssd's : Silicon Power 256gb and AData 240 but....

    Nether of these drives are recognized by either bios or system info :(

    HELP / WHAT TO DO?

    Thx
     
  2. Maxware79

    Maxware79 Notebook Deity

    Reputations:
    122
    Messages:
    801
    Likes Received:
    549
    Trophy Points:
    106
    Is your BIOS set to RAID or AHCI? Maybe it's just something simple like that.
     
  3. rrh

    rrh Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    RAID is disabled. Enable / Disable = pretty much only options unless I enable RAID.

    *** The memory doesnt show up in bios but does show up in "Quick System Info" (inxi) ... scroll to end

    Will maybe look into rolling back bios? I think this W841.B10 may have been a beta and was possibly dropped?

    Machine was built by Alienware around / but before the time the company was sold to Dell. It has Alienware s/n but no Dell service tag.

    Code:
    
    System:    Host: rrhobbs-mx-alienware Kernel: 4.19.0-6-amd64 x86_64 bits: 64 compiler: gcc 
               v: 8.3.0 
               parameters: BOOT_IMAGE=/boot/vmlinuz-4.19.0-6-amd64 
               root=UUID=cca20f14-2b90-4644-8efe-abc6a3d4ab05 ro quiet splash 
               Desktop: Xfce 4.14.2 tk: Gtk 3.24.5 info: xfce4-panel wm: xfwm4 dm: LightDM 1.26.0 
               Distro: MX-19.1_x64 patito feo October 21  2019 base: Debian GNU/Linux 10 (buster) 
    Machine:   Type: Kvm System: alienware product: Alienware M17 v: W841.B10 serial: <filter> 
               Mobo: alienware model: alienware v: alienware serial: <filter> BIOS: Intel 
               v: W841.B10 date: 10/14/2008 
    Battery:   ID-1: BAT0 charge: 17.8 Wh condition: 17.8/97.7 Wh (18%) volts: 16.5/14.8 
               model: W840 W8406450 type: Unknown serial: <filter> status: Full 
               Device-1: hid-00:1f:20:fd:98:41-battery model: Bluetooth Mouse M336/M337/M535 
               serial: N/A charge: N/A status: Full 
    CPU:       Topology: Dual Core model: Intel Core2 Duo P8400 bits: 64 type: MCP arch: Penryn 
               family: 6 model-id: 17 (23) stepping: 6 microcode: 60F L2 cache: 3072 KiB 
               flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 9044 
               Speed: 1857 MHz min/max: 1600/2266 MHz Core speeds (MHz): 1: 1857 2: 1950 
               Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
               Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled 
               Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
               Type: meltdown mitigation: PTI 
               Type: spec_store_bypass status: Vulnerable 
               Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
               Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
               Type: tsx_async_abort status: Not affected 
    Graphics:  Device-1: AMD RV670/M88 [Mobility Radeon HD 3870 X2] vendor: Rioworks driver: radeon 
               v: kernel bus ID: 03:00.0 chip ID: 1002:9509 
               Device-2: AMD RV670/M88 [Mobility Radeon HD 3870 X2] vendor: Rioworks driver: radeon 
               v: kernel bus ID: 06:00.0 chip ID: 1002:9509 
               Display: x11 server: X.Org 1.20.4 driver: radeon resolution: 1440x900~60Hz 
               OpenGL: renderer: AMD RV670 (DRM 2.50.0 / 4.19.0-6-amd64 LLVM 7.0.1) 
               v: 3.3 Mesa 18.3.6 compat-v: 3.0 direct render: Yes 
    Audio:     Device-1: Intel 82801I HD Audio vendor: Rioworks driver: snd_hda_intel v: kernel 
               bus ID: 00:1b.0 chip ID: 8086:293e 
               Device-2: AMD RV670/680 HDMI Audio [Radeon HD 3690/3800 Series] vendor: Rioworks 
               driver: snd_hda_intel v: kernel bus ID: 06:00.1 chip ID: 1002:aa18 
               Sound Server: ALSA v: k4.19.0-6-amd64 
    Network:   Device-1: Marvell 88E8055 PCI-E Gigabit Ethernet vendor: Rioworks driver: sky2 
               v: 1.30 port: 4000 bus ID: 08:00.0 chip ID: 11ab:4363 
               IF: eth0 state: down mac: <filter> 
               Device-2: Realtek RTL8187SE Wireless LAN driver: rtl818x_pci v: kernel port: 5000 
               bus ID: 09:00.0 chip ID: 10ec:8199 
               IF: wlan0 state: up mac: <filter> 
    Drives:    Local Storage: total: 149.05 GiB used: 11.27 GiB (7.6%) 
               ID-1: /dev/sda vendor: Seagate model: ST9160411ASG size: 149.05 GiB block size: 
               physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> 
               rev: DE14 scheme: MBR 
    Partition: ID-1: / raw size: 147.02 GiB size: 143.71 GiB (97.75%) used: 11.27 GiB (7.8%) 
               fs: ext4 dev: /dev/sda1 
               ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap swappiness: 15 (default 60) 
               cache pressure: 100 (default) dev: /dev/sda2 
    Sensors:   System Temperatures: cpu: 60.0 C mobo: N/A 
               Fan Speeds (RPM): N/A 
               GPU: device: radeon temp: 65 C device: radeon temp: 69 C 
    Repos:     No active apt repos in: /etc/apt/sources.list 
               Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
               1: deb http://debian.mirror.globo.tech/debian/ buster-updates main contrib non-free
               Active apt repos in: /etc/apt/sources.list.d/debian.list 
               1: deb http://debian.mirror.globo.tech/debian/ buster main contrib non-free
               2: deb http://deb.debian.org/debian-security buster/updates main contrib non-free
               Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
               1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
               Active apt repos in: /etc/apt/sources.list.d/mx.list 
               1: deb http://mx-linux-packages.mirror.globo.tech/mx/repo/ buster main non-free
               Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
               1: deb [arch=amd64] https://repo.skype.com/deb stable main
               No active apt repos in: /etc/apt/sources.list.d/various.list 
    Info:      Processes: 228 Uptime: 12m Memory: 7.79 GiB used: 1.89 GiB (24.2%) Init: SysVinit 
               v: 2.93 runlevel: 5 default: 5 Compilers: gcc: 8.3.0 alt: 8 Shell: bash v: 5.0.3 
               running in: quick-system-in inxi: 3.0.36 
    
     
  4. senso

    senso Notebook Deity

    Reputations:
    393
    Messages:
    1,304
    Likes Received:
    504
    Trophy Points:
    131
    Maybe those SSDs dont like that your laptop only has SATA2 instead of SATA3?
    Have you tried them in any other laptop/desktop?
     
  5. rrh

    rrh Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Thanks @senso / Before I bought the drives I checked; all versions of SATA are *supposed* to be 100% backward compatible, the only caveat is you are going to get SATA3 speed in a SATA system...

    I havent tried them in any other systems; I had actually bought one of the drives to go in an old Dell N-5010 laptop. When I saw the Alien had the easy swap drawers I decided to put both in the Alien.

    The N-5010 HDD is buried in the chassis; you have to to pull off all kinds of pieces to get to it: https://t.ly/L1iY (youtube teardown) .... I have done it, but....
     
Loading...

Share This Page