Quantcast Sony Vaio CW Atheros AR9285 Wireless Adapter Stopped Working

+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    Notebook Enthusiast
    Join Date
    Jan 2010
    Posts
    22
    Rep Power
    12

    Default Sony Vaio CW Atheros AR9285 Wireless Adapter Stopped Working

    Recently my Atheros wireless adapter stopped working in my laptop. I have not installed any new hardware or software. Nor have I made any changes to any settings. I have also made sure the wi-fi tab is on. When checking the device manager, the yellow exclamation mark is shown with the error message saying the drivers are not installed for the device. When I try to reinstall the drivers, afterwards it says the installation is complete however the yellow exclamation mark/error msg is still listed. I should note the device manager lists the Atheros wireless adapter as a generic name. I remember in the past it would be listed as "Atheros AR9285 Wireless Network Adapter".

    Since nothing has worked, I have tried to restore my system to a previous date. Tried multiple dates with no luck. One odd thing that I did start noticing was the device manager now recognizes the wireless adapter as an Atheros AR9285. Exclamation mark is still there, now with a new error message "This device cannot start. (code 10)". Now I'm not certain this changed after restoring to a previous date or if it changed before trying that. I have tried to update the drivers and now I get the message "The best driver software for this device is already installed. Windows has determined the driver software for this device is up to date".

    I'm starting to think maybe it's a hardware issue. Has anyone else run into this problem?

  2. #2
    Newbie
    Join Date
    Feb 2010
    Location
    Indonesia
    Posts
    4
    Rep Power
    0

    Default Re: Sony Vaio CW Atheros AR9285 Wireless Adapter Stopped Working

    hi, i have the same issues too, did you already resolve your problem?

  3. #3
    Newbie
    Join Date
    Jul 2011
    Posts
    1
    Rep Power
    0

    Default Re: Sony Vaio CW Atheros AR9285 Wireless Adapter Stopped Working

    Download the latest driver from ATHEROS drivers for Microsoft Windows

    Use "Updated Driver" option from the Device Driver "Properties" under Device Manager. (if you try to install the driver any other way, it will not work).

    When you open the "Update Driver" option, make sure you choose "Browse my computer for driver software" and then choose the location of the "inf" file that you downloaded and extracted from the provided site.

    Windows will warn you that the software is not Microsoft certified. Do you really care if it works, while the certified one does not? Accept it.

    As a final step, count down from 10 to 1 to avoid sending a hate-letter to Microsoft or the Atheros people.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -4. The time now is 04:50 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO 3.6.1